none
Unable to install LIS 4.2.4 on RHEL5.8 64bit

    Question

  • I'm unable to install LIS on RHEL 5.8 64bit, getting an following error.

    [root@ip-172-31-12-128 RHEL58]# uname -a
    Linux ip-172-31-12-128 2.6.18-308.24.1.el5xen #1 SMP Wed Nov 21 11:45:43 EST 2012 x86_64 x86_64 x86_64 GNU/Linux
    [root@ip-172-31-12-128 RHEL58]# cd ..
    [root@ip-172-31-12-128 iso]# ls
    CentOS510         CentOS55  CentOS61  CentOS67  CentOS73    Oracle67  Oracle73        RHEL53  RHEL59  RHEL65  RHEL71
    CentOS511         CentOS56  CentOS62  CentOS68  CentOS74    Oracle68  Oracle74        RHEL54  RHEL60  RHEL66  RHEL72
    CentOS511_UPDATE  CentOS57  CentOS63  CentOS69  install.sh  Oracle69  RHEL510         RHEL55  RHEL61  RHEL67  RHEL73
    CentOS52          CentOS58  CentOS64  CentOS70  Oracle64    Oracle70  RHEL511         RHEL56  RHEL62  RHEL68  RHEL74
    CentOS53          CentOS59  CentOS65  CentOS71  Oracle65    Oracle71  RHEL511_UPDATE  RHEL57  RHEL63  RHEL69  uninstall.sh
    CentOS54          CentOS60  CentOS66  CentOS72  Oracle66    Oracle72  RHEL52          RHEL58  RHEL64  RHEL70  upgrade.sh
    [root@ip-172-31-12-128 iso]# ./install.sh
    Removing Hyper-V daemons
    Invoking release specific install file in directory RHEL58
    Installing the Linux Integration Services for Microsoft Hyper-V...
    error: Failed dependencies:
            kernel < 2.6.18-309 is needed by kmod-microsoft-hyper-v-4.2.4.2-20180426.x86_64
            kernel(rhel5_kernel_ga) = 84d69198cf51b494e38d9d0a54e52607c8a507e2 is needed by kmod-microsoft-hyper-v-4.2.4.2-20180426.x86_64
            kernel(rhel5_drivers_base_ga) = 61dc730b8ca5e74017f2df5b55ecda8b7df7f9c2 is needed by kmod-microsoft-hyper-v-4.2.4.2-20180426.x86_64
            kernel(rhel5_vmlinux_ga) = 78f928da689a93ecf2e044fc0ced6b3eaedf5c19 is needed by kmod-microsoft-hyper-v-4.2.4.2-20180426.x86_64
            kernel(rhel5_fs_ga) = 1c422a6b84a2000991b1b99c61506cfd711a20d1 is needed by kmod-microsoft-hyper-v-4.2.4.2-20180426.x86_64
            kernel(rhel5_drivers_video_ga) = a2b696de763cab21944e1e98f127d6cdc163d762 is needed by kmod-microsoft-hyper-v-4.2.4.2-20180426.x86_64
            kernel(rhel5_net_core_ga) = c186a7dc043c903564c2dd9ed49d8847b7043c86 is needed by kmod-microsoft-hyper-v-4.2.4.2-20180426.x86_64
            kernel(rhel5_mm_ga) = d5edc1b3d2a4f2bf8ce28d7f4dbeab27cfeb19bd is needed by kmod-microsoft-hyper-v-4.2.4.2-20180426.x86_64
            kernel(rhel5_drivers_scsi_ga) = 1cc16b1f8996d37eaa858690bfbab7f4030c55b6 is needed by kmod-microsoft-hyper-v-4.2.4.2-20180426.x86_64
            kernel(rhel5_drivers_pci_ga) = 88a9a7f6575f2f00a7ca4ac83a9f3a2c81641290 is needed by kmod-microsoft-hyper-v-4.2.4.2-20180426.x86_64
            kernel(rhel5_net_ethernet_ga) = d17ace18cf21997af17e0b1057679e4819e5b1fc is needed by kmod-microsoft-hyper-v-4.2.4.2-20180426.x86_64
            kernel(rhel5_net_ipv4_ga) = 5f159ec8729b8777d27407ddd6cf485fa3d960f3 is needed by kmod-microsoft-hyper-v-4.2.4.2-20180426.x86_64
            kernel(rhel5_lib_ga) = ff25b583d6d314edd98f7c9533c5867194b3d30d is needed by kmod-microsoft-hyper-v-4.2.4.2-20180426.x86_64
            kernel(rhel5_drivers_scsi_u6) = e3cbe05d63f2207399321ed5a4a38719f42cd213 is needed by kmod-microsoft-hyper-v-4.2.4.2-20180426.x86_64
            kernel(rhel5_net_core_u4) = 0971fc19326374d80187da0f9e0ad6a0a44e358c is needed by kmod-microsoft-hyper-v-4.2.4.2-20180426.x86_64
            kernel(rhel5_drivers_input_ga) = 6721f62837b422dedc38ac8d1e8b4d862ec2b473 is needed by kmod-microsoft-hyper-v-4.2.4.2-20180426.x86_64
            kernel(rhel5_fs_debugfs_ga) = 805b85b7314d1d795a6ab61313070217939fb54f is needed by kmod-microsoft-hyper-v-4.2.4.2-20180426.x86_64
            kernel(rhel5_arch_x86_64_kernel_ga) = 880dbfce5086d666f5bab6ad642c0323fcdabd90 is needed by kmod-microsoft-hyper-v-4.2.4.2-20180426.x86_64
            kernel(rhel5_drivers_acpi_u4) = 2ea0b770166607af80ae50ea034caebee6a1e08a is needed by kmod-microsoft-hyper-v-4.2.4.2-20180426.x86_64
            kernel(rhel5_fs_nls_ga) = 0a7be2859d1a992e0c363811f8fd3a099a8b3ac3 is needed by kmod-microsoft-hyper-v-4.2.4.2-20180426.x86_64
            kernel(rhel5_net_sched_ga) = f59ed7ca1ff4a5999cc750181083f8e6dd78c491 is needed by kmod-microsoft-hyper-v-4.2.4.2-20180426.x86_64
            kernel(rhel5_block_ga) = 5b4effd1cc3809b4bd243e499ab6be486fd95fd9 is needed by kmod-microsoft-hyper-v-4.2.4.2-20180426.x86_64
            kernel(rhel5_drivers_char_ga) = f226911057872ff1aec3f38ff138e7004af9345d is needed by kmod-microsoft-hyper-v-4.2.4.2-20180426.x86_64
            kernel(rhel5_arch_x86_64_mm_ga) = ca7f91963b9397351659241974f92dc85546f8ca is needed by kmod-microsoft-hyper-v-4.2.4.2-20180426.x86_64
            kernel(rhel5_arch_x86_64_kernel_u2) = 12cc0c2f515fd81b2da9071974dc948e339f09cd is needed by kmod-microsoft-hyper-v-4.2.4.2-20180426.x86_64
            kernel(rhel5_drivers_xen_core_ga) = c05a8027c47f037b99169c7441da64fa0a723869 is needed by kmod-microsoft-hyper-v-4.2.4.2-20180426.x86_64
            kernel(rhel5_drivers_scsi_u5) = 241e2a61d7cdde0f97e938dea671ad6363e092fb is needed by kmod-microsoft-hyper-v-4.2.4.2-20180426.x86_64
            kernel(rhel5_kernel_module_ga) = a74a9d2bf87d13d6b9412698dc2728248ca92523 is needed by kmod-microsoft-hyper-v-4.2.4.2-20180426.x86_64
    Kmod RPM installation failed, Exiting
    [root@ip-172-31-12-128 iso]# df -hT
    Filesystem    Type    Size  Used Avail Use% Mounted on
    /dev/sda1     ext3    5.7G  2.5G  3.1G  45% /
    none         tmpfs    1.8G     0  1.8G   0% /dev/shm
    /root/LinuxIC-4.2.4-2.iso
               iso9660    486M  486M     0 100% /mnt/iso
    [root@ip-172-31-12-128 iso]# fdisk -l

    Disk /dev/sda1: 32.2 GB, 32212254720 bytes
    255 heads, 63 sectors/track, 3916 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Disk /dev/sda1 doesn't contain a valid partition table
    [root@ip-172-31-12-128 iso]#

    Kindly help.


    Thursday, May 24, 2018 7:27 AM

All replies

  • Hi there!

    According to the documentation of the Linux Integration Services (LIS) 4.2.4 the following Linux distributions are supported:

    LIS 4.2.4-2 is applicable to the following guest operating systems:
    • Red Hat Enterprise Linux 5.2-5.11 32-bit, 32-bit PAE, and 64-bit
    • Red Hat Enterprise Linux 6.0-6.9 32-bit and 64-bit
    • Red Hat Enterprise Linux 7.0-7.4 64-bit

    Hope this is useful.

    Kind regards,
    Leon


    Blog: https://thesystemcenterblog.com  LinkedIn:   

    Thursday, May 24, 2018 7:41 AM
  • Hi,

    Thank you for your reply, according to the documentation of the LIS RHEL5.8 is supported version but it is not getting installed.

    What I have seen the difference is if you choose Auto disk partition at time of the RHEL 5.8 installation then it lets you install Linux integration services.

    But if you manually configure disk partition them it will not let you install LIS.

    How we can resolve this issue.

    Thursday, May 24, 2018 11:08 AM
  • I think you are running an unsupported kernel there, as LIS 4.x supports only the distro provided kernels.

    Have you installed 2.6.18-308.24.1.el5xen from a different source?

    Wednesday, May 30, 2018 7:07 AM