none
Mapped Drives

    Question

  • Hi,

    We are currently running Windows 7 shop and starting to migrate to 10 from next year. 

    There is a Radius server configured on Server 2008 R2 with access points and a GPO that runs on all the devices to connect to Wifi automatically. Mapped drives are also configured. So when user connects with Wifi, the startup GPO does not get applied and in turn we do not see the home drives mapped. 

    But for some users, we see that there is a red x for the mapped drive and after the device is connected to WIFI, they can connect to it. But for others, we do not see the red x marked drives if they logoff/reboot the device. So what can cause this issue ? 

    Regards,V

    Wednesday, December 21, 2016 5:54 PM

All replies

  • This could be some latency in the wireless interface, when the drives are mapped the user may not be completely authenticated yet. I see this when i map drives for users that use VPN, once they connect to VPN the "x" is still there until they go to the share and it goes away and they see files. I tell most of my users if they see the red "X" they should wait and try to go there anyway. Unless there is an issue woith thier login it should still connect.
    Wednesday, December 21, 2016 6:02 PM
  • Hi - Thanks. But How do we have the red x mark still exists even if the user is not connected to network (Wifi/LAN). Since i see for some users the Red x mark drives are there even though they are not on the network (Wifi/LAN)
    Wednesday, December 21, 2016 6:20 PM
  • if you map a drive while they are connected to the network and tell it to reconnect every time, you will see the red "X" until they logon and go to the drive.

    I'm guessing that either drives were manually mapped ot the group policy is mapping them persistent, and not every time the user logs on and the group policy runs.

    Wednesday, December 21, 2016 6:54 PM
  • We use GPO for the Mapped drives. Is there a way i can stay the mapped drive as red mark even though am not connected to the network. This would help to resolve all this issues.
    Wednesday, December 21, 2016 7:28 PM
  • In the group policy where the drive is mapped there is a checkbox for "Reconnect" if there is a check in it the drive will reconnect whether group policy runs or not, uncheck and the drive will only map when group policy runs.

    If you change this setting on the existing group policy it may take some time to get to the workstations.

    the "X" will remain until you access the drive and it is avaliable to access otherwise it will show as a red "X" if the drive is accessable and mapped when you boot no red "X".

    Wednesday, December 21, 2016 7:48 PM
  • Thanks. This makes sense now for the driver mappings. How about the drive that is added to the user under Profile tab (home folder)
    Wednesday, December 21, 2016 8:00 PM
  • That one does not have a checkbox to reconnect, so my assumption would be that it will only map or show up if the drive and domain controller is avaliable when they logon.

    If you change the group policy to not reconnect and they logon no drives will map, even if the drives are avalbe after logging on.

    My belief is that the home drive mapping works the same as unchecking the reconnect on the group policy mapping.

    Wednesday, December 21, 2016 8:26 PM
  • I just checked for some of the users now and found that they have the Red Mark even though they are not on network and also no group policy changes have been done. How is it possible that it works for them and not for others ? Am really confused now
    Wednesday, December 21, 2016 8:38 PM
  • the red mark is because the group policy that applied to these computers when they were connected to the network had the "reconnect" checked, so even though they are not on the network now it has the drive mapping that reconnects, if you change your grouop policy to not reconnect it will eventually update the computers. you may have to/want to manually disconnect the mapped drives if they don't connect to the network frequently.

    If they don't ever connect to the network again the group policy will not apply more reason to manually disconnect the mapped drives.

    Wednesday, December 21, 2016 8:46 PM
  • keep in mind that if you change the group policy it may take 90 mins for it to reach and apply to computers. Even then they may need to reboot to see the change. Best to let group policy stuff set for a day before you start troubleshooting.

    If the computer is not on the LAN it will never get the group policy as it comes from the domain controller during bootup or signon depending on whether it's a computer policy or user policy.

    Wednesday, December 21, 2016 8:48 PM
  • No I did not make any GPO changes at all. That's why the confusion. How come for some users it is showing as Red x Mark and not for few of them.
    Wednesday, December 21, 2016 8:51 PM
  • users with red x are likely not on network and haven't been or on network and have not tried to access drives, users without red x likly on network at some point even briefly via LAN or VPN or something.

    Some that are red may be because they have not tried to access drive and they are on the network.

    Maybe this will help:

    1) computer turned on boots

    2) Drives set to reconnect try to reconnect during boot.

    3) if they see drive no red x if they don't see drive red x.

    4) That means if they are wireless and not connected to wireless they will not see drive they will get a red x. There is also an option here for wireless to automatically connect if that is set they may see drive if wireless is set to manually connect they may not. They may even get group policies.

    5) now they connect to wireless

    6) they access drive and red x will do away. If they don't access drive there will be a red x until they do.

    This is why I basically tell users if they need the drives and they have red x to try to connect even with the red x, if they can't get to files they need to connect to wireless/and or VPN to get drives.

    So if you unmap the drives and change the group policy to not reconnect, users that need the drive may not have them because group policy doesn't process without connectivity to domain controller, users that don't need drives will not see them. This leaves users that need access to the drives with an issue because they can't get to them, better to tell the users that don't need access to the drive to ignore the red x, and users that need access to try even with the red x.

    Wednesday, December 21, 2016 9:22 PM