locked
Outbound (Internet) Stuck in the Queue RRS feed

  • Question

  • Just implemented an exchange 2016 CU2 edge server into a 2 member DAG. Inbound email works fine. Outbound email to the internet does NOT work. The edge send connector is created and the old internet send connector is disabled. I can telnet from the edge server to the mail servers on port 25 and 2525. I can ping both mailbox servers with fqdn from the edge server and the mailbox servers can ping the edge server using fqdn. The sonicwall firewall has inbound policy - inbound from internet to public ip -> NAT to edge server private ip using smtp services of 25 and 587. Outbound policy - edge server out using public ip -> using smtp services 25 and 587. The last error from the message queue:

    --A matching connector cannot be found to route the external recipient;16;<No Matching Connector>;0

    Sunday, October 23, 2016 11:25 PM

Answers

  • Disable ipv6 on edge server and now email to gmail works.
    • Proposed as answer by David Wang_ Monday, October 24, 2016 5:43 AM
    • Marked as answer by David Wang_ Monday, October 31, 2016 5:27 AM
    Monday, October 24, 2016 2:18 AM

All replies

  • So i just tried to send a test message using telnet from mailbox server to edge server and received:

    550 5.7.54 SMTP; Unable to relay recipient in non-accepted domain

    >get-receiveconnector (on edge server)

    Identity                                           Bindings     Enabled
    --------                                           --------     -------
    Edgeserver\Default internal receive connector EDGESERVER {0.0.0.0:25} True

    On a mailbox server:

    [PS] C:\Windows\system32>Test-EdgeSynchronization


    RunspaceId                  : 13b0b521-1930-49ab-9418-ba9e0e391a00
    SyncStatus                  : Normal
    UtcNow                      : 10/24/2016 12:19:42 AM
    Name                        : Edgeserver
    LeaseHolder                 : CN=MAILSERVER,CN=Servers,CN=Exchange Administrative Group
                                  (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=Commoname,CN=Microsoft
                                  Exchange,CN=Services,CN=Configuration,DC=domain,DC=com
    LeaseType                   : Option
    FailureDetail               :
    LeaseExpiryUtc              : 10/24/2016 12:48:02 AM
    LastSynchronizedUtc         : 10/24/2016 12:18:02 AM
    TransportServerStatus       : Skipped
    TransportConfigStatus       : Skipped
    AcceptedDomainStatus        : Skipped
    RemoteDomainStatus          : Skipped
    SendConnectorStatus         : Skipped
    MessageClassificationStatus : Skipped
    RecipientStatus             : Skipped
    CredentialRecords           : Number of credentials 6
    CookieRecords               : Number of cookies 2

    • Edited by forgiven Monday, October 24, 2016 12:32 AM
    Monday, October 24, 2016 12:05 AM
  • OK, a reboot of all 3 exchange servers got the email flowing outbound. However, i sent a test email to my personal email and got this back from my personal email:

    mx.google.com gave this error:[2001:0:5ef5:79fd:78:1cf7:9ff5:84d] Our system has detected that this message does not meet IPv6 sending guidelines regarding PTR records and authentication. Please review https://support.google.com/mail/?p=IPv6AuthError for more information . h189si9599961qkc.13 - gsmtp

     

    I don't want to use ipv6 so i am confused about this error.

    Monday, October 24, 2016 2:01 AM
  • Disable ipv6 on edge server and now email to gmail works.
    • Proposed as answer by David Wang_ Monday, October 24, 2016 5:43 AM
    • Marked as answer by David Wang_ Monday, October 31, 2016 5:27 AM
    Monday, October 24, 2016 2:18 AM
  • Hi,

    Thank you for generous sharing, we will mark your reply as answer.

    Regards,


    David Wang
    TechNet Community Support


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, October 31, 2016 5:27 AM