locked
Can not post commants in Sharepoint 2013 Blog site with login anonymous RRS feed

  • Question

  • Hi All,

    i have SharePoint 2013 blog site with anonymous login , i tried to post commands in blog but its asking authentication.

    steps i followed :   Enabled anonymous access in web application , enabled anonymous access for blog site (Entire site) , also enabled commands , blogs site contents access for anonymous users (Add , edit). 

    also i used this cmds but its not working.

    $lockdown = get-spfeature viewformpageslockdown

    disable-spfeature $lockdown -url http://sitecollectionURL

    can anyone help me to fix this issue ASAP.

    Thanks,

    Mani L


    Mani L

    Wednesday, November 4, 2015 10:18 AM

Answers

  • Hi Mani,

    The type error is caused by the “created by” field. When you post a comment anonymously,the “created by” field is null in comments list. SharePoint can’t get the value for displaying. Then the error comes.

    For the “Access denied”, I could reproduce your issue. Though I gave the anonymous user enough permissions. The error existed.

    It seems it is by default in 2013.

    As a workaround, you could try to use SharePoint 2010 model blog template. When you create a site collection in SharePoint 2013, you can choose a 2010 template.

    Best Regards,

    CY

    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, November 12, 2015 6:18 AM

All replies

  • Hi Mani,

    According to your description, you couldn’t post comments as an anonymous user.

    Make sure anonymous user has the “add” permission in the comments list.

    And after you disable the lock, you should disable\re-enable anonymous on the site:
    http://blogs.msdn.com/b/russmax/archive/2010/01/22/lockdown-mode-in-sharepoint-2010.aspx

    Best Regards,

    CY


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    • Edited by Chris yuri Thursday, November 5, 2015 9:37 AM
    Thursday, November 5, 2015 9:33 AM
  • HI Chris , thanks for your reply .

    i tried with this steps given on the above URL , i can post the commands and create the posts and manage the posts now . but when i post commands and when i try to create and manage the posts am getting below error   Type Error: b is null for all.

    Please see the below error screenshot and let me know if we have any fix for this issue.


    Mani L



    Thursday, November 5, 2015 5:19 PM
  • HI All , any update to fix this issue?

    thanks,Mani L


    Mani L

    Friday, November 6, 2015 3:05 PM
  • Hi Mani,

    When you create a blog site, which site template do you use? OOB blog template or custom blog template?

    Please create a new blog site with the same template for testing.

    If the issue doesn’t happen, I think the blog site crashed after so many changes.

    And if you use custom template, you could use OOB template for testing again.

    Best Regards,

    CY


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, November 10, 2015 5:51 AM
  • HI Chris ,    i created a blog site with default OOB Blog template , but its not allowing to post command anonymous login ....

    i want to login as anonymously and want to post a command anonymously , is that possible ?    right now everything fine , but when i try to post a command am getting error  

                           Type Error: b is null
                           Type Error: b is null   .

    Please advise to fix this issue ASAP .

    Thanks,

    Mani L


    Mani L


    Tuesday, November 10, 2015 7:56 AM
  • Chris , i created new blog site and i enabled anonymous access to entire web site .

    After that i enabled add. edit  permission for anonymous users for site contends Posts and Commands .

    Now i tried to post the command for one of the blog with anonymous login am getting error    "" Access denied , You not have permission to perform this action or access this resource "" .

    is that possible for login and post commands in anonymous users , please advise.

    Thanks,

    Mani L


    Mani L

    Tuesday, November 10, 2015 11:31 AM
  • is this issue with SharePoint 2013 Blog site ? i just checked in below URL regarding this issue.

    http://www.coreygreen.me/Lists/Posts/Post.aspx?ID=2

    Please let me know if we can fix this issue or not .

    Thanks,

    Mani L


    Mani L

    Tuesday, November 10, 2015 11:51 AM
  • Hi Mani,

    The type error is caused by the “created by” field. When you post a comment anonymously,the “created by” field is null in comments list. SharePoint can’t get the value for displaying. Then the error comes.

    For the “Access denied”, I could reproduce your issue. Though I gave the anonymous user enough permissions. The error existed.

    It seems it is by default in 2013.

    As a workaround, you could try to use SharePoint 2010 model blog template. When you create a site collection in SharePoint 2013, you can choose a 2010 template.

    Best Regards,

    CY

    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, November 12, 2015 6:18 AM
  • Hi Chris,

    i created new Blog site with 2010 template , all is good now .

    But look & feel and customization is not too good with 2010 blog site , i would like to customize this 2010 blog site with some designs in master page .  any idea for customizing 2010 Blog site design customization? 

    Thanks for your help.   Mani L


    Mani L

    Saturday, November 14, 2015 7:28 AM
  • Hi Mani,

    Click site actions->edit in SharePoint designer->master pages.

    Select the pages(.aspx) you want to customize, add some CSS/JavaScript to it.

    You can preview by clicking preview in browser.

    Or you can create a new master page:

    https://www.youtube.com/watch?v=SHimUYnyuWM

    Best Regards,

    CY


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, November 16, 2015 10:43 AM