none
Botched mailbox move left user with two mailboxes RRS feed

  • Question

  • An attempt failed at moving a user's mailbox from one storage group to another on Exchange 2007 sp3.

    The user's active mailbox is on the original storage group, and there is a disconnected mailbox on the target storage group with the same guid.

    I've attempted to remove-mailbox using both a database id and mailbox id, but was denied because mailbox was active/not disconnected.  I also tried to assign disconnected mailbox to a temporary user, with same results/reasons.

    Any help would be greatly appreciated.

    Exchange Server 2007
    Microsoft Corporation
    Version: 08.03.0298.001

    http://social.technet.microsoft.com/Forums/en-US/exchangesvrgenerallegacy/thread/967b0a68-1674-4788-b76a-954c86bd5508

    ( FYI... First Storage Group is destination database containing disconnected mailbox: )

    Event Type: Error
    Event Source: MSExchangeIS Mailbox Store
    Event Category: Logons
    Event ID: 1022
    Date:  6/3/2013
    Time:  7:46:43 AM
    User:  N/A
    Computer: MAIL
    Description:
    Logon Failure on database "First Storage Group\Mailbox Database" - Windows account NT AUTHORITY\NETWORK SERVICE; mailbox /o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=user1.
    Error: 1144
    Client Machine: MAIL
    Client Process: edgetransport.exe
    Client ProcessId: 0
    Client ApplicationId: Client=Transport

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
    Data:
    0000: 8a f8 a8 7d 8e 66 68 48   Šø¨}ŽfhH
    0008: b4 97 20 70 61 92 33 81   ´— pa’3
    0010: 5b 44 49 41 47 5f 43 54   [DIAG_CT
    0018: 58 5d 00 00 56 00 00 00   X]..V...
    0020: ff 00 1b 00 00 00 00 00   ÿ.......
    0028: 00 02 48 00 00 00 3a 67   ..H...:g
    0030: f0 1f fe 00 00 00 bd 44   ð.þ...½D
    0038: 20 10 00 00 00 00 03 59    ......Y
    0040: 20 10 00 00 00 00 e8 32    .....è2
    0048: 40 10 0f 01 04 80 a4 1d   @....€¤.
    0050: 40 10 0f 01 04 80 a4 19   @....€¤.
    0058: 40 10 0f 01 04 80 84 12   @....€„.
    0060: 40 10 05 00 07 80 84 18   @....€„.
    0068: 40 10 05 00 07 80 97 08   @....€—.
    0070: 40 10 78 04 00 00         @.x... 

    Monday, June 3, 2013 5:59 PM

Answers

  • Try moving it two more times to the same database.

    We've been doing quite a lot of moves lately. When a move action is interrupted you are also left with half a mailbox on the destination  database.

    When the move is initiated and stopped in the EMC/EMS you get AppLog eventID 9354 informing you that the mailbox on the destination database hes been removed.

    When the move is initiated and EMC/EMS crashes, everythig suddenly stops and the destination mailbox is not removed.

    However, if you then try to move it again, the move does fail with a AppLog entry EvenID1008 saying that a copy of the database has already been found on de destination database and that it has been removed:

    • The move-mailbox task for mailbox 'Clown P. (Pipo)' failed. 
      Error: Failed to copy basic mailbox information with error: A duplicate mailbox was found due to problems during a Move Mailbox procedure. The duplicate mailbox has been deleted.Try again later. 

    If you try and move tha mailbox again, it will be succesfull.

    Does this apply to your case?





    • Edited by Milan Gajic Tuesday, June 4, 2013 8:31 AM
    • Marked as answer by JGP2 Thursday, June 6, 2013 6:58 PM
    Tuesday, June 4, 2013 8:28 AM

All replies

  • The old way of dealing with this was to move the mailbox back to its original location and all would be repaired.  I don't recall whether that works with Exchange 2007.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    • Marked as answer by JGP2 Thursday, June 6, 2013 6:58 PM
    • Unmarked as answer by JGP2 Thursday, June 6, 2013 6:59 PM
    Tuesday, June 4, 2013 1:17 AM
    Moderator
  • Try moving it two more times to the same database.

    We've been doing quite a lot of moves lately. When a move action is interrupted you are also left with half a mailbox on the destination  database.

    When the move is initiated and stopped in the EMC/EMS you get AppLog eventID 9354 informing you that the mailbox on the destination database hes been removed.

    When the move is initiated and EMC/EMS crashes, everythig suddenly stops and the destination mailbox is not removed.

    However, if you then try to move it again, the move does fail with a AppLog entry EvenID1008 saying that a copy of the database has already been found on de destination database and that it has been removed:

    • The move-mailbox task for mailbox 'Clown P. (Pipo)' failed. 
      Error: Failed to copy basic mailbox information with error: A duplicate mailbox was found due to problems during a Move Mailbox procedure. The duplicate mailbox has been deleted.Try again later. 

    If you try and move tha mailbox again, it will be succesfull.

    Does this apply to your case?





    • Edited by Milan Gajic Tuesday, June 4, 2013 8:31 AM
    • Marked as answer by JGP2 Thursday, June 6, 2013 6:58 PM
    Tuesday, June 4, 2013 8:28 AM
  • Try moving it two more times to the same database.

    We've been doing quite a lot of moves lately. When a move action is interrupted you are also left with half a mailbox on the destination  database.

    When the move is initiated and stopped in the EMC/EMS you get AppLog eventID 9354 informing you that the mailbox on the destination database hes been removed.

    When the move is initiated and EMC/EMS crashes, everythig suddenly stops and the destination mailbox is not removed.

    However, if you then try to move it again, the move does fail with a AppLog entry EvenID1008 saying that a copy of the database has already been found on de destination database and that it has been removed:

    • The move-mailbox task for mailbox 'Clown P. (Pipo)' failed. 
      Error: Failed to copy basic mailbox information with error: A duplicate mailbox was found due to problems during a Move Mailbox procedure. The duplicate mailbox has been deleted.Try again later. 

    If you try and move tha mailbox again, it will be succesfull.

    Does this apply to your case?

    I didn't think of trying that.  But due to circumstance, I'm having to move all mailboxes off that group anyway.  So the problem will be moot by tomorrow.

    Thanks for posting the help!

    • Marked as answer by Zi FengModerator Friday, June 7, 2013 3:00 AM
    • Unmarked as answer by JGP2 Monday, June 17, 2013 8:05 PM
    Thursday, June 6, 2013 6:58 PM
  • glad to be of help. good luck!
    Thursday, June 6, 2013 7:02 PM
  • Try moving it two more times to the same database.

    ....

    However, if you then try to move it again, the move does fail with a AppLog entry EvenID1008 saying that a copy of the database has already been found on de destination database and that it has been removed:

    • The move-mailbox task for mailbox 'Clown P. (Pipo)' failed. 
      Error: Failed to copy basic mailbox information with error: A duplicate mailbox was found due to problems during a Move Mailbox procedure. The duplicate mailbox has been deleted.Try again later. 

    If you try and move tha mailbox again, it will be succesfull.

    Does this apply to your case?

    Ok.  I had it happen again (failed moves), and I confirmed this.  Simply copy the same user to the same group and it will error with "duplicate mailbox has been deleted", and then try a third time to get the box to move.

    I can't believe it wasn't documented somewhere else before.  I was to nervous to attempt a another move before I read your post.

    Thanks again for your help!!

    Tuesday, June 11, 2013 4:50 PM