none
The document specification failed to load RRS feed

  • Question

  • Hi,

          I have a BTS 2009 in WIndows 2008 server. When I imported an msi, I see the assemby version correctly in the Biztalk admin console but I see the older versions in the c:\windows\assembly. The messages fail at the receive location with the followign error:

    The document specification <AAAA.BBBB.CCCC+DDDD> from assembly <AAAA.BBBB, Version=0.0.0.10, Culture=neutral, PublicKeyToken=d3fe7f366d951faa> failed to load. Verify the schema for this document specification is deployed and is in the Global Assembly Cache. 

    Thanks.

    Wednesday, September 29, 2010 11:11 AM

Answers

  • Assemblies can be GAC'ed on three occations

    1. During add resource

    2. During import

    3. During install

    You can see these options when you go to Resources, select and resource and click Modify.

    The default option is 1 and 3. So, unless otherwise you run the MSI packages in the server, the assemblies won't be GAC'ed, while packaging the application (creating MSI), you can always tick the box "GAC while importing".

    Please check your resources.


    Regards, Saravana Kumar [MVP BizTalk Server] http://blogs.digitaldeposit.net/saravana/ http://www.biztalk247.com/
    • Marked as answer by curious_mind Wednesday, September 29, 2010 1:22 PM
    Wednesday, September 29, 2010 12:04 PM
    Moderator
  • How do I check the assembly key file name. I am sorry if these are too basic questions. I am trying to learn :-).

    I deleted the map from the application, re-imported the msi, restarted the host instances, verified the target namespace(below) in the incoming file. These didn't help. I still get the same error.

    <?xml version="1.0" encoding="utf-8" ?>

       <cfsBillgShipment xmlns="http://www.redcross.org/BioArchR2/schema/ePR_CFS/Shipment">
    thanks.

     

    Still, did you also run the MSI (as in double-clicking it and click through that wizard ;))? It's not the same thing as importing it to BizTalk. After doing that, then restart your host instance again.

    • Marked as answer by curious_mind Wednesday, September 29, 2010 1:20 PM
    Wednesday, September 29, 2010 12:53 PM

All replies

  • Hi,

    One of the obvious things you can do is restarting host instances after deployment of your application. Another thing you can look at is the schema type, which is defined using the target namespace and root node. You can check the incoming suspended message and make sure the target namespace and root node match your expected schema. For instance:

    <root xmlns=\"targetnamespace\">

    or

    <ns0:root xmlns:ns0=\"targetnamespace\">

    HTH

    Regards,

    Steef-Jan Wiggers - MVP & MCTS BizTalk Server
    blog: http://soa-thoughts.blogspot.com/
    If this answers your question please mark it accordingly

     


    BizTalk
    Wednesday, September 29, 2010 11:26 AM
    Moderator
  • check assembly key file name of project should not be different and restart the host instance after imported msi.

    @Steef, Thanks its work for me.

     

    Wednesday, September 29, 2010 11:48 AM
  • Assemblies can be GAC'ed on three occations

    1. During add resource

    2. During import

    3. During install

    You can see these options when you go to Resources, select and resource and click Modify.

    The default option is 1 and 3. So, unless otherwise you run the MSI packages in the server, the assemblies won't be GAC'ed, while packaging the application (creating MSI), you can always tick the box "GAC while importing".

    Please check your resources.


    Regards, Saravana Kumar [MVP BizTalk Server] http://blogs.digitaldeposit.net/saravana/ http://www.biztalk247.com/
    • Marked as answer by curious_mind Wednesday, September 29, 2010 1:22 PM
    Wednesday, September 29, 2010 12:04 PM
    Moderator
  • You say that you only imported the MSI. As Saravana said, unless you're using the default settings, you have to run the .msi also, to install the .dlls to GAC. Try running it and then restarting host instance.

    Wednesday, September 29, 2010 12:29 PM
  • I have a development environemnt where I created this new assembly version and I did not change the strong name key file. File receiving & sending works fine in this environemnt. When I exported I used a new name for the msi(with date) and imported in my target env.

    How do I check the assembly key file name in the target environment(that is not working). I am sorry if these are too basic questions. I am trying to learn :-). I had the same assembly key file name which I could GAC for my previous assembly versions in this non-working env. I still see AAAA.BBBB version 0.0.0.5 and 0.0.0.6 but not the 0.0.0.10 version in the GAC.

    I deleted the map from the application, re-imported the msi, restarted the host instances, verified the target namespace(below) in the incoming file. These didn't help. I still get the same error.

    <?xml version="1.0" encoding="utf-8" ?>

     

     

       <cfsBillgShipment xmlns=http://www.test.org/AAAA/schema/BBBB/Shipment>
    thanks.
    Wednesday, September 29, 2010 12:44 PM
  • How do I check the assembly key file name. I am sorry if these are too basic questions. I am trying to learn :-).

    I deleted the map from the application, re-imported the msi, restarted the host instances, verified the target namespace(below) in the incoming file. These didn't help. I still get the same error.

    <?xml version="1.0" encoding="utf-8" ?>

       <cfsBillgShipment xmlns="http://www.redcross.org/BioArchR2/schema/ePR_CFS/Shipment">
    thanks.

     

    Still, did you also run the MSI (as in double-clicking it and click through that wizard ;))? It's not the same thing as importing it to BizTalk. After doing that, then restart your host instance again.

    • Marked as answer by curious_mind Wednesday, September 29, 2010 1:20 PM
    Wednesday, September 29, 2010 12:53 PM
  •  I haven't done that in the past. However I did it now and it works. Thanks a lot. How come it worked fine without running the msi inthe past?

    Sorry, I didn't see your earlier post regarding the "running the msi".

     

    Thanks again to everyone.

    Wednesday, September 29, 2010 1:19 PM
  •  I haven't done that in the past. However I did it now and it works. Thanks a lot. How come it worked fine without running the msi inthe past?

    Sorry, I didn't see your earlier post regarding the "running the msi".

     

    Thanks again to everyone.

    I think you must've uninstalled the application at some point before importing the MSI. Or did you change the environment? When you deploy BizTalk solutions from Visual Studio, it also installs the assemblies to GAC at the same.
    Thursday, September 30, 2010 6:46 AM
  • Hi,

            In my target env there is no visual studio. I always(honestly only 3 times so far) copied the msi and bindings and imported. I am not sure if anyone else did because we share the env and more than one person goes and modifies stuff. So, from what I understand, it is possible one of my piers might have run the msi or uninstalled the application and forgot to pass on the information.

    Thank you.

    Thursday, September 30, 2010 6:06 PM