locked
Catalyst CCC & Driver will not install RRS feed

  • Question

  • hi guys, I got a very annoying problem here. Sorry if this turns out to be a long post, but I'm going to start from the beginning. Okay so I just got an XFX ATI Radeon HD5770 and a Samsung 2343 2048x1152 monitor. I put the monitor together and got to work on installing the 5770. My old card was an ATI Radeon X1650XT with Catalyst 9.11. I put in the 5770, connected the power cable, and checked connection to PCIe slot. I also swapped out my 3GB of ram for newer 4GB that has been lying on my desk for about a year (the 4GB did not work with the X1650XT, but it works fine with the 5770). I boot into windows (vista 64-bit) and download the newest driver (Catalyst 9.12) for the 5770 from amd/ati's site. I click install, it asks me if I want to install folding@home which i uncheck. Click next, gives my dir path, click next and it extracts all files to the new folder. Then the window goes away and the install wizard is supposed to start, but instead i get "CATALYST has stopped working, Windows is searching for a solution..."
    I have been googling this problem for a long time now to no avail yet. The gfx card itself is not defective (I hear the fan power on at boot up, and GPU-Z detects all information about the card correctly). The problem is the driver and CCC software it self. I tried redownloading the CCC suite in case 1st download was corrupt, no dice. I tried just the individual driver, no dice. I tried putting the old card back in and installing new driver for 5770 while using X1650XT, no dice. I tried installing driver in Safe Mode, no dice. I have removed all traces of my previous driver for the X1650XT. I really need this driver to work. I have no idea why it won't install. SYSTEM SPECS:
    Windows Vista Ultimate 64-bit
    ASRock ALive-XFire-eSATAII (I had to install a necessary BIOS update which enables support for ati 5xxx series cards)
    AMD Athlon 64 X2 6000+ Socket AM2
    4GB(2x2GB) G.SKILL DDRII 800MHz RAM
    XFX ATI Radeon HD5770
    AeroCool 620W PSU
    ALSO*: When windows pops up with "CATALYST has stopped working, searching for solution..." it eventually askes to send info to MS, and when i extend the details tab, it says "Files that help describe the problem:
    C:\Users\USER\AppData\Local\Temp\WERBECD.tmp.version.txt
    C:\Users\USER\AppData\Local\Temp\WERCDF1.tmp.appcompat.txt
    C:\Users\USER\AppData\Local\Temp\WERCE02.tmp.mdmp
    I don't know what these files are or what they do. I tried deleting them and then running the catalyst installer, it didn't help.
    ALSO** When I pulled the 5770 out and put the X1650XT back in, Vista instantly recognized it and reinstalled the driver for it. But when I pulled the X1650XT out again and placed the 5770 back in, Windows tried to install a driver for it but it could not and it just said "driver install: failure". Maybe Vista doesn't have full support for the 5770??
    Saturday, December 26, 2009 3:39 AM

All replies

  • Sorry for double posting.

    It seems I have fixed this problem, though I am not entirely sure. I was able to install a basic AMD driver that allowed Vista to recognize my card as ATI Radeon HD5700 Series. Actually, I'm not entirely sure what I installed. I could not get the CCC or standalone driver from ATI to work, but I stumbled upon an AMD Catalyst 9.12 Hotfix. I downloaded this and tried the ATI Setep (setup.exe) that was included and it still gave me the same "CATALYST has stopped working". But on a forum, I read about how some guy got a driver working by manual install through Device Manager. So I went to Device Manager and opened Properties for the 5770 (recognized as "Standard VGA Controller" at the time). It gave me the Code 10 error like it had been giving me before. But I clicked Update Driver under the Driver tab, and when asked to search online for driver (recommended) I chose the alternate option, Browse local computer for driver. Then I specified the AMD Hotfix folder and clicked install, and it recognized ATI drivers. Install was successful, card was now recognized as ATI Radeon HD5700 Series. I reinstalled for the drivers to take effect, and now everything works good. I can utilize the full 2048x1152 of my monitor (w/o drivers, can only go to 1500x1400) and can now launch 3D applications & programs.

    However, CCC is still not installed. I am wondering if I re-download the 9.12 suite, if it will work, or if I will still get "CATALYST ha sstopped working". Luckily, I do not require CCC atm.

    Thanks,
    Hope this helps someone else. 
    Sunday, December 27, 2009 7:15 PM