none
Error 0x80070780 couldn`t access file

    Question

  • Hello,

    we are getting a error 0x80070780 "couldn`t access file" when protecting a volume. I've checked eventlogs and dpm logs on the dpm and the fileserver. But I can't find a hint which file causes the error.

    We are using dpm 2010 with latest hotfixes on a Server 2008r2 with dell ml6000 tape library. File Server is a Windows Storage Server 2008r2 with attached iscsi volumes from dell equallogic array. Groveler service is active on all volumes.

    Protection group seems to be ok since it has 14 volumes to backup on the fileserver. All backups are successful except volume t:\. The Volumes is a about 2tb and all volumes together are about 40tb on this server. Backup runs for a about 4-5 hours and the fails with the described error.

    I've also resetted ownership and permissions for domain admins and lokal admin with icacls for this volume. Without success

    Do you guys can give me tip how to solve the issue or how to find the file causing the error.

     

    greetings stefan

    Friday, October 14, 2011 12:31 AM

All replies

  • Hi,

    The error 0x80070780  = The file cannot be accessed by the system.   Please try running chkdsk t: /f and see if that fixes any problems.  

    If not, Is the file name in the alert ?   Can you check to see if it can be copied off the volume, then deleted, then copied back to be sure the reparse point is valid.


    Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, October 14, 2011 7:49 PM
    Moderator
  • Hello Mike,

     

    there is no info about the file in the error message and in the logs. As far as I can see. I've already run chkdsk twice. Without success Do you know if the file causing the error is listen in any log file?

     

    greetings stefan

    Friday, October 14, 2011 9:01 PM
  • Hi,

    Yes, open a command prompt on the protected server, then:

    1)  CD "C:\program files\microsoft data protection manager\dpm\temp"

    2) C:\program files\microsoft data protection manager\dpm\temp>find "0x80070780" dpmra*.log >error-0x80070780.txt

    3) Notepad error-0x80070780.txt

    Look for a log entry similar to this one - it will have the folder or file name in the error.

     WARNING Failed: Hr: = [0x80070780] BackupRead failed on file(\\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy740\folder_name\File_name
     


    Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, October 14, 2011 9:45 PM
    Moderator
  • Hi,

     

    thanks that is kinda easy :-) it seems the acl was broken on a particular folder even with icacls it doesn't set proper permission for domain admin. Changed it manually´without problems.I think this was the issue.

     

    Many Thanks for the help.

     

     

    greetings stefan

    Friday, October 14, 2011 9:55 PM
  • Hi  mediasyst,

    Could you please teach how to fix this failure? I get the same error code when I try copying some .dwg files after re-installing Windows 2008 R2.

    Tuesday, February 14, 2012 10:08 AM
  • Hi,

    I experienced this issue when trying to (read) access files on a volume which had deduplication in Windows Server 2012 enabled. I played around with deduplication and enabled it on a USB connected harddrive then forgot that I had enabled it. When plugging in the USB harddrive in any other system (including Win8 Ent Win8 Pro, Win7 SP1 Ent and WinXP SP3 Pro) I got this error when trying to access any file which in part was subject to deduplication.

    Plugging in the USB drive in the original Windows Server 2012 host made the files accessible. I then disabled deduplication on the drive. After which the files became accessible from other systems.

    Hope this helps even if it was not the original issue...

    Carl

    • Proposed as answer by danny9001 Thursday, December 06, 2012 3:00 PM
    • Unproposed as answer by danny9001 Thursday, December 06, 2012 3:00 PM
    • Proposed as answer by Xueyihua Monday, November 04, 2013 8:23 AM
    Sunday, October 07, 2012 10:32 AM
  • I delete files by following these steps.
    1 Remove attributes,by file properties.
    2 using PowerShell,use the command

            > Remove-Item<filename>


    • Edited by danny9001 Thursday, December 06, 2012 3:03 PM
    Thursday, December 06, 2012 3:03 PM
  • I found the cause of this was the file attributes. By running attrib in the folder the file was in, I could quickly see that the file was actually a symbolic link, and that the target of that link did not exist.

    Thursday, April 05, 2018 5:08 AM