none
XP machine can't see file shares from Win7 machine

    Question

  • Hi,
    I am having trouble connecting from an XP (Home) desktop machine to a Win 7 (Home Premium) laptop to share files.
    I have read and followed a lot of posts to no avail.
    specifically I have followed the advice in "How to make Windows 7 work with older Windows versions for networking and file sharing"

    - both machines are in the same workgroup
    - there is no trouble going from Win 7 to the XP box
    - on win 7 the network is defined as a 'Work' network
    - firewalls are disabled on both boxes
    - Advanced Network settings
    - Network discovery in ON
    - File and Printer Sharing is ON
    - Public folder sharing is ON
    - password protected sharing is OFF
    - Allow Windows to manage Homegroup connections
    - the shared folder in Win 7 says its shared (its not in the public tree)
    - On folder Advanced setting decurity, 'Everyone' has been added 
    - On folder Advanced setting sharing it says "People without a user account and password for this computer can access folders shared with everyone"

    The XP box is using XP Home which can only use 'Simple File Sharing'.
    On the XP box the win7 machine appears in the Network list under the workgroup.
    If I click on the machine I get a login prompt!
    Attempting to map a drive to the win7 box the same network is shown browsing to the win7 machine does not list any of the shares. (it also does not ask for a login)

    Interestingly if I go back to the network and enter the userid / password then I can see the shares and over in other windows I can map a network drive and see the shares as well.

    So it looks like Win7 not honoring the request to allow anybody to access a specific share.  
    Is there something else at the macro level that needs to be adjusted ??
    Thanks
    JC
    Tuesday, March 16, 2010 11:21 PM

Answers

  • From you r 1st post I noticed:

    'Public folder sharing is ON

    Password protected sharing is OFF'

    That would need to be reversed or better yet just read this...

    http://social.technet.microsoft.com/Forums/en-US/w7itpronetworking/thread/8f21d25d-8189-48e7-8d7f-d6211ac63d31
    Monday, March 22, 2010 12:45 AM

All replies

  • If you would like to allow users access the computer from network with the Guest account in Windows 7, please check the related policy.

    1. Launch gpedit.msc from Start Search box.
    2. Locate to

    Computer Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignment\

    3. In the right pane, double-click “Access this computer from the network”. Click on “Add User or Group”, add “Guest” in the list.
    4. Double-click on “Deny access to this computer from the network”. Select “Guest” and click Remove.

    If the issue still occurs, please temporary disable firewall on the Windows 7 computer.


    Arthur Xie - MSFT
    Wednesday, March 17, 2010 7:08 AM
    Moderator
  • Hi JC 508

    Have you tried simple file sharing on or off? You may be seeing the issue with the Guest Account trying to be used for the Windows 7 machine.

    Open My Computer from the Start Menu or Windows XP Desktop. A new My Computer window will appear.
    1. Open the Tools menu and choose the "Folder Options..." option from this menu. A new Folder Options window will appear.
    2. Click on the View tab and locate the "Use Simple File Sharing (Recommended)" checkbox in the list of Advanced Settings.
    3. To enable Simple File Sharing, ensure this checkbox is checked. To disable Simple File Sharing, ensure this checkbox is not checked. Click inside the checkbox to alternately enable and disable the option.
    4. Click OK to close the Folder Options window. The settings for Simple File Sharing are now updated; no computer reboot is required.
    Tips:
    1. The Simple File Sharing checkbox should be at or near the bottom of the Advanced Settings list in the My Computer Folder Options.
    2. Enabling Simple File Sharing prevents the ability to assign user-level passwords to shares. When Simple File Sharing is enabled on a computer, remote users will not be prompted for a password when accessing that computer's shares.
    3. If the Windows XP Professional computer is part of a Windows domain rather than a Windows workgroup, this process for enabling or disabling Simple File Sharing has no effect. Simple File Sharing always remains disabled for computers joined to domains.

    Kind Regards

    Trent Steenholdt

    Wednesday, March 17, 2010 7:48 AM
  • Hi Trent nice clean post..only thing is the OP has ... XP (Home) desktop
    Wednesday, March 17, 2010 7:58 AM
  • like bubbapcguy said its XP Home so simple file sharing is all you get and it cant be turned off.
    I don't understand how that setting on the XP box could affect the way it accesses Win 7 anyway.

    Following Arthur's lead 
    a) there is no gpedit.msc found or anything like this so I cant follow those instructions - is there another way in to this ?
    b) I did look at the users in control panel and 'Guest' was OFF, I turned it on but it made no difference.

    Firewalls are off on both computers.
    Any other ideas?
    JC
    Wednesday, March 17, 2010 11:52 AM
  • Hi,

    I apologize. I should aware that your system is Windows 7 Home Premium. I suggest you follow the steps below.

    1. Open “regedit” from Start Search box.
    2. Locate to the following tab.

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa\

    3. In the right pane, find the following key.

    RestrictAnonymousSAM

    Change its value to “0”.

    If the issue still occurs, temporary disable antivirus and check the result again.


    Arthur Xie - MSFT
    Thursday, March 18, 2010 6:26 AM
    Moderator
  • Arthur,
    Thank you for your response.
    Alas this has no effect.  All antivirus / security features disabled and the same result.
    Just clicking down in 'Map network drive' shows no shares on the Win7 machine. Right clicking / Explore brings up a login box.

    At the end of the day I am trying to use SyncToy to sync my documents and it has no ability to supply credentials with a path name.

    JC


    Thursday, March 18, 2010 9:28 AM
  • Have you modified the Registry branch as I suggested in my previous post? If it does not help, you may try to change the access permission for the shared folders in Windows 7. Please specially add Guest account in the permission list. That is because Guest is not in the Everyone group in Windows 7.
    Arthur Xie - MSFT
    Friday, March 19, 2010 3:40 AM
    Moderator
  • Arthur,

    Thanks - yes I have adjusted the registry as you suggested.

    Tha access permissions for the folder I am trying to share have been specified as Everyone - full control, and I have now added Guest with full control.

    These make no difference. 

    Just how would XP try and connect? One reading of the file mapping dialogue is that XP will try and connect with its own id, in this case OFFICE8\jc which obviously Win 7 cant cope with.  I tried adding  OFFICE8\jc to the win 7 permissions but it wont allow it.

    Is there a way to make the 'Home' products use or behave like a domain type login pool?

    Thanks

    JC

    Friday, March 19, 2010 7:53 AM
  • Arthur,

    Thanks - yes I have adjusted the registry as you suggested.

    Tha access permissions for the folder I am trying to share have been specified as Everyone - full control, and I have now added Guest with full control.

    These make no difference. 

    Just how would XP try and connect? One reading of the file mapping dialogue is that XP will try and connect with its own id, in this case OFFICE8\jc which obviously Win 7 cant cope with.  I tried adding  OFFICE8\jc to the win 7 permissions but it wont allow it.

    Is there a way to make the 'Home' products use or behave like a domain type login pool?

    Thanks

    JC

    Friday, March 19, 2010 7:53 AM
  • Boot Windows 7 in Safe Mode with Networking and let us know if the shares can be accessed.

    I would like to explain that the Windows 7 computer an only recognize its local accounts and domain accounts if it is a member of the domain. The OFFICE8\jc is the local account of another computer and cannot be recognized by Windows 7. When you access shares on the Windows 7 system from another computer, the log on account must be one of the account in the Windows 7 system, either Guest or other account you entered.

    Can you access the shares after entering \\windows7computernam\sharefolder in Windows Explorer in Windows XP?


    Arthur Xie - MSFT
    Friday, March 19, 2010 9:32 AM
    Moderator
  • Boot Windows 7 in Safe Mode with Networking and let us know if the shares can be accessed.

    I would like to explain that the Windows 7 computer an only recognize its local accounts and domain accounts if it is a member of the domain. The OFFICE8\jc is the local account of another computer and cannot be recognized by Windows 7. When you access shares on the Windows 7 system from another computer, the log on account must be one of the account in the Windows 7 system, either Guest or other account you entered.

    Can you access the shares after entering \\windows7computernam\sharefolder in Windows Explorer in Windows XP?


    Arthur Xie - MSFT
    Friday, March 19, 2010 9:32 AM
    Moderator
  • I have a fairly similar problem, so I hope you don't get upset if I piggyback into your thread.

    I have a client that is running Windows7 Profesional (we updgraded it from Home Premium), the Machine also runs Norton's Security.

    I had the system running but it has stopped working. I am not running a homegroup since all of the other machines in the network are XP and could not get the homegroup to work. One of the Windows7 folder is set a a shareable by everyone and by Guest.

    I had disabled the password protection check also (pretty much like JC 508's set-up) and it was working, A  couple of days ago it stopped working and it only works if I go to the XP systems, go to the Windows Explorer and click on the shared drive and login as a Guest.

    Going back to the Windows7 system, for some reason it will not take disabling the password protection check in the private and public sections of the Advances network sharing section (sic).

    Any clues? Thanks and sorry for the barging-in

    Friday, March 19, 2010 6:27 PM
  • Arthur,

    thanks again for your continued input.

    When I boot the Win 7 machine in safe mode with netwrking the whole computer does not appear on the XP

    Win7 machine = JCLAPTOP   Share name is "JClap_Shared_n_synced" physically= C:\Users\JC\Documents\JClap_shared_n_synced

    XP machine = OFFICE8; share name is Off8Sync  physically= D:\Data_Data\Documents\SharedAndSynced

    When in safe mode attempting to map a network drive from OFFICE8 shows Entire Network / Microsoft Windows Network/ TJS  (the workgroup name) / OFFICE8  

    i.e. there is no entry for JCLAPTOP. So entering directly \\JCLAPTOP\JClap_Shared_n_synced gives

    a) Attempting to connect to \\JCLAPTOP\JClap_Shared_n_synced 

    b) The network path \\JCLAPTOP\JClap_Shared_n_synced could not be found. 

    From your post I understand why OFFICE8\jc cannot work but this implies there is noway to access Win 7 without an account on the Win 7 box, be it real or Guest.  If this is true then I am confused about a whole lot of posts I have followed. Even the entry in Properties / Sharing of the shared folder which says "Password Protection;  People without a user account and password for this computer can access folders shared with everyone"

    That is exactly what I want to do - access without a user account or password.  OR get the chance to specify one.

    Back in XP (with the Win 7 box out of safe mode) if I try to map a drive shows -  Entire Network / Microsoft Windows Network/ TJS  / Jclaptop.   But no shares are shown and the OK box is greyed out. I would expect a list of shares and if pick one be presented with a login box or be able to map to it but not see any contents without a login.

    So in short I get no chance to login with any account.

    p.s. I have posted a similar thread in the synctoy forum as that is what I am ultimately trying to do but so far nobody has an answer from that perspective.   I cant believe its so hard this XP Home to Win7 Home must have been a scenario expected by MS.

    Thanks again

    JC

    Saturday, March 20, 2010 7:18 AM
  • capun,

    Its a forum not a phone call so you are not 'barging in'.   Any evidence is appreciated as we still haven't established whether this is my particular problem or a generic Win 7 Home Premium to XP Home scenario.

    I am interested to know if you can recall what happened between 'was working' and 'not working'

    JC

    Saturday, March 20, 2010 7:21 AM
  • Hi JC 508,

    Does the XP computer have these enabled? http://support.microsoft.com/default.aspx/kb/318030?p=1

    Saturday, March 20, 2010 10:47 AM
  • Nano warp,

    Thanks new info!  Net Bios over TCP/IP was not enabled and is now; the rest of the them were all on.

    It didn't make any difference. :(  The shares are not shown but if I paste in a full link (\\JCLAPTOP\JClap_Shared_n_synced) now it jumps to life and wants a userid / password.

    I cant use the same technique from synctoy it just says it doesn't exist.  As a workaround I have established a drive connection to \\JCLAPTOP\JClap_Shared_n_synced with the use and password and used the drive letter as the target of the sync.  This still says 'path does not exist' UNLESS you use windows explorer to view the new drive - when it asks for the password. Once password entered in explorer this drive will work all over.

    So still no way to connect to win7 without a user / password AND XP has always had trouble remembering mapped drives they come and go and you have to do little sideshows to reconnect all the time which is why I started using the link name.

    Thanks for the effort everybody

    JC

     

    Saturday, March 20, 2010 12:06 PM
  • Put static IP's on the boxes and use the IP address

    net use s: \\5.x.x.x\Share_Name /user:someuser_name password /persistent:no

     

     

    Saturday, March 20, 2010 2:53 PM
  • Bubbapcguy,

    Static IP is a bit too radical, the one it is really needed on is a laptop which travels and connects via all kinds of networks several of which are outside of my control.

    Everybody,

    I think I will conclude

    * Win 7 cannot infact be connected to without a user and password no matter what the dialogs say or how the registry is fiddled.

    * XP is a worse pig as it really doesn't like supplying user-id / passwords and if you give it one it reuses it when it shouldn't.

    * synctoy is really a toy it has no provision to supply credentials, no provision for pre-amble / post-amble commands of any kind; but hey the price is right.

    So the workaround is to

    * create a specific user on win7 with appropriate rights to the folders I am trying to sync only.

    * have a batch file on XP box that maps a drive along with the user /password. And another to drop the share maybe.  

    * Have to remember to use this prior to any sync attempt - then sync as needed.

    Other options like using tools to keep network connections alive are probably not appropriate as one end is a laptop and is out in the field a lot.  So this is a workaround rather than a solution but not that hard to live with.

    Thanks for the help everybody.

    JC

    Sunday, March 21, 2010 2:26 AM
  • I had same type issue and went over it a dozen times. I could not access administrative shares (C$ , D$. ETC$...) on the windows 7 machine from any other smb device, using an admin account. Example admin account on all machines and devices User: admin Password: pass  Pass though authentication works from all devices except when trying to access the windows 7 machine.

    The Solution was to disable UAC. As soon as I disabled UAC and rebooted, I had full access to all shares, all file sharing issues were resolved.  It seems there is nothing wrong with the file and print sharing in windows 7 all problems with it are caused by the U seless A ccount C ontrol.

    Sunday, March 21, 2010 7:07 PM
  • CMD,

    Thanks for the input - tried it but  this didn't work for me.  I think your issues are a bit different as the root folders, especially c: are the subject of a lot of other posts.  

    JC

    • Proposed as answer by CalBoyy Sunday, January 9, 2011 12:32 AM
    Monday, March 22, 2010 12:13 AM
  • From you r 1st post I noticed:

    'Public folder sharing is ON

    Password protected sharing is OFF'

    That would need to be reversed or better yet just read this...

    http://social.technet.microsoft.com/Forums/en-US/w7itpronetworking/thread/8f21d25d-8189-48e7-8d7f-d6211ac63d31
    Monday, March 22, 2010 12:45 AM
  • My Vista home & Xp sp2 can acccess Win7 pro public, but not other shared folders.

    the solution for me is:

    add "GUEST" to "user names" under "security" tab.

    Tuesday, December 28, 2010 11:15 PM
  • I Know this is a late response, but I wrestled with the same issue and figured out the problem:

    Eventhough you set the permission to everyone to view a folder from your windows 7 computer, doesn't mean windows 7 has acutally created the proper permissions for you. Here's what you have to do:

    In Windows 7:

    1) Right click the folder you want to share and click on properties.
    2) Click on the "Sharing" tab
    3) Click on the button "Share..."
    4) Add "Everyone"
    5) Press Share and Close

    6) In the same "Sharing" tab, click on the button "Advanced Sharing..."
    7) Click on "Permsions"
    8) Click "Add"
    9) Click "Advanced"
    10) Click "Find Now"
    11) Scroll through the list and find "everyone"
    12) Click on through pressing OK.

    13) Make sure the permissions are set the way you want (Read/Write/Both etc)

    14) Make sure you have all of the protocols selected with the exception of "network monitor..." in your properties for your network card on your Windows XP Machine.

    That's it! It should work now!

    • Proposed as answer by CalBoyy Sunday, January 9, 2011 12:32 AM
    Sunday, January 9, 2011 12:32 AM
  • I don't think a late response matters, CalBoyy - I've been trying to get access to Win7 shares from XP for two years now. :-/

    (80% of people read my posts backwards: 'Win7 can't see XP'.)

    Registry entries, KB updates, checks on shares, SPs, stop/starting services - everything.  'IsDomainMaster' is nice.  Ah, and your double share configuring; I saw that, with emphasis on the Advanced button, last August.

    My trouble on my XP box is that it can't even touch the troublesome Win7 box, let alone any of its shares.  I can recite KB922120's contents verbatim.

    Only after I reboot the Win7 puter do I get XP-access to it.  After a while even that success dies.

    XP can't access Win7 shares.  XPpro/Win7Ult.  The story continues..

    Yes, I'd say that JC508 was trying to be a bit ambitious - wanting to connect without duplicate authentication between boxes - but I'm just here reading..

    Tuesday, June 21, 2011 8:32 PM
  • I had similar problem, and solved, it's long time ago. If I remember correctly, what I did is to add a "Guest" account with full control to the "Security" of "Properties" of the drive that I want to access from XP. 
    ping
    Tuesday, June 21, 2011 8:45 PM
  • One other thing that just worked for me - check to ensure that the "file and printer sharing" properties of the network connection are enabled.  YOu can right click your network adapter and click properties.  Next to "TCP/IP" and "QoS", there is also the sharing properties.  Just ensure it is enabled.  It was the one thing I hadn't checked...
    Tuesday, October 4, 2011 7:01 PM
  • Please try these steps and hope can solve your problem :

    Network and Sharing Center - Change advanced sharing settings - File sharing connections - Enable file sharing for devices that use 40- or 56-bit encryption - Save changes

    Thursday, September 28, 2017 8:32 AM