Microsoft UAA Bus Driver for High Definition Audio


  • I have an HP Pavillion dv6140US laptop which has been problematic since day 1 regarding sound.  This week I reverted back to XPPro from Vista, which included installing XPSP3. 


    When I originally purchased the laptop I had no sound issues when I had XPSP1 or XPSP2.  Problems started when I installed Vista and are continuing with XPSP3. 


    My current thought is that this issue is related to the Microsoft Universal Audio Architecture (UAA) Bus Driver for High Definition Audio and is applicable to most XPSP3 systems.   I have tried unsuccessfully to update the driver using multiple sources.  The driver vesion can be found within your local Device Manager under System Devices (mine is dated 3/5/04 ver: 


    I have unsuccessfully tried updating the driver via the following sources:

    • Letting the OS search for an update
    • HP OEM provided update sp33867; install does not seem to complete regardless of how I try
    • Microsoft reference; Message: The current service pack installed is newer than the fix you are trying to apply

    If I could get the updated (Microsoft Universal Audio Architecture (UAA) Bus Driver for High Definition Audio  driver installed I am hopeful that the issue would go away.  What a pain! 


    Is there a MSFT patch issued that I am missing?



    Friday, September 12, 2008 2:33 PM

All replies

  • simplePCman, if you already have a "Microsoft Universal Audio Architecture (UAA) Bus Driver for High Definition Audio" driver, then you do not need to update it.  What makes you think this is the problem?


    Have you installed the drivers for your audio hardware (Conexant High Definition Audio)?


    Saturday, September 13, 2008 3:56 PM
  • Hi,

    i'm having the same trouble, with a toshiba laptop. It has a realtek audio chip, which needs Ms UAA . By installing it, the sound works but microphone's not. In other forums recommends installing SondMax audio driver over Ms UAA, but doing it I can hear sound and microphone's input but still can't see it as an input device.

    Saturday, September 13, 2008 4:08 PM
  • keberflores, if (and only if) your PC has Realtek HD Audio hardware, then do the following:


    - download the latest Realtek HD Audio drivers from

    and save them to disk - do not instal them yet.


    - in "Device Manager", if Microsoft UAA Bus driver is already present, then right-click and select "Disable".  Then, also try right-clicking and select "Uninstall".  Dismiss/cancel any attempt by Windows to install drivers for new hardware found.


    - now install the downloaded Realtek drivers.

    Saturday, September 13, 2008 4:42 PM
  •    I'm having the same problem as all of you with my new OS Build; I 5 Caore Board & Processor. All else went great; Besides finding New bad sector Ram at first!... But this UAA Bus Driver Issue has really got me stumped... I agree, It must be a unforseen bad root in the sector before the Service pack 3 installment was released....

    Friday, September 10, 2010 5:34 AM
  •   Relating back too the previous comment I made about bad unforseen sector in the adio streamline; ( Before the Service Pack 3 Release)... Now this is just a thought too calculate people; Is there a Difference between the Numinomical & Valadarion Table Audio Streamlining Build's ; ( Before Pretext Service pack 3.), Ex. File Error that could be Causing this Whole Mess?...
    Friday, September 10, 2010 6:01 AM
  • this ms-uaa driver download for sp1 and sp2


    Wednesday, September 29, 2010 5:55 PM