none
Exchange 2013 Extended Delay in Sending Mail

    Question

  • My exchange environment:  server 2012r2  exchange 2013 ver 15.0 1365.1  cu 18 installed 

    If I try to send an email to certain domains the message will remain in the queue for aprrox. 9hrs. then release to the recipient.  Error is  (451 4.4.0 DNS query failed with error dns retry). Checking nslookup on the exchange server results in a 2 second time out. The result is the same if I use a internal DNS server or a public DNS server such as Goggle 8.8.8.8 the server is configured to forward dns request to the two internal dns servers. When I check nslookup on the two internal dns servers I have no issues resolving the domain. After digging in to this more my exchange appears to send ip6 request for 9hrs than fail over to ip4 to resolve this happens only on a few select domains, the rest no problems.  I have tried to disable the iphelper service on the exchange server but that dosen’t  seem to have helped. Working with the admin of the effected domain  ”Your DNS server is issuing IPv6 addresses for us, but aside from the company webpage, we don’t have any IPv6 address space configured.   There certainly is not an IPv6 MX record for the mail server.   I’m wondering if your mail server is attempting IPv6 delivery and having to wait for that to fail before trying the IPv4 address.”

    Any help would be appreciated

    Thanks

    Monday, April 16, 2018 5:10 PM

All replies

  • Have you configured your send connector to use a specific DNS server, and if so, is it specified correctly?  Best practice is to not do that, and to make sure the Exchange server's network DNS server can resolve external DNS names and not specify one for the send connector.  In any case, it does appear you're having DNS problems, and that's where I'd focus my troubleshooting.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!


    Monday, April 16, 2018 9:25 PM
    Moderator
  • Hi bman_cei,

    Any update now?
    If the above suggestion helps, please be free to mark it as answer for helping more people.

    Regards,

    Kyle Xu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Thursday, April 26, 2018 1:41 AM
    Moderator
  • no still having the problem tried every combination on the dns servers and the exchange servers and yes the exchange server can resolve most external dns names that i have tried (so iknow some forwarding is going on) only certain domains will not resolve always results in a 2 second  time out  both of the dns servers  can resolve  the domains in question

    dcdiag /test:dns   all passed 

    no entries in the cached lookups for  domains in question  on the dns servers   

     
    Thursday, April 26, 2018 4:18 PM