locked
Dot net with Windows 2008 R2 SP1 fails RRS feed

  • Question

  • hi,

    I have installed Windows 2008 R2 SP1 Standart Edition. After that trying to install MS .net feature 3.5.1 from server manager, but no luck.

    I also tried installing using powershell but no luck.

    Need help.

    Framework 3.5.1 failed with error code 0x80070643.  Fatal error during installation


    Bangalore, INdia,9886759578
    Thursday, August 18, 2011 10:17 PM

Answers

  • I have resoved the issue, THaks lot to all for help

    Windows update was causing the issue.

     


    Bangalore, INdia,9886759578
    Wednesday, August 24, 2011 6:11 PM

All replies

  • This article walks through some issues with .net 3.5.1 installs on servers. 

    http://support.microsoft.com/kb/976982


    If you found this post helpful, please give it a "Helpful" vote. If it answered your question, remember to mark it as an "Answer".

    Rich Prescott | MCITP, MCTS, MCP

    Blog | Twitter: @Arposh | Powershell Client System Administration tool
    Thursday, August 18, 2011 11:03 PM
  • Thanks for the help Arposh,

     

    I have Windows 2008 R2 SP1 which has dot net as OS component. Cleanup tool will not help to uninstall however I will try with fixit and update.

     

    HM


    Bangalore, INdia,9886759578
    Friday, August 19, 2011 1:20 AM
  • hi,

    I tried the option which above KB says. Since .net 3.5.1 is part of Windows 2008 R2 SP1 OS, so there is no repair.

     

    Still same issue.

     

    Need help urgently?

     

     

     

     


    Bangalore, INdia,9886759578
    Sunday, August 21, 2011 4:07 AM
  • Hi,

    As far as I know, Windows Server 2008 R2 includes .Net Framework 3.5 with SP1. You need to install it from --> Server Manager --> Features --> .Net Framework 3.5.1 Features.

    By default, the system comes with .Net Framwork Setup v2.0.50727 installed. You can verify it via the following registry key 
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP
    - Version REG_SZ 2.0.50727

    Based on my experience, usually the 0x80070643 error during install .Net Framework relates with the old or corrupt files for current version.

    Based on this situation, please try:

    1.  Try to repair the current version by "SFC" and "/Scannow" as administration account.

    2.  after that, if it still don't work, please try to run the System Update Readiness Tool:

    ----------

    Description of the System Update Readiness Tool for Windows Vista, for Windows Server 2008, and for Windows 7 

    http://support.microsoft.com/kb/947821/en-us

    After that, please try to install the  .net 3.5.1  again.

    Thanks.

    Kevin Tu


    “Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.”
    Monday, August 22, 2011 9:47 AM
  • Thanks a lot kevin for reply.

    I have configured Windows 2008 R2 deployment image using MST 2010 U1 and WDS. I am deploying OS thru this.

    Now this issue is not with one system, but will all the image I am deploying. Now trying image with new OS media. I am downloading the image from MS website. Thinking may be image is currepted.

    I have configired image in such a way that .net framework 3.5.1 should install during OS build. It shows 100% completed, imedeately after that its start reverting changes.

    Using below syntext to run as a batch file during OS build:

    Powershell -Command "&{Import-Module Servermanager;add-Windowsfeature File-Services,FS-DFS-Replication,NET-Framework-Core,gpmc,Telnet-Client,rdc,RSAT-ADDS-Tools,RSAT-AD-AdminCenter,RSAT-ADLDS,RSAT-AD-Powershell,backup,backup-Tools,Windows-Internal-DB,WSRM,Desktop-Experience}" -Restart

     

     

     

     

     


    Bangalore, INdia,9886759578
    Monday, August 22, 2011 9:05 PM
  • I have resoved the issue, THaks lot to all for help

    Windows update was causing the issue.

     


    Bangalore, INdia,9886759578
    Wednesday, August 24, 2011 6:11 PM
  • Hi Singh,

    Could you tell me how did you solve this issue? I have the same problem.

    Dmitry

    Tuesday, October 25, 2011 9:52 AM
  • Hi all, I just had a major pain trying to get .net 3.51 installed onto a a NEW server, it turned out it was a corrupt windows process activation service..

     

    http://www.techieshelp.com/cannot-install-net-framework-3-5-1-on-server-2008-0x80070643/

     

     

    Tuesday, December 13, 2011 9:25 AM
  • i am Not able to install dotnet framwork 4.0 on windows 2008 R2 ent.

    i m geting error when i m install

    "Generic Trust Failure"

    please help me if any one getting solution for the same problem


    PL

    Tuesday, May 1, 2012 11:26 AM
  • Hi every one

    i am Not able to install dotnet framwork 4.0 on windows 2008 R2 ent.

    i m geting error when i m install

    "Generic Trust Failure"

     

    please help me if any one getting solution for the same problem


    PL

    Tuesday, May 1, 2012 11:27 AM