none
Sharepoint 2007 e archiviazione di documenti da Windows 7

    General discussion

  • Sto usando con molta soddisfazione la funzionalità di gestione documenti di sharepoint 2007.

    Con XP, sia in lan che via internet e sia in dominio che fuori dominio, riesco a eseguire l'estrazione del file, a modificarlo e ad archiviarlo direttamente da word (per fare un esempio).

    Se eseguo le stesse operazioni su Windows 7, anche qui sia in lan che fuori lan e sia in dominio che fuori dominio, riesco ad eseguire l'estrazione, modificare il file e salvarlo
    MA
    non riesco ad archiviarlo. Ne consegue che ho la copia in locale che dovrei riuppare su server manualmente.

    Qualcuno ha consigli a riguardo?
    Se funziona con XP non capisco perchè Windows 7 (che reputo migliore) non debba farlo...

     

    Grazie in anticipo!

    Wednesday, November 17, 2010 4:40 PM

All replies

  • Ciao smurfxx,

    le prove sui clients le fai con lo stesso utente o comunque con utenti che hanno sicuramente gli stessi permessi?

    Quale versione di office usano i due clients? E in che versione sono i documenti office su sharepoint?

    Ciao


    Pat (Microsoft Office Project MVP) -- http://patriziamonti.wordpress.com

    Wednesday, November 17, 2010 8:41 PM
  • Ciao, si effettivamente mi sono dimenticato di citare questi particolari:

    - l'utente che uso per fare le prove generali è sempre administrator ma ho visto che nelle prove con xp anch gli user di più basso livello riescono a fare le modifiche senza errori

    - I client con windows 7 usano office 2010 professional mentre i client xp usano office 2007 professional. Ho anche il caso di windows 7 professional con office 2007 professional di cui la prova non va a buon fine

    - I documenti su sharepoint sono tutti versione 2003, infatti vengono sempre aperti in modalità compatibilità sugli office più recenti

    EDIT: Ho capito facendo altre prove incrociate che è tutta colpa di office 2010 e del suo upload center, come riportato qui http://social.technet.microsoft.com/Forums/en-US/officeappcompat/thread/58b7a875-033c-43ff-9fd2-b550eed5e6a5

     

    Peccato che nessuno abbia ancora dato una risposta a questo difetto...

    Thursday, November 18, 2010 11:24 AM
  • Ciao smurfxx,

    a me non sembra che tu abbia lo stesso problema riportato nel post che hai segnalato. Comunque se dalle tue prove ti sembra lo stesso, il workaround è qui: http://social.msdn.microsoft.com/forums/en-US/sharepointdevelopment/thread/54fe06d5-caba-431c-8472-0b500e22f390

    Ciao


    Pat (Microsoft Office Project MVP) -- http://patriziamonti.wordpress.com

    Thursday, November 18, 2010 8:30 PM
  • Da quello che mi sembra di capire non c'è soluzione se non caricarli a mano, giusto?

    Il problema è che se fosse per me nessun problema ma ho a che fare con gente che fa fatica a muovere il mouse, quindi meno passaggi hanno e meglio è...

    Friday, November 19, 2010 11:15 AM
  • Mah... io non interpreto come te: devi fare l'upload (non è propriamente a mano e, fra l'altro, è il metodo corretto con cui gli utenti devono caricare i documenti creati esternamente a SharePoint) di un paio di documenti seguendo le istruzioni (almeno uno nel primo passaggio e almeno uno nel secondo) per risolvere il problema, che però non è esattamente il tuo stesso, come ti dicevo; siccome però la procedura è semplice, ti conviene provare.

    Ciao


    Pat (Microsoft Office Project MVP) -- http://patriziamonti.wordpress.com

    Friday, November 19, 2010 7:25 PM
  • Guarda, ormai è appurato che è un problema di office 2010. Il tuo workaround è una soluzione ma non per gli utenti "normali" e inoltre non capisco perchè office 2010 non si agganci nativamente bene a sharepoint 2007...
    Monday, November 22, 2010 8:06 AM
  • Devo smentirti... ho tanti clients con Office 2010 che si "agganciano" perfettamente a SharePoint 2007.

    Ho trovato, però, alcune cose che possono causare il problema:

    • sul server, in iis7, non deve essere installata la feature "Webdav"; se è questo il tuo caso disinstalla webdav e riavvia il server
    • sul client il sito non deve essere inserito fra i siti attendibili ma nella zona "intranet locale" 
    • non si deve accedere al sito utilizzando l'indirizzo ip, ma occorre usare il nome sito
    • nell'amministrazione centrale di sharepoint deve essere abilitata l'integrazione client (Central Admin->Application Management->Authentication Providers->authenticaton provider-->"Enable Client Integration?")
    • se hai creato la site collection in un "percorso gestito" e non hai creato il sito nella relativa root potrebbero esserci problemi: meglio crearlo
    • controlla le notifiche nell'upload center: quando si presenta il problema se la notifica risulta in pausa fai un resume e dovrebbe sbloccarsi

    Ciao

     


    Pat (Microsoft Office Project MVP) -- http://patriziamonti.wordpress.com

    Monday, November 22, 2010 8:06 PM
  • Intanto ti ringrazio del supporto che mi stai dando, nel post precedente mi ero dimenticato di scriverlo e addirittura il mio tono sembrava un po' arrogante, non era quella la mia intenzione!

    Ho verificato le cose che mi hai citato e posso dirti che:
    - webdav non era installato sulla macchina, quindi il problema non sussiste
    - su client il sito è aggiunto fra i siti attendibili
    - ho sempre fatto l'accesso al sito tramite il nome macchina e non l'ip
    - in amministrazione centrale il client integration era già attivo
    - sinceramente questo passaggio mi sfugge, il sito è stato creato da root, andando alla voce "crea sito"
    - in upload center ho provato a mettere in pausa e riprendere l'upload

    Dopo aver effettuato tutte queste prove il risultato non è cambiato.

    Mi viene un dubbio solo sulla penultima voce che non mi è chiara...

    Wednesday, November 24, 2010 9:00 AM
  • Se il thread che segnali descrive in maniera adeguata il tuo problema potresti condividere con noi la versione di MOSS 2007 che hai installata? Per condividere questo dato seguile queste indicazioni: Central Administration\Operations\Servers in Farm\Version (è un numero: XX.X.X.XXXX)

    -Romeo


    Romeo Pruno | Microsoft MVP SharePoint Server | http://www.nonaka.eu/feed
    Thursday, November 25, 2010 10:25 AM
  • La versione è 12.0.0.6545

    Il problema ormai è noto: nella mia azienda TUTTI i client con office 2010 danno problemi.
    Ripeto una cosa essenziale: i client riescono a fare download ed aprire il lettura o modifica i documenti ma abbiamo bisogno delle revisioni.

    Quindi il procedimento standard è:
    - estrarre il documento
    - aprirlo (verrà chiesta di fare una copia nella cartella bozze locale)
    - fare tutti le modifiche sul documento e salvarlo
    - quando si chiude il documento viene chiesto di archiviarlo subito; negli office 2010 è qui che si presenta l'errore di upload, negli altri office l'upload avviene senza problemi con tanto di richiesta revisione e commenti aggiuntivi

    Il sistema operativo dei client non c'entra nulla, sia xp che vista che 7 con office 2003 e 2007 funzionano (addirittura da fuori la rete lan, cioè da internet), mentre l'unico a rognare è office 2010 e il suo upload center che non restituisce nemmeno un log dettagliato dell'errore.

    Thursday, November 25, 2010 1:54 PM
  • La versione è aggiornata alla CU di Agosto! Ti consiglio, di aprire un ticket di supporto con Microsoft per capire il problema di compatibilità e magari condividere la tua esperienza ancora aggiornado questo thread.

    -Romeo


    Romeo Pruno | Microsoft MVP SharePoint Server | http://www.nonaka.eu/feed
    Friday, November 26, 2010 7:47 AM
  • Ok! Non ho mai aperto un ticket di supporto Microsoft, dove si apre?

    In ogni caso stiamo effettuando un po' di passaggi per passare a sharepoint 2010 che non ha questo difetto (tra le altre cose), quindi diciamo che ho voluto aprire questa discussione per tentare di far lavorare da subito le persone e per capire se era un problema facilmente risolvibile con qualche aggiustamento nella configurazione.

    Monday, November 29, 2010 8:24 AM
  • Il ticket Microsoft si apre tramite richiesta al supporto tecnico in base al vostro tipo di contratto di licenza.
    Romeo Pruno | Microsoft MVP SharePoint Server | http://www.nonaka.eu/feed
    Monday, November 29, 2010 10:16 AM