locked
Formatting Linked Lists RRS feed

  • Question

  • I made a connect between a master and transaction lists in share point, when I select the master record in list 1 the transactions associated with that master record are displayed in list 2. 

    After making the connection, I have lost the search option which usually appears at the top of the list to skip to a specific record, is there some way to get this back?

    When I add a new transaction record, it does not auto fill with the customer ID which links the master and sub list? For example if I am viewing customer SMITH10010 transactions and I want to add a new transaction, it will be for SMITH10010 and I need it to auto fill that field.

    Thank you.
    Monday, January 18, 2016 3:57 PM

Answers

  • Hi,

    From your description, you have 2 requirements:

    In a list web part, the list search box is not available and you want it back.

    When you filter the items in sub list using the select option in master list, new item in sub list will auto fill the customer ID field.

    For Q1, first you need to update your SharePoint with December 2015 CU.

    Then edit the page > edit the list web part > under Miscellaneous section > enable “Display search box.” > save the page.

    For Q2, per my test, there is no OOB way to achieve your requirement, you will need custom code.

     

    Best regards,                                                                                                       

    Aaren liu


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, January 19, 2016 4:46 AM
  • Hi Steve,

    I have done test again and I can reproduce your senior.

    When I search for an item then click the Select icon before it, the page will refresh to show all master records, the searched item will be displayed as “Selected”. And at the same time, the correct transaction records will display.

    I haven’t find a solution to solve the issue. But it doesn’t affect the connection.

    Best regards,                                                                                                       

    Aaren liu


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, January 26, 2016 9:56 AM

All replies

  • Hi,

    From your description, you have 2 requirements:

    In a list web part, the list search box is not available and you want it back.

    When you filter the items in sub list using the select option in master list, new item in sub list will auto fill the customer ID field.

    For Q1, first you need to update your SharePoint with December 2015 CU.

    Then edit the page > edit the list web part > under Miscellaneous section > enable “Display search box.” > save the page.

    For Q2, per my test, there is no OOB way to achieve your requirement, you will need custom code.

     

    Best regards,                                                                                                       

    Aaren liu


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, January 19, 2016 4:46 AM
  • Thank you Aaren, This worked great, with one small issue. After I added the search box, I can now search the master list, then when I find the correct item, i can then click on the item and the transactions will be displayed in the linked transaction list. But, at the same time the master list is auto refreshed and the correct (find) master record disappears and the first non filtered item now appears on the master list, while the correct transaction for the search is displayed in the linked list. What can I do to insure that the filtered (searched) record remains displayed on the master list.

    Thank you.

    Tuesday, January 19, 2016 3:16 PM
  • Hi Steve,

    I have done test again and I can reproduce your senior.

    When I search for an item then click the Select icon before it, the page will refresh to show all master records, the searched item will be displayed as “Selected”. And at the same time, the correct transaction records will display.

    I haven’t find a solution to solve the issue. But it doesn’t affect the connection.

    Best regards,                                                                                                       

    Aaren liu


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, January 26, 2016 9:56 AM