locked
After Import-spweb Site Theme is grayed out RRS feed

  • Question

  • Hi, 

    i Need to move a sub site to a site collection and when done change the theme to look the same as all the other sites but ran into a issue.

    i Create the destination team site and the theme's work with no issue.

    Then i run my command after which the theme looks like this:

    Why will this happen.

    There was some errors saying it cant over write the Master Page. In total n think 10 errors but will have to load them later. Dont have access to log at the moment.

    Anyone seen this behavior before?

    Thursday, July 18, 2013 5:12 AM

Answers

  • Hi Danie,

    I have a test in my local server with default team site template, export and import the site works well, the theme can be set as expected.

    Based on your description and the error message you have met. I think this issue is related to master page.

    If your site use a custom master page that cause this issue, I would suggest you to try the following workaround:

      • Change the top site to the theme of your choice going to Site Actions > Site Settings > Site Theme.
    1. Navigate to      the top site to see the newly applied theme.
    2. View the HTML      source of the SharePoint page using the theme you want.
    3. Look for a      link tag containing the .css file for the applied theme.  It will      look something like this:
           <link rel="stylesheet" type="text/css" id="onetidThemeCSS"      href="http://SharePoint2010/SITE/_themes/Belltown/Bell1011-65001.css"/>     
    4. Copy the href      value to your clipboard or to a text file if you like.  It should      look something like:
           /SITE/_themes/Belltown/Bell1011-65001.css
    5. On your top      level site, go to the Site Actions > Site Settings > Master Page      screen.
    6. Scroll to the      bottom where the Alternate CSS URL section is.  Select the      "Specify a CSS file..." option.
    7. Paste the      path copied from the href above into the text box.
    8. Check the Reset      all sub-sites to inherit this alternate CSS URL option.
    9. Click OK.
    10. Navigate to      your sub-sites and verify the theme has been applied.

    More information:

    http://answers.oreilly.com/topic/1401-how-themes-work-in-sharepoint-2010/

    Thanks,


    Qiao Wei
    TechNet Community Support


    • Edited by Qiao Wei Friday, July 19, 2013 2:43 AM modify content
    • Marked as answer by Qiao Wei Tuesday, July 23, 2013 3:48 PM
    Friday, July 19, 2013 2:42 AM

All replies

  • Maybe there is another command i can try...
    Thursday, July 18, 2013 5:01 PM
  • Hi Danie,

    I have a test in my local server with default team site template, export and import the site works well, the theme can be set as expected.

    Based on your description and the error message you have met. I think this issue is related to master page.

    If your site use a custom master page that cause this issue, I would suggest you to try the following workaround:

      • Change the top site to the theme of your choice going to Site Actions > Site Settings > Site Theme.
    1. Navigate to      the top site to see the newly applied theme.
    2. View the HTML      source of the SharePoint page using the theme you want.
    3. Look for a      link tag containing the .css file for the applied theme.  It will      look something like this:
           <link rel="stylesheet" type="text/css" id="onetidThemeCSS"      href="http://SharePoint2010/SITE/_themes/Belltown/Bell1011-65001.css"/>     
    4. Copy the href      value to your clipboard or to a text file if you like.  It should      look something like:
           /SITE/_themes/Belltown/Bell1011-65001.css
    5. On your top      level site, go to the Site Actions > Site Settings > Master Page      screen.
    6. Scroll to the      bottom where the Alternate CSS URL section is.  Select the      "Specify a CSS file..." option.
    7. Paste the      path copied from the href above into the text box.
    8. Check the Reset      all sub-sites to inherit this alternate CSS URL option.
    9. Click OK.
    10. Navigate to      your sub-sites and verify the theme has been applied.

    More information:

    http://answers.oreilly.com/topic/1401-how-themes-work-in-sharepoint-2010/

    Thanks,


    Qiao Wei
    TechNet Community Support


    • Edited by Qiao Wei Friday, July 19, 2013 2:43 AM modify content
    • Marked as answer by Qiao Wei Tuesday, July 23, 2013 3:48 PM
    Friday, July 19, 2013 2:42 AM
  • Hi, there is no master page.

    Got kind of a solution...

    i just change the solution before i enable publishing...it then keeps the theme 

    Tuesday, July 23, 2013 7:23 PM
  • I know this is a very old thread but ran into this today and figured out the cause in my case.

    I was exporting a subsite from one site collection and importing into a top level site in a new site collection, the Select Theme settings were all greyed out.  What I had to do was change the Inherit Theme setting of the subsite I was exporting from "Inherit theme from the parent of this site" to "Specify a theme to be used by this site and all sites that inherit from it:".  Then export the subsite.  After importing it into the new site I enabled the publishing features. Now the Inherit Theme settings are no longer greyed out.

    I guess when importing a site SharePoint doesn't check if the site being imported is a top level site or subsite.  Top level sites can't have the Inherit theme from parent option but the when importing it sets this value anyway.

    Tuesday, June 27, 2017 1:33 PM