none
Sharepoint Create Catalog Task fails RRS feed

  • Question

  • Hi,

    at the moment I have the problem that I cannot protect one of my Sharepoint farms.
    In the DPM Protection pane the Protection status is "Backup metadata enumerating failed".
    In the Monitoring pane the status is completed with the description:

    The job completed successfully with the following warning:
    DPM could not resolve the SQL alias S000257\SP2010_INT on the SharePoint front-end web server. (ID 31250 Details: Unknown error (0x80131534) (0x80131534))

    I checked the alias on both WFE servers, there set in 32bit and 64bit and are TCP/IP.
    So I tried to force the sharepoint catalog to populate again with the powershell command:
    Get-ProtectionGroup yourdpmservername |get-datasource |where-object {$_.type -like "*sharepoint*"} | start-createcatalog

    I then get a error message in DPM:

    Type: SharePoint Catalog Task
    Status: Failed
    Description: An unexpected error occurred while the job was running. (ID 104 Details: Unknown error (0x80131534) (0x80131534))
    End time: 21.02.2013 13:22:54
    Start time: 21.02.2013 13:22:54
    Time elapsed: -
    Data transferred: 0 MB (0 bytes)

    In Eventviewer of the DPM I get the warning:

    DPM failed to gather item level catalog for 14 database(s) of the SharePoint Farm SP2010_Int_General\SP2010_Int_Farm_Config on servername. Some of the recovery points for these databases in the farm would be associated with an earlier successful catalog. (ID: 3133)

    I already tried to configuresharepoint.exe again & deleting and adding the Sharepoint to the backup. 
    All VSS writers are stable and No error

    At the moment, I don't know where else to look...

    Thursday, February 21, 2013 12:39 PM

Answers

  • Hi,

    Possible other causes.


    • SharePoint VSS Writer is in failed state.
    • SharePoint VSS Writer isn’t running
     
      To check - from administrative command prompt Run: diskshadow.exe - then list writers, search output for "SharePoint Services Writer"

    • SharePoint farm administrator don’t have SQL Permissions
    • Account used by configuresharepoint –enablesharepointprotection doesn’t have SQL Permissions
    The account used needs to be SharePoint Farm administrator and hold sysadmin role on the SQL Server that is hosting SharePoint Farm databases.
    • SQL alias is used, the alias can’t be ‘translated’ to <SQLServerName>\<InstanceName>
    • SQL alias can be translated to <SQLServerName>\<InstanceName> but SQL Browser on the SQL Server side can’t redirect that string to the port used by that SQL named instance
    • SharePoint 2010 has Search configured and this registry key exists on the SharePoint WFE Server.
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Data Protection Manager\Agent\2.0\SharePointSearchEnumerationEnabled
    The reason for the error is that SharePoint Search protection for SharePoint 2010 has been deprecated in DPM 2010.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Monday, February 25, 2013 3:49 PM
    Moderator

All replies

  • Hi,

    Check the solution in: http://social.technet.microsoft.com/Forums/en-US/dpmsharepointbackup/thread/69782b8d-9d2d-4a74-aabd-63784828d023

    Sounds like a similar issue.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Saturday, February 23, 2013 12:51 AM
    Moderator
  • Hi,

    thanks for the reply.

    I didn't have the error: System.Management.ManagementException: Invalid class in any of the .errlog.
    I still tried to execute the command mofcomp "C:\Program Files (x86)\Microsoft SQL Server\100\Shared\sqlmgmproviderxpsp2up.mof".

    Didn't work for me, still same error message!

    Monday, February 25, 2013 8:58 AM
  • Hi,

    Possible other causes.


    • SharePoint VSS Writer is in failed state.
    • SharePoint VSS Writer isn’t running
     
      To check - from administrative command prompt Run: diskshadow.exe - then list writers, search output for "SharePoint Services Writer"

    • SharePoint farm administrator don’t have SQL Permissions
    • Account used by configuresharepoint –enablesharepointprotection doesn’t have SQL Permissions
    The account used needs to be SharePoint Farm administrator and hold sysadmin role on the SQL Server that is hosting SharePoint Farm databases.
    • SQL alias is used, the alias can’t be ‘translated’ to <SQLServerName>\<InstanceName>
    • SQL alias can be translated to <SQLServerName>\<InstanceName> but SQL Browser on the SQL Server side can’t redirect that string to the port used by that SQL named instance
    • SharePoint 2010 has Search configured and this registry key exists on the SharePoint WFE Server.
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Data Protection Manager\Agent\2.0\SharePointSearchEnumerationEnabled
    The reason for the error is that SharePoint Search protection for SharePoint 2010 has been deprecated in DPM 2010.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Monday, February 25, 2013 3:49 PM
    Moderator
  • I got the wrong user from our sharepoint team, the SharepointFarm Admin I got wasn't in the SQL sysadmin role. After using the right Farm admin account with the right SQL permissions everything worked fine.

    Thank you very much!

    Tuesday, February 26, 2013 3:26 PM