Lync 2010 - simultaneous ringing fails if no Lync client is active RRS feed

  • Question

  • When I set "Simultaneous Ringing" and no other Lync client is logged in, the secondary line rings once, the caller gets a fast busy, the call does not go to voice mail.

    Several scenarios work....
    - Call forwarding, Lync client logged in, Call is forwarded
    - Call forwarding, Lync client logged off, Call is forwarded
    - Call forwarding, Lync EC Phone active on the network, Call is forwarded
    - Simultaneous Ring, Lync client logged in, success
    - Simultaneous Ring, Lync EC Phone active on network, success
    - Simultaneous Ring, Lync client logged off (and Lync EC Phone not active), FAILS - and no VM

    Its like Lync is saying, yes I can ring another device simultaneously since you have an active Lync connection, but if you want a call forwarded when you are not logged into Lync, you should configure forwarding and not simultaneous ringing.

    Is this standard behavour? If not, any ideas what might be wrong?


    Friday, November 15, 2013 7:33 PM

All replies

  • Tom, This is not a standard behaviour. If Lync client is not logged-in, call should ring on 2nd number/contact without any issue. 

    It would be good to capture logs and share.

    Friday, November 15, 2013 9:17 PM
  • I agree with Hemat, this is not standard behavior.  Run the logger on the front ends and review the SIPStack messages you see, that should give insight into why the calls are failing.

    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answer". http://www.swc.com/solutions/unified-communications

    Friday, November 15, 2013 9:36 PM
  • Hi,

    Is there any update on the issue?

    You can refer to this blog to enable logging tool and get trace for troubleshooting.


    Note: Microsoft is providing this information as a convenience to you. The sites are not controlled by Microsoft. Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. Please make sure that you completely understand the risk before retrieving any suggestions from the above link.

    Kent Huang
    TechNet Community Support

    Monday, November 18, 2013 7:50 AM
  • Thanks for the replies everyone. I am tied up with an Exhange installation for a few days and might not get to the log collection until next week.

    Don't worry, I'll be updating everyone  :)


    Monday, November 18, 2013 10:44 PM
  • I have a colleague that opened a ticket with Microsoft on this. I will post a follow up when we get an answer.


    Friday, November 22, 2013 9:34 PM
  • Still tracking on this.

    Currently MS has come back saying that we need to disable "Early Media" on our SIP gateway. IN the holidays now and waiting to find someone that can help us. Will update again later.


    Monday, December 23, 2013 3:11 PM
  • Yes. Disabling Early Media on the gateway should most probably resolve your issue.

    Hire Us : http://www.datsit.in/ Get your first Lync project done absolutely free!

    Monday, December 23, 2013 3:17 PM
  • What type/firmware is your gateway?  Are you waiting to find help with someone that can disable that feature?  Did they explain why they think disabling Early Media will help? 

    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answer". SWC Unified Communications

    Monday, December 23, 2013 3:46 PM
  • Any updates?

    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answer". SWC Unified Communications

    Wednesday, February 19, 2014 4:03 PM
  • I had the same issue with Lync 2013. The problem was that the gateway was not passing all progress messages through to the PSTN (SIP) provider. Since the provider wasn't seeing progress it would not provide ringback and then eventually timeout. Calls would end with a fast busy.

    To solve the issue you need to examine SIP 180, 181, and 183 messages, manipulating them as necessary to ensure that the gateway, Lync and the upstream provider are compatible.

    Unfortunately there is no "one-size-fits-all" solution because the specific settings needed depend on the gateway and whatever is upstream (typically a SIP trunking provider, a PBX or another gateway).

    This Blog post goes over a few scenarios which might be helpful:


    If you have a gateway which is Lync certified, then you should contact the manufacturer for the specific settings you need. If you have a newer Cisco ISR gateway (15.1.4M6), there is an integration guide on the official MS site:


    which mentions the following limitation:

    "No ringback is heard when call is forwarded from a Lync Endpoint to a PSTN Endpoint. This can be corrected by allowing 183 without SDP on the outbound dial-peers to Lync, but this will result in no ring back on regular inbound calls."

    However, this note about "no ringback" is not 100% correct. The limitation on no-ringback when you allow 183 without SDP depends on the upstream side's behavior. For example, our provider is Lync compatible and does do progress (generate ring-back) on SIP 183 messages.

    You also have some ability at the gateway to manipulate those messages into other messages that might work. For example; Cisco:

    voice-class sip map resp-code 181 to 183

    The bottom line is that the gateway needs to do the manipulation of the signalling to make it compatible with both ends. If your gateway is not officially supported it may not have the necessary capability to do this or you may need to do a lot of trial and error to figure it out.

    Tuesday, March 25, 2014 1:18 PM