none
DPM 2016/Server2016 Problem with protecting System State on a Server 2012 R2 server RRS feed

  • Question

  • I have recently migrated some servers from DPM 2016 on Server 2012R2 using legacy storage to our new DPM 2016/Server 2016 box with modern storage.

    Everything is working fine except the System State/BMR on a Hyper V host server running Server 2012R2. I am getting the follwing errors:-

    On DPM: 

    DPM cannot create a backup because Windows Server Backup (WSB) on the protected computer encountered an error (WSB Event ID: 517, WSB Error Code:  0xCEAC8FF0). (ID 30229 Details: Internal error code: 0x80990ED0)

    On the server:-

    Backup of volume C: has failed. Windows Backup encountered an error when accessing the remote shared folder. Please retry the operation after making sure that the remote shared folder is available and accessible.

    I have tried a test backup using Windows Server Backup and it works fine. It also worked on the old server.

    While I was investigating this problem I could see some people are saying you need to raise the size of the disk allocation for DPM, but these options seem to be greyed out in DPM 2016, I'm assuming possibly because of the way modern storage works?

    Has anyone any idea what could be causing this? Other protected servers are doing bare metal backups on this same DPM server just fine?  

    Wednesday, May 3, 2017 11:45 AM

All replies

  • Hi,

    Are you using the newest Update Rollup for SCDPM 2016?


    Michael Seidl (MVP)

    SYSCTR Senior Consultant, Blogger, CEO

    Blog | Twitter | Facebook | LinkedIn | Xing | Youtube

    Note: Posts are provided "AS IS" without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

    Sunday, May 7, 2017 8:47 AM
  • Yes we're on version 5.0.322.0 which is Update Rollup 2
    Monday, May 8, 2017 7:51 AM
  • Hi!

    Same problem here. If I remove protected server from group and re-add it again, then new Bare-Metal BackUp finished without problems. But next backup fails again.

    Friday, June 16, 2017 7:26 AM
  • I never got to the bottom of this one, and actually ended up just not doing a bare metal on it. Other 2008 R2 boxes did work after deleting the temporary windows backup directory and rerunning it, but not on this one. So something must have been screwy with that particular box.
    Friday, June 16, 2017 8:47 AM
  • We have got the same issue. Perhaps someone found a solution or logged a support case?


    Kind regards, Mark

    Tuesday, July 11, 2017 7:30 PM
  • I'm having the same issue.  For the time being I'm just not doing BMR\SS backups, not ideal.
    Wednesday, July 19, 2017 8:34 PM
  • The issues we've seen with BMR backup on DPM 2016 and modern backup storage have mostly been with the initial allocation of storage for the BMR backup. What I also see is if the initial replica creation fails the BMR backup isn't marked in an error state until the first scheduled recovery point is attempted.

    I use this method to either increase the initial replica size or modify based on the size of the data on the C: drive + 10%.

    https://blogs.technet.microsoft.com/dpm/2017/04/14/how-to-increase-dpm-2016-replica-when-using-modern-backup-storage-mbs/

    One of the other strategies (dependent on where the BMR backup fails) I use is to run the bmrbackup.cmd from the protected server (start  /WAIT %SystemRoot%\system32\wbadmin.exe start backup -allcritical -quiet -backuptarget:%1) and substitute the backup target with a share that I've temporarily created on the DPM server to validate that I have no network or firewall factors in play. I also run the wbadmin get status command on the protected server command line as this sometimes provide useful information as to why the failure occurs.

    What I've also seen is that in some cases the -allcritical switch is not just the C: drive, dependent on what application has been installed on the server so the size for the BMR replica can be skewed.

    I've also seen cases where a previous System State backup leaves the WindowsImageBackup folder on the server and this can cause BMR backup called by DPM to fail. I think this was mentioned in another reply to this post.

    Hope this info is useful for anyone troubleshooting BMR backup.

    Wednesday, July 19, 2017 10:03 PM