locked
Windows 7 wallpaper GPO RRS feed

  • Question

  • I have a windows 7 test environment. And i have created GPO's for testing. When i log in with a test PC to the domain i am not getting a proper wallpaper. If i kill explorer.exe i am getting correct wallpaper, and if i run it from task mng then wallpaper is gone. If i log in as a local admin the wallpaper is set properly.

    The wallpaper file is in the correct location “c:\windows\web\wallpaper”

    And the registry is set properly.

    Thanks for the help.

    Friday, June 25, 2010 7:22 PM

Answers

  • This is a known behavior. The Registry key [HKEY_CURRENT_USER\Control Panel\Desktop\WallPaper] is missing and caused this problem. To work around this issue, please create a String Value [HKEY_CURRENT_USER\Control Panel\Desktop\WallPaper] on client and try to set wallpaper.
     
    We can use Group Policy Preference->Registry to deploy this Registry key or use user logon script to deploy this Registry key.

    Arthur Xie - MSFT
    • Marked as answer by Arthur Xie Tuesday, June 29, 2010 5:41 AM
    Monday, June 28, 2010 7:51 AM

All replies

  • This is a known behavior. The Registry key [HKEY_CURRENT_USER\Control Panel\Desktop\WallPaper] is missing and caused this problem. To work around this issue, please create a String Value [HKEY_CURRENT_USER\Control Panel\Desktop\WallPaper] on client and try to set wallpaper.
     
    We can use Group Policy Preference->Registry to deploy this Registry key or use user logon script to deploy this Registry key.

    Arthur Xie - MSFT
    • Marked as answer by Arthur Xie Tuesday, June 29, 2010 5:41 AM
    Monday, June 28, 2010 7:51 AM
  • Thank you for the reply. I need to create "HKEY_CURRENT_USER\Control Panel\Desktop\WallPaper" and point wallpaper to the local .bmp file?

    Thank you and have a good monday everyone.

    Monday, June 28, 2010 3:01 PM
  • Just tried that. That seems to fix the problem.

    Thank you.

    Monday, June 28, 2010 3:02 PM
  • I've tried the same but not work also applied Microsoft Hotfix but not luck.
    Jatin Purohit Ahmedabad-India
    Sunday, July 4, 2010 11:17 AM