locked
All Right click options have disappeared for a user RRS feed

  • Question

  • When in a Windows 7 Explorer all right click options for folders and files are no longer being offered.
    The only feature that still seems to be working is that when you drag a file from one drive to another drive in a different window using right click - it still asks if you want to copy or move the file and behaves properly.

    I have checked whether this malfunction is restricted to this one user by logging on as a different user on the same PC and accessing a windows explorer - here the system works properly by offering all right click option menus for files and folders
    The only other reference to this problem that I have found suggests to try a command line prompt command sfc /scannow  - which I did try and it didn't produce any results at all (Windows Resource Protection did not find any integrity violations).

    Thanks for all suggestions.

    John

    Tuesday, May 27, 2014 9:34 PM

Answers

  • Thank you for your response.

    In answer to your question - All right click functions, including icons on the desktop and Explorer did not have any right click context menu function.

    I did download and use the recommended 3rd party app called shexview.exe but it did not indicate any disabled context menu functions.

    I did find from further research a registry hack that fixed my problem.   It would seem that some unknown program or malware turned off the context menus from functioning but this fixed the problem:

    Manual Registry Hack
    ALWAYS BACKUP YOUR REGISTRY FIRST!
    Open up regedit.exe through the start menu search or run box, and then browse down to the following key (create the key if it does not exist)

        HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    Click on the Explorer key so that it is highlighted and then look on the right side at the top
    See if there is a D word value that is: NoViewContextMenu
    If there is, see below to see if it is turned off or on:
        Enable Context Menus: 0
        Disable Context Menus: 1
    To change the D word, Right Click on NoViewContextMenu and select Modify and change the Value Data to 0 to turn on the menus
    If there is not a D word, create one...
    Create a new 32-bit DWORD value on the right-hand side named NoViewContextMenu with one of these values:

        Enable Context Menus: 0
        Disable Context Menus: 1

    The change should be instant, whether enabling or disabling the context menus.

    Note that this setting could also be set under HKEY_LOCAL_MACHINE as well, so you should check both places if this doesn’t work.

    • Marked as answer by Yolanda Zhu Thursday, June 5, 2014 7:24 AM
    Friday, May 30, 2014 7:54 PM

All replies

  • Hi,

    Are you able to right-click on the desktop? In most cases, issues in a windows explorer are caused

    by incompatible shell extension. We can use shellexView to disable non-Microsoft related extensions

    of Windows Explorer to see what’s going on.

    You can refer to guide in this link:
    http://technet.microsoft.com/en-us/magazine/2009.06.toolbox.aspx

    If you know that you have installed some 3rd party toolbars or application which are related with

    Windows Explorer, you can uninstall them as a test.

    Please Note: The third-party product discussed here is manufactured by a company that is

    independent of Microsoft. We make no warranty, implied or otherwise, regarding this product's

    performance or reliability.


    Yolanda Zhu
    TechNet Community Support

    Wednesday, May 28, 2014 5:38 AM
  • Thank you for your response.

    In answer to your question - All right click functions, including icons on the desktop and Explorer did not have any right click context menu function.

    I did download and use the recommended 3rd party app called shexview.exe but it did not indicate any disabled context menu functions.

    I did find from further research a registry hack that fixed my problem.   It would seem that some unknown program or malware turned off the context menus from functioning but this fixed the problem:

    Manual Registry Hack
    ALWAYS BACKUP YOUR REGISTRY FIRST!
    Open up regedit.exe through the start menu search or run box, and then browse down to the following key (create the key if it does not exist)

        HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    Click on the Explorer key so that it is highlighted and then look on the right side at the top
    See if there is a D word value that is: NoViewContextMenu
    If there is, see below to see if it is turned off or on:
        Enable Context Menus: 0
        Disable Context Menus: 1
    To change the D word, Right Click on NoViewContextMenu and select Modify and change the Value Data to 0 to turn on the menus
    If there is not a D word, create one...
    Create a new 32-bit DWORD value on the right-hand side named NoViewContextMenu with one of these values:

        Enable Context Menus: 0
        Disable Context Menus: 1

    The change should be instant, whether enabling or disabling the context menus.

    Note that this setting could also be set under HKEY_LOCAL_MACHINE as well, so you should check both places if this doesn’t work.

    • Marked as answer by Yolanda Zhu Thursday, June 5, 2014 7:24 AM
    Friday, May 30, 2014 7:54 PM