locked
IE 11 - Compatibility View selected - document mode is "5"? RRS feed

  • Question

  • Hello,

    When I add a website to compatibility view in IE11 (alt-x b) and open f12 developer tools, I would expect the document mode to be listed as 7 (IE7) by default.

    Instead, this particular site is listed as document mode 5 when I check.

    What are possible reasons for document mode 5 being selected instead of doucment mode 7 ?

    What can I check to see why that is happening?

    thanks

    Thursday, October 30, 2014 7:36 AM

All replies

  • refer: http://msdn.microsoft.com/en-us/library/ff955410(v=vs.85).aspx

    "Quirks Mode" = IE5

    You will get Quirks Mode if the page does not declare a valid DOCTYPE...


    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)


    • Edited by DonPick Thursday, October 30, 2014 10:05 AM
    • Marked as answer by IUSR345369 Thursday, October 30, 2014 11:32 AM
    • Unmarked as answer by IUSR345369 Friday, October 31, 2014 12:07 PM
    Thursday, October 30, 2014 10:05 AM
  • Hi Don,

    In fact, the flow chart does not answer the question.

    The website has been added to the compatbility view list. Based on the flow diagram, it should then go to EmulateIE7 mode . But instead, its going to Quirks mode, as if the website has not been added to the list at all.



    • Edited by IUSR345369 Friday, October 31, 2014 12:09 PM
    Friday, October 31, 2014 12:09 PM
  • Hi IUSR345369,

    Do this issue only occur on specific website?
    Please share us the website link that going to use IE5 mode if you willing to.

    I have tested in my environment and can’t find this situation.


    Best regards,
    Fangzhou CHEN


    Fangzhou CHEN
    TechNet Community Support


    Monday, November 3, 2014 11:00 AM
  • It is occuring with an intranet site - its an older version of Microsoft CRM. Interestingly on either IE11 or IE8, it is defaulting to "Quirks mode".

    Cheers

    Tuesday, November 4, 2014 11:39 AM
  • defaulting to "Quirks mode".

    AFAIK that is expected.  Compatibility View = IE7 Quirks mode which is what you are getting.  UAS = IE7 & DM = 5.  If you need something else you might try Enterprise mode.



    Robert Aldwinckle
    ---

    Tuesday, November 4, 2014 9:27 PM
    Answerer
  • Robert,

    Thanks for the reply. Unfortunately I am not a mind reader so can you kindly elaborate on the following acronyms you are referring to:

    UAS -

    DM -

    And can somebody please confirm that document mode 7 = IE7 mode and document mode 5 =  IE5 aka IE7 Quirks mode 

    thanks.


    • Edited by IUSR345369 Wednesday, November 5, 2014 1:50 PM
    Wednesday, November 5, 2014 1:49 PM

  • Hi IUSR345369,

    Does this issue occur in every computer of your environment?
    Does other websites have the similar issue?

    Please take the following steps for troubleshooting:
    1. Open Local Group Policy Editor, go to Administrative Templates\Windows Components\Internet Explorer\Compatibility View and check if we enable the policy Use Policy List of Quirks Mode sites.
    2. Check the html file and see if we have forced the IE11 to display in IE 5 mode.

    Please take a loot at the following article.

    http://msdn.microsoft.com/en-us/library/jj676915(v=vs.85).aspx

    Additionally, we could try to use the Enterprise mode as MVP Robert mentioned .

    Best regards,
    Fangzhou CHEN


    Fangzhou CHEN
    TechNet Community Support


    • Edited by FangZhou Chen Monday, November 17, 2014 2:11 AM
    • Proposed as answer by Michael_LS Tuesday, November 25, 2014 5:47 AM
    Monday, November 10, 2014 6:54 AM