locked
RDP is not working after MS update. RRS feed

  • Question

  • From Private PC to Private PC doesn't connect.

    Remote Desktop Disconnected

    Remote Desktop cannot connect to the remote computer because the authentication certificate received from the remote computer is expired or invalid.  In some cases, this error might also be caused by a large time discrepancy beetween the client and server computers.

    ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

    From Public DynDNS  to Private PC

    Remote Desktop Disconnected

    This computer can't connect to the remote computer.

    Try connecting again. if the problem continues, contact the owner of the remote computer or your network administrator.

    ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

    Troubleshooting.

    telnet x.x.x.x 9999 from Private PC to Private PC does connect.

    telnet z.z.z.z 7777 from  Public DynDNS  to Private PC does connect.

    telnet 127.0.0.1 8888 from Private PC to loop back does connect.

    telnet y.y.y.y  8888 from Private PC to loop back using the IP does connect.

    msconfig -> disable all services except for the MS and still not working

    sfc /scannow -> no errors found

    rstrui -> Review the System Restore points.

    regedit -> HKEY_LOCAL_MACHINE -> SYSTEM -> services -> TermService

     Q&A

    I would like to see if the RDP could be remove and reinstall?

    Note: This RDP is running for years until last one-two MS update(s)

    Note: No new software was install and any other abnormally was happened

    Note: Windows 7 Pro 64 bit

    Wednesday, April 13, 2016 1:45 AM

Answers

  • Sometimes this error might also be caused by a large time discrepancy between the client computers. You could try to check both the date and time on the client machine. The time may be correct, but the date may be incorrect.

    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, April 18, 2016 1:18 AM
  • Hi bastion,

    you can connect from Win 7 pro to win vista but not vice versa

    if you need to connect to another computer via RDC, the host computer must have your user account added to allowed accounts

    please check on the host(target) machine

    1) Control Panel -> System and Security -> System -> Remote Settings(left pane)

    2) Remote -> Allow connections only from computers running Remote Desktop with Network Level Authentication (more secure)

    or

    Allow connections from computers running any version of Remote Desktop (less secure)

    3) Select Users -> Add 'your user account'

    OR

    please check on your(source) machine

    1) RDC -> Options -> Advanced -> Server authentication -> if server authentication fails -> connect and don't warn me

    you are sure you are connecting to your host (and not an impersonator) right ?

    OR

    please check on your(source) machine

    Your system ->Control Panel -> User Accounts and Family Safety -> Credential Manager -> Certificate based credentials -> Remove the certificate for your host system

    Regards

    Monday, April 18, 2016 4:05 PM

All replies

  • What are the error in event logs ? 

    Can you try a clean boot and check the results ? 


    Arnav Sharma | http://arnavsharma.net/ Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by bastion123 Thursday, April 14, 2016 4:04 AM
    • Unmarked as answer by bastion123 Thursday, April 14, 2016 4:04 AM
    Wednesday, April 13, 2016 2:29 AM
  • Sharma,

    I'm already did that step. The Windows 7 get updated again. I did another clean boot. I check the event viewer and no entries were found. The RDP still not working.

    Thanks,  

    Thursday, April 14, 2016 4:06 AM
  • Hi bastion123,

     

    You mentioned that this RDP is running for years until last one-two MS updates, I suppose that the updates may cause the problem, please uninstall the updates and check the result.

     

    I also noticed the error message, in some cases, this error might also be caused by a large time discrepancy between the client computers. Please check both the date and time on the client machine. The time may be correct, but the date incorrect, so check both.

    Refer to the link:

    http://www.sana-tech.net/blog/?p=1677

    Please Note: Since the websites are not hosted by Microsoft, the links may change without notice. Microsoft does not guarantee the accuracy of this information.

     

    Best Regards,

    Tao


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, April 14, 2016 1:05 PM
  • Sharma,

    I checked the date and time in both computer and they are synced correctly. I used another computer out my network to connect using the RDP and I got connected. Now, what else I should be checking.

    The computer at home that I use to connect is a Windows Vista 32-bit. From the Windows Pro 7 I get connected using the RDP perfectly to the Windows Vista 32-bit. However, when I try to connect from Windows Vista 32-bit to the Windows Pro 7, I got the RPD error that I explained here already. Now with this new test and results, what else it could causing this problem?

    Thanks,

    Friday, April 15, 2016 2:17 PM
  • Sometimes this error might also be caused by a large time discrepancy between the client computers. You could try to check both the date and time on the client machine. The time may be correct, but the date may be incorrect.

    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, April 18, 2016 1:18 AM
  • Hi bastion,

    you can connect from Win 7 pro to win vista but not vice versa

    if you need to connect to another computer via RDC, the host computer must have your user account added to allowed accounts

    please check on the host(target) machine

    1) Control Panel -> System and Security -> System -> Remote Settings(left pane)

    2) Remote -> Allow connections only from computers running Remote Desktop with Network Level Authentication (more secure)

    or

    Allow connections from computers running any version of Remote Desktop (less secure)

    3) Select Users -> Add 'your user account'

    OR

    please check on your(source) machine

    1) RDC -> Options -> Advanced -> Server authentication -> if server authentication fails -> connect and don't warn me

    you are sure you are connecting to your host (and not an impersonator) right ?

    OR

    please check on your(source) machine

    Your system ->Control Panel -> User Accounts and Family Safety -> Credential Manager -> Certificate based credentials -> Remove the certificate for your host system

    Regards

    Monday, April 18, 2016 4:05 PM