none
Reporting Services Error during Install RRS feed

  • Question

  • Hi,

    Am trying to set up DPM 2010.  The computer is a Domain Controller because DPM requires a domain.  But it's the only computer on the domain (it's really a web server and I want to be able to back up SQL Server.)

    The server is a 2008 R2 Server on which I installed SQL Server 2008 SP2.  The instance is called MSDPM and I followed the instructions closely for installing everything on a domain controller from here: http://technet.microsoft.com/en-us/library/ff399416.aspx

    Everything has gone well to this point:  When installing DPM on the SQL page, it says:

    Setup has detected that the installation of the Reporting Services is not correctly configured...

    However, as far as I can tell, it is correctly configured.  Reporting Services is set up and running just fine.  I have searched, but haven't found a resolution to this.

    Edit:  Found this in the Application Log:

    Login failed for user 'JET\DPMSQLSvcsAcct'. Reason: Failed to open the explicitly specified database. [CLIENT: <named pipe>]

    Is there a login that I need to add somewhere?  I can open in SSMS just fine.

    Greg
    Friday, March 18, 2011 3:41 AM

Answers

  • The resolution, it turns out, was quite simple.

    The issue was that when specifing an already installed instance of SQL Server, the installer could not connect.  The resolution was to specify in instance name in this manner <computername>\<instancename>, NOT "localhost\"<instancename> and NOT ".\"<instancename>

    Apparently there is some raised security which does not allow the use of "localhost" or the dot to indicate localhost.  As soon as I put in the actual name of the computer, then it connected just fine and installed.

    Greg

    • Marked as answer by Greg Gum Tuesday, March 22, 2011 1:33 AM
    Tuesday, March 22, 2011 1:32 AM

All replies

  • Hi Greg,

    Did you pre-install SQL Reporting services or are you letting the DPM install include SQL and SQL Reporting Services?

    Saturday, March 19, 2011 7:33 AM
    Moderator
  • I have tried letting DPM install SQL Server, but it fails because it is on a Domain Controller.

    So I tried pre-installing SQL Server, which succeeds, but then DPM cannot connect to the Reporting Server even though it is installed.

    In any case, I have contact MS Support for help with this.

    Greg

    • Marked as answer by Greg Gum Tuesday, March 22, 2011 1:33 AM
    • Unmarked as answer by Greg Gum Tuesday, March 22, 2011 1:33 AM
    Saturday, March 19, 2011 9:15 PM
  • The resolution, it turns out, was quite simple.

    The issue was that when specifing an already installed instance of SQL Server, the installer could not connect.  The resolution was to specify in instance name in this manner <computername>\<instancename>, NOT "localhost\"<instancename> and NOT ".\"<instancename>

    Apparently there is some raised security which does not allow the use of "localhost" or the dot to indicate localhost.  As soon as I put in the actual name of the computer, then it connected just fine and installed.

    Greg

    • Marked as answer by Greg Gum Tuesday, March 22, 2011 1:33 AM
    Tuesday, March 22, 2011 1:32 AM
  • I was using a preinstalled instance as you are required to if you are installing on a domain controller.  In any case, this is now resolved (see other post.)

    Greg

    Wednesday, March 23, 2011 10:46 PM