locked
Windows 7 Performance Issues RRS feed

  • Question

  • We are having a ton of performance issues post - XP upgrade to Win7 Pro

    I just upgraded to SP1 but this did not resolve any issues, might have made them worse. We are a simple small business with 30 users, LAN 1 class C subnet. Windows 2008R2 AD/DNS/Print Server

    Printers are pushed out via GP. 

    Ever since upgrade - office 2010 is slow. Local word doc's freeze when opening. If you try to print to a non-default printer there is this lag on pulling up the printer and then printing. Very slow. 

    I am just shocked that we are having more performance issue post the upgrade to Windows 7. XP users do not experience the same issues Office/Printing.. that we are having in Windows 7 64bit machines. Any ideas - must be services running or something that is causing it?

    Also - we upgraded to Win7 with new machines. 64Bit, 4GB ram, E5 Intel Processors. Machines running 32bit Office 2010. 

    Thanks,

    SJMP

    Tuesday, May 10, 2011 1:42 PM

Answers

  • The issue seems to be rooted in the Bluetooth services - specifically the Bluetooth Support Service - this "discovery device service" when stopped will also disable your ability to view or discover any local/network printers. So this is a bug with Windows 7 - Bluetooth device discovery should be at the end of the line, not at the top. 

    I finally disabled and uninstalled all bluetooth software that came built in with Windows 7 - once the device software was remove I was able to see my printers again - and my networking issue has been resolved. 

     

    BLUETOOTH SUPPORT SERVICE -was responsible for 80% of the performance issues. Take Note - Microsoft. People in office dont give a crap about Bluetooth support when they are working on their desktops.

     

    SJMP

    • Marked as answer by SJMP Tuesday, May 17, 2011 12:13 PM
    Tuesday, May 17, 2011 12:13 PM

All replies

  • Hi,

     

    Thanks for posting in Microsoft TechNet forums.

     

    Please disable two Microsoft Services to check the result:

     

    “Function Discovery Resource Publication” and “Function Discovery Provider Host”

     

    1. Click the Start Button type "msconfig" (without quotation marks) in the Start Search box, and then press Enter.

     

    Note: If prompted, please click Continue on the User Account Control (UAC) window.

     

    2. Click the "Services" tab, uncheck the boxes before “Function Discovery Resource Publication” and “Function Discovery Provider Host” services.

     

    If the issue persists, let us prepare clean boot to troubleshoot.

     

    Best Regards

    Magon Liu

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Wednesday, May 11, 2011 5:56 AM
  • Thanks for the Reply Magon - those services where already stopped. 

    Two things I have noticed - my NIC is not being initialized by Windows until way past logon - first problem. 

    THanks,

    Scott

    Wednesday, May 11, 2011 12:05 PM
  • Hi Scott,

    The performance issue could due to incompatible device driver, like you said, NIC driver could be one of the root cause. Based on my experience, 64 bit system is more infected by such issues.

    At this point, it is suggested visiting the device manufacture's website and install the latest compatible driver for Windows 7. All devices including NIC, Audio card, Chipset etc..

    If there is no driver for Windows 7, suggest install the old version in compatible mode.

    Another possibility is conflict with third party services. Let us prepare clean boot to troubleshoot the issue.

    Regards,

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Thursday, May 12, 2011 4:41 AM
  • These are Dell and Lenovo desktops/laptops with compatible and fully up to date drives from the Manufacturer I already did this before opening this thread. 

    The only other services - HP, Symantec (AV only - no other app), iTunes, Office 2010. Adobe Pro.....

    Thursday, May 12, 2011 2:45 PM
  • we are talking about a company upgrade - no machines were upgraded - new machines were purchased with windows 7  
    Thursday, May 12, 2011 4:45 PM
  • The only other services - HP, Symantec (AV only - no other app), iTunes, Office 2010. Adobe Pro.....

    Hi Scott,

    I recommend we continue the troubleshooting by disabling the services you mentioned above as it is hard for us to know accurate information of a third party product behaviouring on the Windows system.

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Tuesday, May 17, 2011 5:00 AM
  • The issue seems to be rooted in the Bluetooth services - specifically the Bluetooth Support Service - this "discovery device service" when stopped will also disable your ability to view or discover any local/network printers. So this is a bug with Windows 7 - Bluetooth device discovery should be at the end of the line, not at the top. 

    I finally disabled and uninstalled all bluetooth software that came built in with Windows 7 - once the device software was remove I was able to see my printers again - and my networking issue has been resolved. 

     

    BLUETOOTH SUPPORT SERVICE -was responsible for 80% of the performance issues. Take Note - Microsoft. People in office dont give a crap about Bluetooth support when they are working on their desktops.

     

    SJMP

    • Marked as answer by SJMP Tuesday, May 17, 2011 12:13 PM
    Tuesday, May 17, 2011 12:13 PM