none
Cannot start the Administration Utility on CentOS MapR Cluster RRS feed

  • Question

  • Hi there,  I am having trouble to set up the enterprise configuration to run code remotely.

    I do have a problem starting up the Administrator Utility on CentOS. The following error appears:

    # cd /opt/microsoft/mlserver/9.2.1/o16n
    #dotnet Microsoft.MLServer.Utils.AdminUtil/Microsoft.MLServer.Utils.AdminUtil.dll

    It was not possible to find any compatible framework version
    The specified framework 'Microsoft.NETCore.App', version '1.1.0' was not found.
      - Check application dependencies and target a framework version installed at:
          /
      - Alternatively, install the framework version '1.1.0'.


    I did already try a lot of things but actually, I can't find the appropriate framework version for CentOS. Atm. I am on the newest version of dotnet for CentOS (it seems there is no backward compatibility).

    #dotnet --info
    .NET Command Line Tools (2.0.3)

    Product Information:
     Version:            2.0.3
     Commit SHA-1 hash:  eb1d5ee318

    Runtime Environment:
     OS Name:     centos
     OS Version:  7
     OS Platform: Linux
     RID:         centos.7-x64
     Base Path:   /usr/share/dotnet/sdk/2.0.3/

    Microsoft .NET Core Shared Framework Host

      Version  : 2.0.3
      Build    : a9190d4a75f4a982ae4b4fa8d1a24526566c69df


    • Edited by GoldSte88 Friday, December 1, 2017 10:19 AM
    Friday, December 1, 2017 7:30 AM

All replies

  • Hello there, yes you are right. the dotnet core versions are not backward compatible. the Microsoft ML Server requires dotnet core 1.1 version and does not work with other versions. Most probably, you will have dotnet core 1.1 installed on your machine, which may have been masked now by dotnet core 2.0. 

    You can either (1) Uninstall dotnet core 2.0 if you dont need it, and see if previous dotnet core 1.1 gets unmasked. OR (2) Install dotnet core 1.1 again, using instructions here: https://github.com/dotnet/core/blob/master/release-notes/download-archives/1.1.5.md

    Friday, December 1, 2017 6:50 PM
  • Hello,

    Machine Learning Server has a dependency in dot net core 1.1.0 that should be present in the install path if you followed the installation instructions: https://docs.microsoft.com/en-us/machine-learning-server/install/machine-learning-server-linux-install 

    Try this:

    cd /opt/microsoft/mlserver/9.2.1/o16n
    sudo dotnet Microsoft.MLServer.Utils.AdminUtil/Microsoft.MLServer.Utils.AdminUtil.dll
    (https://docs.microsoft.com/en-us/machine-learning-server/operationalize/configure-machine-learning-server-enterprise) 

    Friday, December 1, 2017 11:56 PM
  • Well, still doesn't work with 1.1.5:

    .NET Command Line Tools (1.1.5)

    Product Information:
     Version:            1.1.5
     Commit SHA-1 hash:  2b517ddd29

    Runtime Environment:
     OS Name:     centos
     OS Version:  7
     OS Platform: Linux
     RID:         centos.7-x64
     Base Path:   /root/dotnet/sdk/1.1.5

    Microsoft .NET Core Shared Framework Host

      Version  : 1.1.0
      Build    : 928f77c4bc3f49d892459992fb6e1d5542cb5e86

    dotnet Microsoft.MLServer.Utils.AdminUtil\Microsoft.MLServer.Utils.AdminUtil.dll

    Welcome to .NET Core!
    ---------------------
    Learn more about .NET Core @ https://aka.ms/dotnet-docs. Use dotnet --help to see available commands or go to https://aka.ms/dotnet-cli-docs.

    Telemetry
    --------------
    The .NET Core tools collect usage data in order to improve your experience. The data is anonymous and does not include command-line arguments. The data is collected by Microsoft and shared with the community.
    You can opt out of telemetry by setting a DOTNET_CLI_TELEMETRY_OPTOUT environment variable to 1 using your favorite shell.
    You can read more about .NET Core tools telemetry @ https://aka.ms/dotnet-cli-telemetry.

    Configuring...
    -------------------
    A command is running to initially populate your local package cache, to improve restore speed and enable offline access. This command will take up to a minute to complete and will only happen once.
    Decompressing 100% 6145 ms
    Expanding 100% 7702 ms
    No executable found matching command "dotnet-Microsoft.MLServer.Utils.AdminUtilMicrosoft.MLServer.Utils.AdminUtil.dll"



    • Edited by GoldSte88 Tuesday, December 5, 2017 8:21 AM
    Monday, December 4, 2017 2:36 PM