none
Windows 10: "Sync your settings" option greyed out for domain users RRS feed

  • Question

  • Hi All,
    we have an issue with the "Sync your settings" option; it is greyed out for all domain users, even if the domain user has connected a Microsoft account for other apps (e-mail, calendar, store, etc.)

    There is no GPO configured for this option, but the option is disabled.
    We have tested this issue on the build 1703 and 1803.
    Any idea?
    Thanks

    Thursday, May 3, 2018 12:33 PM

All replies

  • I believe this is normal behavior because they connected to domain.

    Try sign out from Microsoft Account and then sign in again.

    Also test if you are not connected to domain, is it working or not?

    Thursday, May 3, 2018 2:22 PM
  • I believe this is normal behavior because they connected to domain.

    So domain joined PCs, can't sync settings even with a Microsoft account configured?

    Try sign out from Microsoft Account and then sign in again.

    Same problem.

    Also test if you are not connected to domain, is it working or not?

    Same problem.

    Anyway, If I add the Microsoft account as a sign-in account and I enter on Windows as that user, all works fine.

    Thursday, May 3, 2018 3:05 PM
  • Hi thenewmessiah,

    I’m afraid that it does. According to the Microsoft website provided, if your machine is domain joined, you will notice your "Sync my settings" option is disabled for your MSA account. Please check the issue in the link below I posted.

    "Sync your settings" options are unavailable

    https://social.technet.microsoft.com/Forums/windows/en-US/e5926328-5f9e-4317-9fb5-8d7f55dec68d/sync-your-settings-options-are-unavailable-linked-account-issue?forum=win10itprogeneral

    Regards,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, May 4, 2018 9:28 AM
    Moderator
  • I’m afraid that it does. According to the Microsoft website provided, if your machine is domain joined, you will notice your "Sync my settings" option is disabled for your MSA account. 

    Thanks for your reply.
    Isn't clear if this is a bug or Microsoft removed this function for domain users.
    Anyway, I have checked my registry key under "Computer\HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\SettingSync\Groups\" and the "Enabled"   value is set to 1 to all keys except for "Computer\HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\SettingSync\Groups\AppSync".
    If I manually change the value to "1" for "Computer\HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\SettingSync\Groups\AppSync", nothing changes.

    I was trying to replace Chrome with Edge, but this seems an hard work for those who sync settings across devices.

    Friday, May 4, 2018 3:00 PM
  • Sync settings should be available for all users. Settings from a domain should not be allowed to be overridden by changes not allowed within the domain, but for allowed changes, users should get the same settings on their work and private devices. That is what I would want and expected. If you also expect that, please vote up this request.
    Tuesday, June 12, 2018 4:00 PM
  • All my settings is "on" - but still grayed out.

    Solution: Open "Run" and write 'ms-settings:sync' - same control panel but this time not grayed out - works for me :-)

    Thursday, July 5, 2018 11:45 AM
  • All my settings is "on" - but still grayed out.

    Solution: Open "Run" and write 'ms-settings:sync' - same control panel but this time not grayed out - works for me :-)

    Not a solution for me.

    Same problem.

    Friday, September 14, 2018 10:00 AM
  • Same problem here on my new computer with Windows 10 1803.

    I don't have this problem on my old PC with Windows 1709. On that one I can Sync all.
    That old PC was Windows 8 and upgraded to Windows 10 and all the upgrades since then.


    Kind regards / Met vriendelijke groet, IS Group Rob Mulder Kantoorautomatiseerder Wielingenstraat 8 T 0299 476 185 1441 ZR Purmerend F 0299 476 288 www.is.nl / www.isenterprise.com KvK Hoorn 36049256

    Friday, September 14, 2018 10:42 AM
  • Same problem here! 

    I looked at the key from an account (on another machine) that has sync settings enabled.  One thing that jumps out at me is that the "Flags" field on the working key is "50000643" but it's 40100443 or 40100643 on other accounts on this machine with sync settings disabled. 

    Also, LatestDPAPIKeyVersion on the working account reg key is "1533515726" but on the other local machine greyed-out sync setting user account keys, it's 1437158669 or 1537424260.

    Does anyone know if this is where the problem lies?  I am not able to test this out by changing the key on the user with the greyed out sync settings to "50000643", or make the same change with the LatestDPAPIKeyVersion, and, frankly, I wouldn't be surprised if something broke... Hope this helps someone else figure out the solution.

    [HKEY_USERS\.DEFAULT\Software\Microsoft\IdentityCRL\StoredIdentities\outlook.com\S-1-5-21-xxxxxxxxxx]

    "AccountType"="LocalConnected"
    "Keywords"="Associated;Connected"
    "Flags"="50000643"
    "FamilyID"="xxxxx"
    "LatestDPAPIKeyVersion"="1533515726"
    "FirstName"="xxxx"
    "ChildFlags"="00000000"
    "LastName"="xxxx"
    "DisplayName"="xxxx"
    "DefaultCredSaved"="Persisted"
    "CertHash"="xxx"
    "ContainerName"="IDENTITYCRL_CERT_CONTAINER_xxxxx"

    Boo hiss Microsoft for making this change!  >:(

    R




    • Edited by rkflum Sunday, September 23, 2018 7:38 AM
    Sunday, September 23, 2018 6:23 AM
  • I figured out a work-around to get it working on domain accounts.  Not sure if the sync is working 100%, but one of my users will give me feedback in the next couple days.

    Here are the steps in general:
    1. Add Microsoft Account to a local admin/user account on the PC and make sure the Sync toggle is blue.
    2. Open regedt32.exe and navigate to[HKEY_USERS\.DEFAULT\Software\Microsoft\IdentityCRL\StoredIdentities\
    3. Find the appropriate xxxxxx.com container, right-click and export registry to local C drive.
    4. Log out of local account and sign back in with Domain User account.
    5. Add Microsoft Account to Domain User account. Sync toggle will still be grey.
    6. Find exported reg key and change the SID value to the current domain user's
     (To find the SID, open cmd.exe and enter the command:  wmic useraccount where name="USER" get sid ) where USER is domain account name, keep the quotes.
    7. Save the file to your Desktop because you won't be able to overwrite the original on C:\
    8. Double-click the Reg file to inject the code.
    9. Launch regedt32.exe and navigate to [HKEY_USERS\.DEFAULT\Software\Microsoft\IdentityCRL\StoredIdentities\
    10. Confirm the new container is in the registry.
    11. Close all programs and log out/restart.
    12. Sign back in and open Sync Settings from the Windows Search bar.  Toggle should be blue and 'ON'

    *There seems to be a bug in Windows 10 when a Microsoft Account is linked to the built-in Administrator account, the option to 'Remove' is gone, and only 'Manage' is available*
    To fully remove the Microsoft account from the built-in Administrator account:
    1. Open regedt32.exe and delete the SID container for the local account. 
    2. Open Control Panel\System and Security\System\ and open Advanced System Settings.
    3. Go to User Profiles - Settings, and delete the Administrator account.  Windows will confirm that it cannot completely delete the folder, which is fine.  (If you are not allowed to delete/recreate the Built-in Administrator account, make sure to do this entire procedure with a newly created local administrator account).
    4. When you sign back in with the Administrator account, you should be presented with a new Welcome screen, and no trace of the Microsoft account.

    If you have any questions pleaset let me know!

    • Edited by Hideki Komine Thursday, October 18, 2018 11:49 PM formmating issues
    • Proposed as answer by Wmeerkerk Wednesday, February 27, 2019 3:11 PM
    Thursday, October 18, 2018 11:46 PM
  • Wow that's a complicated work-around for something that used to work simply.

    Daryl Sensenig Tents For Rent

    Monday, November 26, 2018 7:40 PM
  • Well, this enables syncing on 1809. [s]But the sync settings are still greyed out :D[/s] Sometimes they 'r not...

    • Edited by Wmeerkerk Wednesday, February 27, 2019 3:56 PM
    Wednesday, February 27, 2019 3:12 PM
  • Thank you, it worked for me.

    It has been the only way, no group policy or regedit has worked before.

    Thank you much!

    Sunday, March 3, 2019 7:41 PM
  • The last info we have from Microsoft: Windows 10 in Domain is by design that Sync MSA disabled.

    Monday, September 2, 2019 7:02 PM
  • Any/All greyd out service means the service is available,but needs to be configured to the OS....

    Best bet,open control-panel/Administrator Tools/Event Viewer/System/Expand the tree/locate the Warning-Error/Properties/let the OS tell you the fault(s).....

    Monday, September 2, 2019 7:32 PM
  • The last info we have from Microsoft: Windows 10 in Domain is by design that Sync MSA disabled.

    I wonder if the intent is that we join the PC to Azure-AD? This is not well explained so far as I can tell...
    Thursday, October 31, 2019 1:54 PM
  • Bummer!  Same issue.
    Friday, November 1, 2019 11:20 PM