locked
Getting an error message as Project Server Service Application PSError: GeneralQueueJobFailed (26000) when i tried to publish the project RRS feed

  • Question

  • PSI: [QUEUE] System.Data.SqlClient.SqlException: Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding. at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection) at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj) at System.Data.SqlClient.TdsParserStateObject.ReadSniError(TdsParserStateObject stateObj, UInt32 error) at System.Data.SqlClient.TdsParserStateObject.ReadSni(DbAsyncResult asyncResult, TdsParserStateObject stateObj) at System.Data.SqlClient.TdsParserStateObject.ReadNetworkPacket() at System.Data.SqlClient.TdsParserStateObject.ReadBuffer() at System.Data.SqlClient.TdsParserStateObject.ReadByte() at System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj) at System.Data.SqlClient.SqlCommand.FinishExecuteReader(SqlDataReader ds, RunBehavior runBehavior, String resetOptionsString) at System.Data.SqlClient.SqlCommand.RunExecuteReaderTds(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, Boolean async) at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method, DbAsyncResult result) at System.Data.SqlClient.SqlCommand.InternalExecuteNonQuery(DbAsyncResult result, String methodName, Boolean sendToPipe) at System.Data.SqlClient.SqlCommand.ExecuteNonQuery() at Microsoft.Office.Project.Server.DataAccessLayer.DAL.SubDal.ExecuteStoredProcedureReturnVal(String storedProcedureName, SqlParameter[] parameters) at Microsoft.Office.Project.Server.DataAccessLayer.ProjectDal.PublishProject(Guid projUID, Int32 lastPubRev, Int32 lastSumRev, Int32 state, Int32 opcode, Int32& value, String& stageName) at Microsoft.Office.Project.Server.BusinessLayer.Queue.ProcessPublishMessage.ProcessPublishProjectMessage(Message msg, Group messageGroup, JobTicket jobTicket, MessageContext mContext)

    I have followed the solution suggested in msdn forum http://blogs.msdn.com/b/brismith/archive/2009/07/31/project-server-2007-timeout-settings.aspx, even after increasing i am still getting the same error when i tried to publish the project.

    Does anyone have idea on this.

    Thanks

    Sunitha

    Wednesday, January 18, 2012 7:33 AM

All replies

  •  

    Hi,

    Did check Manage Queue Job, there might be job stuck there or restart Microsoft Project Queue Service.

     


    Thanks, Kashif
    Wednesday, January 18, 2012 8:14 AM
  • I had exactly the same issue a while ago and Brian's post did fix it for me, i did make a mistake with the value whilst editing the Registry and made the value 6000 in stead of 60000. 

    Maybe you have already re-checked but it might just be a simple typo!!

    Sorry i cant help more

    Andre


    http://av-epm.blogspot.com
    Wednesday, January 18, 2012 11:04 AM
  • You can try one more thing, change executionTimeout in web.config. just look out for this maxRequestLength in the web.config and modify it to something like this

      <httpRuntime maxRequestLength="51200" executionTimeout="300" />

    May be this solves your problem.

     


    Thanks, Kashif
    Wednesday, January 18, 2012 6:14 PM
  • I have followed the solution suggested in msdn forum http://blogs.msdn.com/b/brismith/archive/2009/07/31/project-server-2007-timeout-settings.aspx.

    changed the defalut value from 30minutes to 90minutes. after changes when i published the project, the project get Sql Timeout after 30mins not after 90mins.The value which i have changed is not reflecting.

    Does any one have idea on this?

    Thanks,

    Sunitha


    • Edited by Sunitha vv Friday, February 10, 2012 10:04 AM
    Friday, February 10, 2012 10:04 AM
  • Did you change IIS connection timeout setting? Secondly, did you try changiing web.config's executionTimeout as mentioned above.

    Thanks, Kashif

    Friday, February 10, 2012 10:28 AM
  • I made changes to the IIS and ASP.NET connection timeout setting,but didnt find the 2nd option

    ie., The HKCU hive of the Windows registry, didnt find the path

    \HKCU\Software\Microsoft\Office\12.0\MS Project\Settings\

    in my server i am able to see till \HKCU\Software\Microsoft\.

    Do i have to change the Webconfig of the WCF service which we are using or something else?

    Thanks,

    Sunitha

    Friday, February 10, 2012 10:40 AM
  • Are you working on PS 2010? If yes, follow this

    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\MS Project\Settings

    For web.config of your root sharepoint directory follow this path.

    C:\inetpub\wwwroot\wss\VirtualDirectories\80\web.config

    Modify the httpRuntime.

    <httpRuntime maxRequestLength="51200" executionTimeout="300" />

    Try this and we'll see what else can be done :)


    Thanks, Kashif

    Friday, February 10, 2012 10:49 AM
  • Yes, i am working on PS2010.

    in my server i am able to see till HKEY_CURRENT_USER\Software\Microsoft\

    Thanks,

    Sunitha

    Friday, February 10, 2012 2:15 PM
  • You might not have MS Project, did you try other solution? Secondly are you publishing the project through PSI? If yes, show your code please.


    Thanks, Kashif

    Friday, February 10, 2012 2:37 PM
  • I have a similar problem but when using a specific view in the Project Center.

    I get the Timeout error in the ULS and the Project Center doesn't load any project and says that's been an error.

    I've checked the executionTimeout in the web.config and it is 3600 seconds

    I found this post in the Brian Smith's blog: http://blogs.msdn.com/b/brismith/archive/2009/07/31/project-server-2007-timeout-settings.aspx

    In the Project Server Published database the setting in the MSP_WEB_ADMIN table for WADMIN_CORE_SQL_TIMEOUT is 30 seconds only. He says that this value should be increased (PS2007)

    Could this be the problem? Can this value be increased? Manually? Do you loose the Microsoft support?

    Thanks

    Tuesday, May 8, 2012 11:57 AM
  • I am never in favor of increasing a timeout if it is just covering up a more serious problem - so the best thing is to only use any timeout change as a last resort or a troubleshooting step.  Please review the database maintenance plan recommendations for Project Server at http://technet.microsoft.com/en-us/library/cc973097.aspx to ensure that SQL Server is able to respond quickly.  Most performance issues we investigate come down to poor DB maintenance - usually fragmented indexes or out of date statistics.  Also review the recommended DB settings at http://technet.microsoft.com/en-us/library/ee662107.aspx.

    To Josep's point - if you do find the need to change a setting in the database then this would not invalidate your support - provided it was returned to the normal vaue if requested by Microsoft.  Also if you think it is something the Support Engineer needs to consider as part of assisting you - then please tell them all such changes you have made.

    Best regards,

    Brian.


    Blog | Facebook | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page

    Wednesday, May 9, 2012 5:47 PM
  • Hi Brian,

    I've finally increased the WADMIN_CORE_SQL_TIMEOUT value to 300 with PowerShell and the GetDatabaseTimeout method (I guess this doesn't break the support) but the views are still giving me the timeout error.

    I have already checked the recommended DB settings but the result is the same -> Timeout error.

    The only thing I've not done yet is to rebuild and defragment the indexes. I'll check that

    Thursday, May 10, 2012 7:29 AM
  • Update to my previous post.

    Checking the index fragmentation in the Project Server databases I have seen that there are a few indexes in each database with a fragmentation higher than 90% and much others between 50% - 90%.

    Now we are planning when to do the index defragmentation in order to improve the performance.

    I'll keep you updated

    Thursday, May 10, 2012 11:19 AM
  • After running the database maintenance plan it seems everything is working well now and I'm not getting any timeout using the views with filters
    Tuesday, May 15, 2012 3:57 PM
  • Hi Sunitha,

    Check below link ,might be usse full for your isue.

    http://blogs.msdn.com/b/brismith/archive/2009/07/31/project-server-2007-timeout-settings.aspx


    Hasan Jamal Siddiqui(MCTS,MCPD,ITIL@V3),Sharepoint and EPM Consultant,TCS

    Thursday, January 2, 2014 9:23 AM