locked
Windows Search returns no results after indexing external hard drive RRS feed

  • Question

  • I have music files on an external hard drive that are compressed in zip files.  After doing many lengthy searches on this drive, I decided to try indexing it.  Unfortunately, after I did that, I get zero search results every time.  I've played with the settings to ensure that zip files were included in the index and I rebuilt the index.  I've tried showing hidden files and folders.  I tried to include non-indexed, hidden and system files in the advanced search.  Sometimes that helped but sometimes it didn't.  It seems to only find the files if they are in the current open folder and I have the advanced search option checked to include non-indexed or hidden file.  I have the option checked to include subfolders in the index too.  I tried unchecking the folder to remove the index, but I still can't get any search results.  I might try renaming the drive letter of the external drive to see if that gives me a clean slate.  I just restored my operating system to factory settings and I really don't want to have to do that again because of this annoying problem.  I really need to be able to search for files on this external drive. 
    Tuesday, March 17, 2009 12:39 PM

Answers

  •  

    In order to bypass this issue, I changed the drive letter of my external hard drive.  This resolved the issue and so far the only ramification is that I had to clear the database in my music software and reimport the files.  The steps to change the drive letter in Vista is as follows.  This step is similar in XP as well. 

    1) Click Start
    2) Right-click My Computer and select Manage
    3) Click Disk Management (Under Storage)

    4) Right-click the drive you want to change

    5) Select Change Drive Letter and Paths…

    6) Click Change.

    7) Select a letter in the drop-down list. 

    8) Click OK.

     

    Note: If you have any shortcuts pointed to the previous drive letter, they will no longer work.  If you have any databases pointing to the drive, then you may need to clear the database and import the files again.

    Monday, March 23, 2009 8:05 PM

All replies

  •  

    Hi WendyRenee, I'd like to inform you that the Index will not search through external devices. We should be able to do a non-indexed search through Advanced Search.

    Hope this helps!


    Sean Zhu - MSFT
    Thursday, March 19, 2009 7:11 AM
    Moderator
  •  

    In order to bypass this issue, I changed the drive letter of my external hard drive.  This resolved the issue and so far the only ramification is that I had to clear the database in my music software and reimport the files.  The steps to change the drive letter in Vista is as follows.  This step is similar in XP as well. 

    1) Click Start
    2) Right-click My Computer and select Manage
    3) Click Disk Management (Under Storage)

    4) Right-click the drive you want to change

    5) Select Change Drive Letter and Paths…

    6) Click Change.

    7) Select a letter in the drop-down list. 

    8) Click OK.

     

    Note: If you have any shortcuts pointed to the previous drive letter, they will no longer work.  If you have any databases pointing to the drive, then you may need to clear the database and import the files again.

    Monday, March 23, 2009 8:05 PM
  • I'm using windows vista
    I indexed my ext hard drive and, as above, couldn't search on it afterwards.
    To "unindex" the drive, I opened the "indexing options" window. In here, I removed my external hard drive from the list of included locations.
    This seems to have "unindexed" the drive. I can now search the drive as before, without having to change the drive letter.

    Thursday, August 27, 2009 1:25 PM