none
DPM 2012 SP1 Upgrade fails with operating system is Window 2003 IA64 error RRS feed

  • Question

  • Trying to upgrade DPM 2012 to DPM 2012 SP1. I installed Update Rollup 3 before trying the upgrade. I don't want to remove Reporting Services to fix this error.

    Windows OS is Windows 2008 R2.

    SQL server is a local install of SQL Standard 2008 R2 SP1 with Reporting Services.

    Error Message:

    Exception summary:
    The following is an exception stack listing the exceptions in outermost to innermost order
    Inner exceptions are being indented

    Exception type: Microsoft.SqlServer.Configuration.RulesEngineExtension.RulesEngineRuleFailureException
        Message:
            The operating system is Window 2003 IA64. Reporting Service 2008 R2 is not supported on Window 2003 IA64.  Please remove Reporting Services from the list of features to install.
        Data:
          SQL.Setup.FailureCategory = RuleViolationFailure
          DisableWatson = true
        Stack:
            at Microsoft.SqlServer.Configuration.RulesEngineExtension.RunRulesAction.ExecuteAction(String actionId)
            at Microsoft.SqlServer.Chainer.Infrastructure.Action.Execute(String actionId, TextWriter errorStream)
            at Microsoft.SqlServer.Setup.Chainer.Workflow.ActionInvocation.ExecuteActionHelper(TextWriter statusStream, ISequencedAction actionToRun)

    Friday, January 4, 2013 1:53 AM

Answers

  • I had a friend with a similar issue today. This is how he fixed it. It fixed another issue i had.

    1. Backup the Database in the command prompt, DPMBackup.exe -db, located at Microsoft Data Protection Manager\DPM\bin .

    2. The backup will live in Microsoft Data Protection Manager\DPM\Volumes\ShadowCopy\Database - copy this folder to a folder in the root of the C drive.

    3. Uninstall DPM 2012 select the option to retain the data.

    4. Uninstall all SQL stuff on the DPM box.

    5. Reboot

    6. Install DPM 2012, without SP1. During the upgrade select the option to use windows updates

    7. Don't open DPM at all. Run this command to restore the database by typing - DpmSync –restoredb –dbloc <DPMDB location>

    8. Run this command DpmSync -sync

    9. Run windows updates and install any DPM updates. Do not install any SQL updates.

    10. Then run the SCCM 2012 SP1 upgrade.

    11. Once thats done (it should work now) perform a consistency check.

    • Marked as answer by nrsc1 Sunday, January 20, 2013 5:13 PM
    Tuesday, January 8, 2013 11:18 PM

All replies

  • I am having the same issue.
    Tuesday, January 8, 2013 10:54 PM
  • I had a friend with a similar issue today. This is how he fixed it. It fixed another issue i had.

    1. Backup the Database in the command prompt, DPMBackup.exe -db, located at Microsoft Data Protection Manager\DPM\bin .

    2. The backup will live in Microsoft Data Protection Manager\DPM\Volumes\ShadowCopy\Database - copy this folder to a folder in the root of the C drive.

    3. Uninstall DPM 2012 select the option to retain the data.

    4. Uninstall all SQL stuff on the DPM box.

    5. Reboot

    6. Install DPM 2012, without SP1. During the upgrade select the option to use windows updates

    7. Don't open DPM at all. Run this command to restore the database by typing - DpmSync –restoredb –dbloc <DPMDB location>

    8. Run this command DpmSync -sync

    9. Run windows updates and install any DPM updates. Do not install any SQL updates.

    10. Then run the SCCM 2012 SP1 upgrade.

    11. Once thats done (it should work now) perform a consistency check.

    • Marked as answer by nrsc1 Sunday, January 20, 2013 5:13 PM
    Tuesday, January 8, 2013 11:18 PM
  • I was able to get the install to work by doing a repair of SQL, then installing SP2 from the DPM install media at SCDPM\SQLSVR2008R2SP2\SP

    After that and a reboot, I was able to install SP1

    Monday, January 21, 2013 10:15 PM
  • Right Size Solutions Answer worked for me as well.

    Tuesday, February 5, 2013 12:03 PM
  • Repairing SQL then re-running DPM SP1 worked for me.
    Thursday, April 18, 2013 2:21 PM