none
Missing api-ms-win-core-* DLLs RRS feed

  • Question

  • G'day. Running MDT 2013 and the new ADK. Successfully captured a Windows 7 64 bit reference image but the create media task fails the last step with "BCDedit returned an error" and the .iso is not created. Copying the content directory to a bootable USB doesn't start the deploy sequence when executed - just kicks out a Windows error.

    Manually running the 'GenerateMedia.ps1' script pauses at an error stating that: 'api-ms-win-core-libraryloader-l1-1-1.dll' 

    could not be found - and it is indeed not on the Windows 7 computer I am using. Is this a Windows 8 dll and does this mean we can't use this feature for Windows 7 anymore?

    Thanks.

    • Moved by Hart Wang Friday, October 21, 2016 3:28 AM
    Thursday, October 20, 2016 3:47 PM

Answers

  • I would take a look at the top related threads list to the left of this thread on this page.  Other than that,  I don't know how to help you with your script.

    Many questions such as where do I find logs and what logs are interesting are found in: MDT TechNet Forum - FAQ & Getting Started Guide Please take the time to read it. Also if you don't post logs your problem won't be easily solved.

    • Marked as answer by Tommy_1234 Monday, October 24, 2016 8:47 PM
    Monday, October 24, 2016 7:13 PM
    Moderator

All replies

  • Hi Tommy,

    Thank you for your post. Based on your description, your question is more related to Microsoft Deployment Toolkit. We will move your thread to Microsoft Deployment Toolkit forum for dedicated support.

    Best Regards,
    Li Wang


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, October 21, 2016 3:24 AM
  • GenerateMedia.ps1 isn't an MDT script.  Do you know where it come from?

    Many questions such as where do I find logs and what logs are interesting are found in: MDT TechNet Forum - FAQ & Getting Started Guide Please take the time to read it. Also if you don't post logs your problem won't be easily solved.


    Friday, October 21, 2016 11:15 PM
    Moderator
  • Hello. Thanks for the reply. No bdd.log but have a DISM.log How to send it up? Tried copy and paste but no go.

    Tried to send some screen shots, but errrors out with 'can't send pictures without account verification'? Thanks.

    Monday, October 24, 2016 4:23 PM
  • I would take a look at the top related threads list to the left of this thread on this page.  Other than that,  I don't know how to help you with your script.

    Many questions such as where do I find logs and what logs are interesting are found in: MDT TechNet Forum - FAQ & Getting Started Guide Please take the time to read it. Also if you don't post logs your problem won't be easily solved.

    • Marked as answer by Tommy_1234 Monday, October 24, 2016 8:47 PM
    Monday, October 24, 2016 7:13 PM
    Moderator