none
Lync 2013 to Skype For Business Client experience RRS feed

  • Question

  • Hi,

    We are migrating users from Lync Server 2013 to Skype for Business Server 2015.In process of migrating users we will also update Lync 2013 client to Skype for business client.We gone through the article https://technet.microsoft.com/en-us/library/dn954919(v=ocs.15).aspx.

    At present all users resides at Lync Server 2013 and using Lync 2013 client where EnableSkypeUI is set as "False" and required update(2889923) to update Skype for Business client is not installed/pushed.Is there any way client continue to use Lync 2013 client without any PROMPT after installing KB2889923 ?

    As per above article it says "User asked to switch to Lync mode " if EnableSkypeUI is set as False and require updates installed on client machine.Can we install required updates silently without asking/prompt to users and when we change EnableSkypeUI = True then only lync client should be updated to SFB ?

    -DJ

    Sunday, May 8, 2016 11:05 PM

All replies

  • This require registry change on each user machine.

    Please check the chapter " First launch client behaviors" on the same link you provided..

    https://technet.microsoft.com/en-us/library/dn954919%28v=ocs.15%29.aspx?f=255&MSPPError=-2147217396

    By default, when users launch Skype for Business for the first time, they will always see the Skype for Business user interface--even if you have selected the Lync client experience by setting the value of the EnableSkypeUI parameter to $False as described previously. After several minutes, users will then be asked to switch to Lync mode.

    If you want to display the Lync user interface when users launch the Skype for Business client for the first time, follow these steps before the client is started for the first time after being updated:

    1. Confirm that the value of EnableSkypeUI is set to $False in the policy you are using as described previously.

    2. Update the system registry on the user's computer. You should do this before the first time users launch the Skype for Business client, and you should do this only once. For information about how to create a Group Policy Object to update the registry on a domain joined computer, see the section later in the topic.

      In the [HKEY_CURRENT_USER\Software\Microsoft\Office\Lync] key, create a new Binary value.

      The Value name must be EnableSkypeUI, and the Value data must be set to 00 00 00 00.

      The key should look like the following:

      [HKEY_CURRENT_USER\Software\Microsoft\Office\Lync]
      "CanSharePptInCollab"=dword:00000001
      "CanShareOneNoteInCollab"=dword:00000001
      "CanAppShareInCollab"=dword:00000001
      "EnableSkypeUI"=hex:00,00,00,00
      
      

    The Lync user interface will now be displayed when users launch the Skype for Business client for the first time.


    - Muralidharan. Please mark as answer/useful if my contribution helps you.

    Monday, May 9, 2016 11:58 AM
  • Hi Muralidharan,

    We have tested after making those registry settings but still user was getting prompt.Just to confirm if any one has tried it and got success ?

    -DJ

    Monday, May 9, 2016 12:10 PM
  • Hi,

    Can someone please share any experience on the above issue ?

    -DJ

    Tuesday, May 10, 2016 8:44 PM
  • Hi,

    Please share if someone has any view on this issue.

    -DJ

    Thursday, May 12, 2016 9:17 PM
  • Hi,

    Base on my test, no matter the SFB client policy EnableSkpeUI set to be false or true, and the PC registry parameter "EnableSkypeUI" to 00 00 00 00, there is always a prompt appear.

    If you want these users stay Lync UI, then they may don't install KB2889923 as a workaround.

    Best Regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Eason Huang
    TechNet Community Support

    Friday, May 13, 2016 9:32 AM
    Moderator
  • Thanks Eason,

    This is also my finding, not sure what Microsoft Article is talking about to hide this prompt.

    In our environment we have Lync server 2013 and Skype for business Server, running in co-existence mode.We need to migrate user from Lync server 2013 to SFB Server 2015 and while migrating we also need to update user client from Lync 2013 to Skype for Business.

    At present KB2889923 update is not installed but if we want to update user client along with migration, we have to update machine with this update.I am trying to search if there is any workaround thorugh which user does not get prompt and client updation can be controlled via Client Policy.

    -DJ

    Friday, May 13, 2016 12:39 PM
  • Any suggestion please ?

    -DJ

    Sunday, May 15, 2016 9:03 PM