none
Loggin UAG RRS feed

  • Question

  • Hi All

    i have a litle problem with my Microsoft UAG, i can add aplications but when i try to enter on it this not loggin i can enter to my UAG portal but when i do clic in a aplication( other web portal) this sendme to the new page with a paremeter named FirstActivation=true and not loggin me in i am using a .NET BASIC portal with framework 1.1.

     

    Thanks for advices and directions

    Grettings

    Tuesday, December 7, 2010 4:14 PM

Answers

  • Hi,

    thx for the app. I will test it soon. As far as i could see in you login.aspx you defined the form-name as name="form_login", ths of course must match the <NAME></NAME> tags in your FormLogin.xml. So please change the value from <NAME>Form1</NAME> to <NAME>form_login</NAME> because this is the actual http content.

    Bye,

    Andreas


    Andreas Hecker - Blog: http://microsoft-iag.blogspot.com/
    • Proposed as answer by MrShannon Wednesday, December 15, 2010 2:38 AM
    • Marked as answer by Erez Benari Wednesday, December 22, 2010 9:36 PM
    Tuesday, December 14, 2010 4:54 PM

All replies

  • Hi,

    can you describe you scenario a little bit more detailed? You published a web application on the portalsite. How is authentication done on the webapp? is it forms-based or windows authentication or basic auth?

    Bye,

    Andreas


    Andreas Hecker - Blog: http://microsoft-iag.blogspot.com/
    Wednesday, December 8, 2010 3:39 PM
  • Hi andreas i have a forms-base authentication like this:

    form-name: Form1

    user text-box: textbox1

    pass text-box: textbox2

    submit button: button1

    i enter to my portal but nothing happend only stay there

     

    Grettings, bicho

     

    Wednesday, December 8, 2010 4:08 PM
  • Hi,

    you can read my blog-post about passing credentials to form-based webapps and use this as a guide to pass the credentials to your application. You can read how to publish the application in this article also. I think this should show you the way how to solve your problem.

    http://microsoft-iag.blogspot.com/2010/10/uagenable-sso-by-passing-user.html

    Bye,

    Andreas


    Andreas Hecker - Blog: http://microsoft-iag.blogspot.com/
    Thursday, December 9, 2010 7:56 AM
  • Hi Andreas i follow the steps in your guide but the login still not happening, exist one way to be ensure where a script is called?

    i try to insert some alerts but nothing happend, i am really frustrated let me explain my steps

     

    i add one aplication names "wuag1" and  type "waug1"  point to 192.168.1.101/WUAG1 then i have the directory CustomeUpdate at UAGdirectory\von\conf\WizardDefault\FormLogin then into the CustomUpdate dir i have the formLogin.xml like this 

    <WHLFILTFORMLOGIN ver="1.0">
    <APPLICATION>
    <APPLICATION_TYPE>wuag1</APPLICATION_TYPE>
    <USAGE description="Form1">
    <PRIMARY_HOST_URL>*.login\.aspx.*</PRIMARY_HOST_URL>
    <SCRIPT_NAME source="data_definition">wuag1</SCRIPT_NAME>
    <USER_AGENT>
    <AGENT_TYPE search="group">all_supported</AGENT_TYPE>
    <POLICY>multiplatform</POLICY>
    <SCRIPT_NAME source="data_definition">FormLoginHandler</SCRIPT_NAME>
    </USER_AGENT>
    <LOGIN_FORM>
    <NAME>Form1</NAME>
    <METHOD>POST</METHOD>
    <CONTROL handling="dummy_value">
    <TYPE>USER_NAME</TYPE>
    <NAME>TextBox1</NAME>
    <DEF_VALUE>siteusr</DEF_VALUE>
    </CONTROL>
    <CONTROL handling="dummy_value">
    <TYPE>PASSWORD</TYPE>
    <NAME>TextBox2</NAME>
    <DEF_VALUE>sitepass</DEF_VALUE>
    </CONTROL>
    </LOGIN_FORM>
    </USAGE>
    </APPLICATION>
    </WHLFILTFORMLOGIN>
    

    then  i have the script at FormLoginDataDefinitions.xml 

    <SCRIPT name="wuag1">
    			<!-- Possible value javascript or vbscript, if javascript tag could be omitted-->
    			<LANGUAGE>javascript</LANGUAGE> 
    			<!-- Possible value cdata or base64, if javascript tag could be omitted-->
    			<BODY encoding="cdata">
    				<![CDATA[
    
    					function FormLoginSubmit()
    					{  
    						alert('entrando');
    						formsCol = document.forms;
    						if (formsCol.length == 1)
    						{
    						alert('entrando2');
    							try{
    
    							var submitbtn = document.getElementById('button1');
    							if (submitbtn)
    								alert('entrando3');
    								submitbtn.click();
    						  }catch(e){}
    						}
    						return false; 
    					}
    				
    				]]>
    			</BODY>
    		</SCRIPT>
    
    

    and then i active my trunk and acces to my aplication but this cannot login 

    Grettings,

    Bicho


     

    Thursday, December 9, 2010 7:57 PM
  • Hi,

    please try to make the following changes:

    <USAGE description="form_login"> , the description value has to be "form_login"!

    <PRIMARY_HOST_URL><![CDATA[/login.aspx.*]]></PRIMARY_HOST_URL>

    I think you can clear-out your alert('xxx') commands and simply try to login, do not forget, to activate your configuration. Be sure, that the ElementId of you submitbutton really is Button1. I think aftery aou aplly the changes above you can login sucessful.

    Bye,

    Andreas 


    Andreas Hecker - Blog: http://microsoft-iag.blogspot.com/
    Friday, December 10, 2010 12:35 PM
  • Hi andreas

    well... i make the changes on but the login still not happening

    :/ 

    i am really confuse at this point 

    i still make some changes trying to make the automatic redir, delete this portal and add a new one

    Grettings, bicho

    Friday, December 10, 2010 4:38 PM
  • a couple of points maybe you want to know:

     

    - Enabled debug mode to my portal

    - My aplication exist on a adress type 192.168.1.103/WUAG1

    - My login form is on 192.168.1.103/WUAG/login.aspx

    - And i am running windows server 2008 in a virtual machine 

    - My conecction to Microsoft AD works fine

    Maybe in one of this points something makes you a clue

    Grettings, bicho

    Friday, December 10, 2010 5:13 PM
  • Hi,

    ok, then try to change the statement to  <![CDATA[/WUAG/login.aspx.*]]. we need to make sure that the regex matches the url. then it will work. i think the regex is not correct.

    Bye

    Andreas


    Andreas Hecker - Blog: http://microsoft-iag.blogspot.com/
    Friday, December 10, 2010 10:02 PM
  • Hi,

    any updates on this?

    Bye,

    Andreas


    Andreas Hecker - Blog: http://microsoft-iag.blogspot.com/
    Sunday, December 12, 2010 11:00 PM
  • Hi andreas mi regex match with <![CDATA[/WUAG/login.aspx.*]] and no positive  changes the loggin still not happening,

     

    grettings

    Monday, December 13, 2010 4:33 PM
  • Can i access the portal from the internet so that there is a chance to help you remotely? It MUST work! Perhaps we can setup a teamviewer session if you like.

    Bye

    Andreas


    Andreas Hecker - Blog: http://microsoft-iag.blogspot.com/
    Monday, December 13, 2010 6:59 PM
  • i dont have exit to internet from that server i start a fresh instalation (server+UAG forefront) before this attempt i post my result here thanks by the help

     

    Grettings

    Bicho

    Monday, December 13, 2010 8:32 PM
  • Can you send me your app for testing in my local environment?

    Bye

    Andreas


    Andreas Hecker - Blog: http://microsoft-iag.blogspot.com/
    Monday, December 13, 2010 11:02 PM
  • Hi andreas here is my little aplication with vstudio 2003 and framework 1.1

    http://dl.dropbox.com/u/1123852/WUAG1.zip

    Grettings

    Tuesday, December 14, 2010 12:10 AM
  • Hi,

    thx for the app. I will test it soon. As far as i could see in you login.aspx you defined the form-name as name="form_login", ths of course must match the <NAME></NAME> tags in your FormLogin.xml. So please change the value from <NAME>Form1</NAME> to <NAME>form_login</NAME> because this is the actual http content.

    Bye,

    Andreas


    Andreas Hecker - Blog: http://microsoft-iag.blogspot.com/
    • Proposed as answer by MrShannon Wednesday, December 15, 2010 2:38 AM
    • Marked as answer by Erez Benari Wednesday, December 22, 2010 9:36 PM
    Tuesday, December 14, 2010 4:54 PM
  • Hi andreas at least good new my configuration works, the key was on tag <NAME></NAME> well so many thanks, now i going to try with a multiple web on SSO

    Thanks by the help and directions

     

    Grettings

    Bicho

    Tuesday, December 14, 2010 6:33 PM
  • Hi,

    fine that it works now. So enjoy!

    Bye,

    Andreas


    Andreas Hecker - Blog: http://microsoft-iag.blogspot.com/
    Tuesday, December 14, 2010 7:54 PM