none
Two different client installation fails XP

    Question

  • Having two differrent client install problems with SBS 2011E. These are on computers running XP SP3. I have already connected 3x Windows 7 machines, a Vista, and a 2 other XP machines.

     

    FIRST ERROR FIXED!!!!!

    The first error, I go all the way through the client deployment process, Restart, then it throws a "The installation was cancelled" "The SBS 2011 Connector has encountered an unexpected error" "Click here to undo most of the changes etc etc". I click close, it restarts, though it doesn't disconnect me from the domain or remove my computer on the Server.

    Logs:

    [3372] 110905.183558.6101: ClientSetup: Start of ClientDeploy
    [3372] 110905.183558.6880: General: Initializing...C:\WINDOWS\Temp\Client Deployment Files\ClientDeploy.exe
    [3372] 110905.183558.7348: ClientSetup: Installing ThemeUI for temporary user: CommandLine=C:\WINDOWS\system32\regsvr32.exe /n /i:/UserInstall C:\WINDOWS\system32\themeui.dll /s
    [3372] 110905.183558.8595: General: Show floating language bar
    [3372] 110905.183558.8595: ClientSetup: Loading Wizard Data
    [3372] 110905.183559.8101: ClientSetup: Current DeploymentStatus=Running
    [3372] 110905.183602.1632: ClientSetup: Showing the Client Deployment Wizard
    [3660] 110905.183602.6931: ClientSetup: Running MigrateProfileTask at WizardPage ProfileMigration
    [3660] 110905.183602.7398: ClientSetup: Entering ConnectorWizardForm.RunTasks
    [3660] 110905.183602.7398: ClientSetup: Running Task with Id=ClientDeploy.MigrateProfile
    [3660] 110905.183602.7710: ClientSetup: Entering MigrateProfileTask.Run
    [3372] 110905.183602.9268: ClientSetup: Set the Deployment Sync Event
    [3660] 110905.183602.9580: ClientSetup: Add domain user [AFSPC\Ann] to local user group
    [3660] 110905.183602.9736: ClientSetup: LookupAccountSid (computerName = [], sid = [S-1-5-32-545])
    [3660] 110905.183602.9892: ClientSetup: NetLocalGroupAddMember (server = [], groupName = [Users], sidMember = [S-1-5-21-1894279239-3205943765-3523587499-1130])
    [3660] 110905.183603.1294: ClientSetup: Migrate profile from [HANSOLO-AFSPC06\Office] to [AFSPC\Ann]
    [3660] 110905.183603.1450: ClientSetup: Moving User Profile: SourceUserSid=S-1-5-21-667753645-243359931-1007009338-1005 DestinationUserSid=S-1-5-21-1894279239-3205943765-3523587499-1130
    [3660] 110905.183603.1450: ClientSetup: ProfileMgmt on Windows XP
    [3660] 110905.183617.5756: ClientSetup: Mark as private folder [C:\Documents and Settings\Office\Local Settings\Temp\{0BB96F9F-5F29-410C-A87D-9E2B98362C94}] - Could not find FullControl ALLOW access for current windows user [HANSOLO-AFSPC06\__clientsetup__$].
    [3660] 110905.183617.6535: ClientSetup: MigrateProfileTask failed: ErrorCode:0
    BaseException: Microsoft.WindowsServerSolutions.ClientSetup.ProfileMigrationException: Source User [HANSOLO-AFSPC06\Office] profile contains private folders
       at Microsoft.WindowsServerSolutions.ClientSetup.ProfileMgmt.Move(User sourceUser, User destinationUser)
       at Microsoft.WindowsServerSolutions.ClientSetup.ClientDeploy.MigrateProfileTask.Run(WizData data)
    [3660] 110905.183617.6535: ClientSetup: Exiting MigrateProfileTask.Run
    [3660] 110905.183617.6535: ClientSetup: Task with Id=ClientDeploy.MigrateProfile has TaskStatus=Failed
    [3660] 110905.183617.6535: ClientSetup: Task with Id=ClientDeploy.MigrateProfile has RebootStatus=NoReboot
    [3660] 110905.183617.6535: ClientSetup: Exting ConnectorWizardForm.RunTasks
    [3372] 110905.183617.6691: ClientSetup: MigrateProfileTask returned Status: TaskStatus=Failed
    [4008] 110905.183639.5488: ClientSetup: Running Tasks for Wizard Page ConfiguringComputer
    [4008] 110905.183639.5488: ClientSetup: Entering ConnectorWizardForm.RunTasks
    [4008] 110905.183639.5488: ClientSetup: Running Task with Id=ClientDeploy.PrepareClient
    [4008] 110905.183639.5955: ClientSetup: Entering PrepareClientTask.Run
    [4008] 110905.183639.5955: ClientSetup: Ensuring that ServiceName=NetTcpPortSharing is Running
    [4008] 110905.183839.6064: ClientSetup: Could not ensure NetTcpPortSharing service is Running: System.ServiceProcess.TimeoutException: The timeout provided has expired and the 'NetTcpPortSharing' service has not reached any of the desired states. Desired states are 'Running', 'Paused', 'Stopped', and the current state is 'StartPending').
       at Microsoft.WindowsServerSolutions.Common.ServiceUtility._ThrowTimeout(ServiceController objSvc, ServiceControllerStatus[] statusArray)
       at Microsoft.WindowsServerSolutions.Common.ServiceUtility._PollForStatusChange(ServiceController objSvc, DateTime deadline, ServiceControllerStatus[] statusArray)
       at Microsoft.WindowsServerSolutions.Common.ServiceUtility.WaitForMultipleStatus(ServiceController objSvc, DateTime deadline, ServiceControllerStatus[] statusArray)
       at Microsoft.WindowsServerSolutions.Common.ServiceUtility.ChangeObjectState(Methods method, ServiceController svc, DateTime deadline)
       at Microsoft.WindowsServerSolutions.Common.ServiceUtility.EnsureStarted(ServiceController svc, Int32 timeout)
       at Microsoft.WindowsServerSolutions.Common.ServiceUtility.EnsureStarted(String serviceName, Int32 timeout)
       at Microsoft.WindowsServerSolutions.ClientSetup.ClientDeploy.PrepareClientTask.Run(WizData data)
    [4008] 110905.183839.6064: ClientSetup: Exiting PrepareClientTask.Run
    [4008] 110905.183839.6064: ClientSetup: Task with Id=ClientDeploy.PrepareClient has TaskStatus=Failed
    [4008] 110905.183839.6064: ClientSetup: Task with Id=ClientDeploy.PrepareClient has RebootStatus=NoReboot
    [4008] 110905.183839.6064: ClientSetup: Exting ConnectorWizardForm.RunTasks

    I fixed this Error WOOHOO!

    http://forum.wegotserved.com/index.php/topic/20363-connector-install-fail-xp-32-success-for-win-7-64/

    His solution worked! Had to change the smsvchost.exe and smsvchost.exe.config files to their earlier versions.

    Still having problems as seen below :(

     

    The 2nd Error happens on a different machine:

    I run the deployment wizard, and the installer reaches the point where it asks to restart the computer. On Boot, the "_clientsetup_$" profile is logged in, but it throws a "Cannot find C:\Windows\Temp\Client" and aborts the installation, leaving me logged into the barebones "_clientsetup_$" profile. I then have to manually change a few settings regarding login, and manually disconnect myself from the domain just to get back to my original local profile.

    EDIT: This log is after i have changed folder permissions to give "Everyone" full control of the "Client" and "Client Deployment files" folders.

     

    ---------------------------------------------------------

    [1840] 110908.112034.3906: ClientSetup: Start of ClientDeploy

    [1840] 110908.112034.4843: General: Initializing...C:\WINDOWS\Temp\Client Deployment Files\ClientDeploy.exe

    [1840] 110908.112034.4843: ClientSetup: Loading Wizard Data

    [1840] 110908.112034.7343: ClientSetup: Current DeploymentStatus=Running

    [1840] 110908.112035.0937: ClientSetup: Showing the Client Deployment Wizard

    [1840] 110908.112035.2031: ClientSetup: Adding Server Info data in the Product Registry

    [1840] 110908.112035.2187: ClientSetup: Set the Deployment Sync Event

    [520] 110908.112039.0625: ClientSetup: Running ValidateUser Tasks at WizardPage DomainUserCred

    [520] 110908.112039.0625: ClientSetup: Entering ConnectorWizardForm.RunTasks

    [520] 110908.112039.0625: ClientSetup: Running Task with Id=ClientDeploy.ValidateUser

    [520] 110908.112039.1718: ClientSetup: Entering ValidateUserTask.Run

    [520] 110908.112039.1875: ClientSetup: Install root cert to local trusted store

    [520] 110908.112039.2656: ClientSetup: Validating User

    [520] 110908.112039.2656: ClientSetup: Call MachineIdentityManager.GetMachineStatus

    [520] 110908.112039.7968: ClientSetup: Current Machine Join Status: Active

    [520] 110908.112039.7968: ClientSetup: Exiting ValidateUserTask.Run

    [520] 110908.112039.7968: ClientSetup: Task with Id=ClientDeploy.ValidateUser has TaskStatus=Success

    [520] 110908.112039.7968: ClientSetup: Task with Id=ClientDeploy.ValidateUser has RebootStatus=NoReboot

    [520] 110908.112039.7968: ClientSetup: Exting ConnectorWizardForm.RunTasks

    [520] 110908.112039.7968: ClientSetup: Running JoinNetwork Tasks at WizardPage DomainUserCred

    [520] 110908.112039.8125: ClientSetup: Entering ConnectorWizardForm.RunTasks

    [520] 110908.112039.8125: ClientSetup: Running Task with Id=ClientDeploy.JoinDomain

    [520] 110908.112039.8125: ClientSetup: Entering JoinDomainTask.Run

    [520] 110908.112039.8125: ClientSetup: Domain Join Client to Server Domain: ClientComputerName=LANDO-AFSPC01 ServerDomainNetBiosName=AFSPC

    [520] 110908.112039.8125: ClientSetup: Trying to set Local Nic Dns address as the Server IP.

    [520] 110908.112039.8125: ClientSetup: Configure DNS settings on local NIC

    [520] 110908.112039.8125: ClientSetup: Got Server Ip=[192.168.1.22]

    [520] 110908.112040.7187: ClientSetup: Exception in CheckNetworkAdapter: System.Management.ManagementException: Invalid query 

       at System.Management.ManagementException.ThrowWithExtendedInfo(ManagementStatus errorCode)

       at System.Management.ManagementObjectCollection.ManagementObjectEnumerator.MoveNext()

       at System.Management.ManagementObjectCollection.get_Count()

       at Microsoft.WindowsServerSolutions.ClientSetup.ClientDeploy.JoinDomainTask.IsNicHardwareLoopback(String nicGuid)

    [520] 110908.112044.3125: ClientSetup: Exception in CheckNetworkAdapter: System.Management.ManagementException: Invalid query 

       at System.Management.ManagementException.ThrowWithExtendedInfo(ManagementStatus errorCode)

       at System.Management.ManagementObjectCollection.ManagementObjectEnumerator.MoveNext()

       at System.Management.ManagementObjectCollection.get_Count()

       at Microsoft.WindowsServerSolutions.ClientSetup.ClientDeploy.JoinDomainTask.IsNicHardwareLoopback(String nicGuid)

    [520] 110908.112047.5468: ClientSetup: NetGetJoinInformation (server = [], ...)

    [520] 110908.112047.5468: ClientSetup: Server Domain already contains a computer with Client Machine Name

    [520] 110908.112047.5468: ClientSetup: Join Domain has not been forced

    [520] 110908.112047.5468: ClientSetup: Join Domain will not be Run

    [520] 110908.112053.5156: ClientSetup: Exiting JoinDomainTask.Run

    [520] 110908.112053.5156: ClientSetup: Task with Id=ClientDeploy.JoinDomain has TaskStatus=Retry

    [520] 110908.112053.5156: ClientSetup: Task with Id=ClientDeploy.JoinDomain has RebootStatus=NoReboot

    [520] 110908.112053.5156: ClientSetup: Exting ConnectorWizardForm.RunTasks

    [1840] 110908.112053.5156: ClientSetup: JoinNetwork Tasks returned TaskStatus=Retry

    [520] 110908.112054.9843: ClientSetup: Running JoinNetwork Tasks at WizardPage ComputerAlreadyExists

    [520] 110908.112054.9843: ClientSetup: Entering ConnectorWizardForm.RunTasks

    [520] 110908.112054.9843: ClientSetup: Running Task with Id=ClientDeploy.JoinDomain

    [520] 110908.112054.9843: ClientSetup: Entering JoinDomainTask.Run

    [520] 110908.112054.9843: ClientSetup: Domain Join Client to Server Domain: ClientComputerName=LANDO-AFSPC01 ServerDomainNetBiosName=AFSPC

    [520] 110908.112054.9843: ClientSetup: Trying to set Local Nic Dns address as the Server IP.

    [520] 110908.112055.0000: ClientSetup: Configure DNS settings on local NIC

    [520] 110908.112055.0000: ClientSetup: Got Server Ip=[192.168.1.22]

    [520] 110908.112055.0156: ClientSetup: Exception in CheckNetworkAdapter: System.Management.ManagementException: Invalid query 

       at System.Management.ManagementException.ThrowWithExtendedInfo(ManagementStatus errorCode)

       at System.Management.ManagementObjectCollection.ManagementObjectEnumerator.MoveNext()

       at System.Management.ManagementObjectCollection.get_Count()

       at Microsoft.WindowsServerSolutions.ClientSetup.ClientDeploy.JoinDomainTask.IsNicHardwareLoopback(String nicGuid)

    [520] 110908.112058.0937: ClientSetup: Exception in CheckNetworkAdapter: System.Management.ManagementException: Invalid query 

       at System.Management.ManagementException.ThrowWithExtendedInfo(ManagementStatus errorCode)

       at System.Management.ManagementObjectCollection.ManagementObjectEnumerator.MoveNext()

       at System.Management.ManagementObjectCollection.get_Count()

       at Microsoft.WindowsServerSolutions.ClientSetup.ClientDeploy.JoinDomainTask.IsNicHardwareLoopback(String nicGuid)

    [520] 110908.112101.0937: ClientSetup: NetGetJoinInformation (server = [], ...)

    [520] 110908.112101.1093: ClientSetup: Server Domain already contains a computer with Client Machine Name

    [520] 110908.112101.1093: ClientSetup: Join Domain has been forced

    [520] 110908.112101.1093: ClientSetup: Running Join Domain

    [520] 110908.112101.1093: ClientSetup: Disconnect any share to the server.

    [520] 110908.112101.1093: ClientSetup: NetUseEnum (UncServerName = [] )

    [520] 110908.112101.1250: ClientSetup: NetUseEnum (UncServerName = [] )

    [520] 110908.112101.1250: ClientSetup: Trying to clear dns cache.

    [520] 110908.112101.5312: ClientSetup: Calling SetPrimaryDnsSuffix.

    [520] 110908.112101.5312: ClientSetup: SetPrimaryDnsSuffix (AFSPC.local)

    [520] 110908.112101.5312: ClientSetup: SetComputerNameEx (AFSPC.local)

    [520] 110908.112101.9218: ClientSetup: Update tcpip Domain parameter with AFSPC.local

    [520] 110908.112101.9218: ClientSetup: Calling join domain [AFSPC.local] with domain user [AFSPC.local\brock] credential.

    [520] 110908.112101.9375: ClientSetup: Joining local machine to domain AFSPC.local

    [520] 110908.112101.9375: ClientSetup: NetJoinDomain( , AFSPC.local, , AFSPC.local\brock, *, NetSetupJoinDomain, NetSetupAcctCreate, NetSetupAcctDelete, NetSetupDomainJoinIfJoined, NetSetupDeferSpnSet)

    [520] 110908.112117.0000: ClientSetup: nativeNetJoinDomain returned ErrCode=1355

    [520] 110908.112117.0000: ClientSetup: JoinDomain failed: System.ComponentModel.Win32Exception (0x80004005): The specified domain either does not exist or could not be contacted

       at Microsoft.WindowsServerSolutions.ClientSetup.NativeMethods.NativeMethodRetryWrapper(NativeMethodInvoker nmi, UInt32 numTries, TimeSpan timeToWaitBetweenRetries, String descriptionForLog, UInt32[] retryableErrorCodes)

       at Microsoft.WindowsServerSolutions.ClientSetup.NativeMethods.NetJoinDomain(String server, String domain, String destinationOuPath, String user, SecureString password, JoinDomainOptions joinOptions)

       at Microsoft.WindowsServerSolutions.ClientSetup.ComputerMgmt.JoinDomain(String domainName, String domainUserName, SecureString domainUserPass, String machineAccountOU)

       at Microsoft.WindowsServerSolutions.ClientSetup.ClientDeploy.JoinDomainTask.Run(WizData data)

    [520] 110908.112123.2500: ClientSetup: Exiting JoinDomainTask.Run

    [520] 110908.112123.2500: ClientSetup: Task with Id=ClientDeploy.JoinDomain has TaskStatus=Failed

    [520] 110908.112123.2500: ClientSetup: Task with Id=ClientDeploy.JoinDomain has RebootStatus=NoReboot

    [520] 110908.112123.2500: ClientSetup: Exting ConnectorWizardForm.RunTasks

    [1840] 110908.112123.2500: ClientSetup: JoinNetwork Tasks returned TaskStatus=Failed

    [1840] 110908.112131.6250: ClientSetup: Back from the Client Deployment Wizard

    [1840] 110908.112131.6250: ClientSetup: Saving Wizard Data

    [1840] 110908.112131.6250: ClientSetup: End of ClientDeploy: ErrorCode=1603

    • Edited by tampabrock Thursday, September 8, 2011 4:02 PM
    Monday, September 5, 2011 7:50 PM

All replies

  • Fixed the first error!
    Tuesday, September 6, 2011 3:02 PM
  • This might seem like a silly question but do you have any issues getting into task manager on that machine?

     

    Secondly, it looks like it is struggling to configure the nic correctly.

    Could you try setting that client to have a static IP, and point the dns only to the servers IP?

     

    Also, remove any computer accounts from the server that have the same name as this client pc.


    Robert Pearman SBS MVP (2011) | www.titlerequired.com | www.itauthority.co.uk
    Tuesday, September 27, 2011 8:38 AM
    Moderator
  • Thanks Robert, you're a genius! 

    I had the same issue with SBS 2011 essentials not connecting (error msg: "the server is not available. Try connecting this computer again") and was receiving the same error in the ClientDeploy.log as Tampabrock (ClientSetup: nativeNetJoinDomain returned ErrCode=1355).

    I realised that the network doesn't have DHCP so the computer wasn't getting an IP address. I changed it to a Static address and pointed the DNS to the server as you suggested and it worked fine the second time around.

    Thanks again mate - you saved me a load of time troubleshooting!

    Friday, January 4, 2013 5:10 AM