none
high availability Clustering - Second node can run the cluster but not after a reboot RRS feed

  • Question

  • Hello,

    I have a strange issue and that is that we have a SQL clustered role with WIndows Server 2016. Failovers work fine on both nodes but if both nodes are shutdown and only de 2nd node is booted then it cannot get the Cluster and the Cluster Role online.

    i tried the Clear-ClusterDiskReservation -force –Disk 2 -node hostname but that does not make any difference.

    I don't see any clear messages, only ;

    The Cluster Service service terminated with the following service-specific error: 
    A quorum of cluster nodes was not present to form a cluster.

    or;

    [RHS] RhsResType::NotifyAllResourceTypesMonitorIsShuttingDown: (21)' because of 'Startup routine for ResType MSMQTriggers returned 21.'

    FatalError is Calling Exit Process. 

    Failover Cluster Manager encountered a fatal error.


    System.Runtime.InteropServices.COMException (0x80070718): Not enough quota is available to process this command. (Exception from HRESULT: 0x80070718)

    which is strange since we do not have message queuing used or have quota usage configured.

    When trying to configure the quorom disk again it is not possible to select a disk if the 1st node is not online.

    it states "No disks suitable for cluster disks were found. For diagnotsic information about disks available to the cluster, use the Validate a Configuration Wizard to run Storage".

    but as soon as the 1st Node is booted everything is fine and shutting that 1st Node then everything is working on the 2nd Node.

    Someone have an idea what could be wrong here ?

    thanks in advance.

    Wednesday, September 30, 2020 8:26 PM