locked
Workflow not executing in Sharepoint 2007 RRS feed

  • Question

  • Hi,
    I have created a workflow in Sharepoint Designer that is meant to copy a file from a Document Library named
    For Approval
    to a Document Library named

    Approved

    where the  <Test> field is populated with the value <Yes>

    My expectation is that the files will be copied to the Approved Library when they are modified and their  coresponding  Test column contains the value "Yes", both conditions are satisfied, yet this is not happening as displayed in the screen shot of the Approved Library below.

    Please be aware that I am very new to Sharepoint so it is possible/probable I may have overlooked something very basic here.

    Any advice greatly appreciated, thanks.




    • Edited by learner1959 Wednesday, June 19, 2013 4:51 PM
    Wednesday, June 19, 2013 4:46 PM

Answers

  • If you launch the workflow manually does it work as expected?
    • Marked as answer by learner1959 Monday, June 24, 2013 3:05 PM
    Thursday, June 20, 2013 12:09 PM
  • Hi Leendert,

    Allow this workflow to be manually started from an item  was unchecked in the Workflow Definition.

    So I could not start this manually.

    I checked this and when I started the workflow manually it behaved as expected.

    This is not the complete solution for me, but it gives me enough to work with....

    Thanks for your input....

    Monday, June 24, 2013 3:05 PM

All replies

  • Check on what events the workflow is getting triggered :

    1) item adding

    2) item updating

    3) item deleting

    if the required one is not selected, you can select them and deploy your workflow again.

    All the best!


    Thanks Santhosh V

    Wednesday, June 19, 2013 8:55 PM
  • Hi Santhosh V,

    thanks for your input.

    The event is set to trigger  as displayed below;

    Thursday, June 20, 2013 8:49 AM
  • A further question then, is this copying a list item or an actual document?

    In order for a copy to be done, there has to be at least one identical item between target and source.  With a document, this is typically the Title or Name columns.  With a list, this depends on what you've used or built.

    You've also checked that your testing account has permissions on your target too?


    Steven Andrews | SharePoint Professional | http://www.twitter.com/backpackerd00d | https://baron72.wordpress.com/

    Thursday, June 20, 2013 10:38 AM
    Answerer
  • Hi Steven,

    Thank you for your input.

    Below is a screengrab of the source Document Library, named For Approval

    and below is a screengrab of the destination  Document Library, named Approved

    What I am trying to achieve is to move or copy the actual document to the Approved folder. I chose Copy because the workflow designer has an option for "Copy List Item".

    My intepretation of the Action "Copy List Item" is that if the associated condition is satisfied (in this instance Test=Yes) then the actual documents in the For Approval library will be copied to the Approved Library. Have I misunderstood how this process works?

    I have confirmed that my testing account has permissions on the targer library.

    Thursday, June 20, 2013 11:01 AM
  • If you launch the workflow manually does it work as expected?
    • Marked as answer by learner1959 Monday, June 24, 2013 3:05 PM
    Thursday, June 20, 2013 12:09 PM
  • Hi Leendert,

    thanks for your response,

    I started the workflow manually by selecting Workflows from the drop down menu

    And then entering an approver and clicking the Start button

    This changed the Approval status to "In Progress" but no files have moved to the Approved folder

    • Marked as answer by learner1959 Monday, June 24, 2013 3:01 PM
    • Unmarked as answer by learner1959 Monday, June 24, 2013 3:02 PM
    Thursday, June 20, 2013 1:15 PM
  • Hi Leendert,

    Allow this workflow to be manually started from an item  was unchecked in the Workflow Definition.

    So I could not start this manually.

    I checked this and when I started the workflow manually it behaved as expected.

    This is not the complete solution for me, but it gives me enough to work with....

    Thanks for your input....

    Monday, June 24, 2013 3:05 PM