none
sharing sites with external users: email notifications

    Question

  • Hi , I'm trying to share a 0365 SharePoint Online team site with an external user (the site collection is enabled for external sharing etc) when I click 'Share' I get the usual pop share box where I enter the user's email address and then SharePoint tells me it's an external address etc, i fill in the mesage box and choose a permission for the user and click on 'share'

    Instead of the usual pop up notification that says I have shared the site with 'Joe Bloggs' I get a notification box saying 'Shared with external users' and there's no notification email in my Outlook in box and the user does not receive the shared email either. When I check the Access and Requests settings I can see the pending request in 'External User Invitations'. The same problem happens when I tested fwith the same user on anther site and other users from the same organisation as the user having problems have accessed the same sites and had email notifications. Would it be a problem with this users individual account?

    Regards


    kegan1

    Friday, November 25, 2016 3:00 PM

Answers

  • Hi all

    Hi ,  it was very bizarre, I tried everything but the user was still not getting the share email, I tried doing the same thing from an 0365 Group and the user received the shared email group invite as a guest. In the end my fellow sharepoint admin tried sharing the classic site to the same user from Chrome and it worked, so whether or not there was a weird browser cache thing going on? I was using IE 11.


    Cheers

    Kevin


    kegan1

    • Marked as answer by kegan1 Tuesday, November 29, 2016 11:48 AM
    Tuesday, November 29, 2016 11:48 AM

All replies

  • Hi,

    Please ask the user whom you shared the site with to double check his/her email box for  with shared link.

    You will not receive any email notification in your email box when you share the link or site apart from "Access Request settings".

    If you see the item in the "Request Pending", then user yet to accept your sharing.

    So I would suggest you to ask the user to double check the email box.


    Murugesa Pandian | MCPD | MCTS | SharePoint 2010 |


    Sunday, November 27, 2016 4:59 AM
  • Hi Kegan1,

    From your description, Instead of the usual pop up notification that says you have shared the site with 'Joe Bloggs' you get a notification box saying 'Shared with external users'.

    It seems that you share the site with the external user firstly.

    Try to share the site to the issued external user with the site owner and compare the results.

    Besides, navigate to site settings->site permissions->Access request settings, check the settings:

    Best Regards,

    Lisa Chen


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, November 28, 2016 6:52 AM
    Moderator
  • Hi , I have already checked the access request settings and the invitation ot the user I have tried to share the site with  is in there as 'pending'. When I try to share the site with the user I get a pop up box 'shared with external users' everyone else I sahre the site with i get the usual Site shared with 'Joe Bloggs' and the receive an email notification with sharing link as do I myself in my inbox as the person who shared the site.

    kegan1

    Monday, November 28, 2016 9:36 AM
  • Hi kegan1,

    Make sure the user has valid email address.

    Besides, try to login on the site with the user and check whether the user can access to the site.

    Best Regards,

    Lisa Chen


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, November 28, 2016 10:02 AM
    Moderator
  • Hi,

    Going forward you wont receive the email notification when you share the link with external user.

    Recent updates with "Feature Update: Sharing mails sent in SharePoint Online and OneDrive for Business" restrict to use the user's Exchange Email box instead it will user noreply email id.


    Murugesa Pandian | MCPD | MCTS | SharePoint 2010 |

    Monday, November 28, 2016 1:17 PM
  • Hi all

    Hi ,  it was very bizarre, I tried everything but the user was still not getting the share email, I tried doing the same thing from an 0365 Group and the user received the shared email group invite as a guest. In the end my fellow sharepoint admin tried sharing the classic site to the same user from Chrome and it worked, so whether or not there was a weird browser cache thing going on? I was using IE 11.


    Cheers

    Kevin


    kegan1

    • Marked as answer by kegan1 Tuesday, November 29, 2016 11:48 AM
    Tuesday, November 29, 2016 11:48 AM
  • Hi kegan1,

    I am using IE 11 and I cannot reproduce your issue.

    Try to clear IE cache and compare the results.

    https://kb.wisc.edu/page.php?id=15141

    Best Regards,

    Lisa Chen


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, November 29, 2016 12:10 PM
    Moderator