none
Applications taking a long time to load? RRS feed

  • Question

  • I installed Windows 7 yesterday on my PC, replacing my old XP SP2. At first I was quite impressed - maybe this was just as a result of having essentially reformatted my computer, however i found that windows 7 was doing much better than my xp.

    Today, I tried opening Firefox from the taskbar. It takes a long long time, and even when it opens i've already clicked half a dozen times so it opens half a dozen windows. This is the case for any other application pretty much, from wherever i open it.

    I tried going back to a system restore point i created yesterday, but to no avail ; i saw a similar thread where another user complained about this problem in relation to folders, and he found that AVG Carbonite was reducing the performance. But I don't know if his problem concerned applications too.

    Any advice?
    Sunday, June 7, 2009 10:57 AM

Answers

  • hey, thanks for all the help ladies/gents. =)

    but, i found that avg was indeed the problem. i'm running a fairly decent computer, 3gb ram, quad core 2.4ghz so i figured it had to be something i'd installed and avast and avg were the only things i'd installed. it was a bit of a nightmare to uninstall as well; i actually needed an avg removal tool!!

    thanks anyway!!

    • Marked as answer by dwoltersEditor Wednesday, June 10, 2009 12:45 PM
    Wednesday, June 10, 2009 9:34 AM

All replies

  • anagra,

    What do you have for hardware? Did you add any drivers on your own, or did they all come through windows update that first day? You can check what was installed by going to control panel, windows update, then on the bottom of the left pane, choose installed updates. See what happened yesterday for driver updates.
    Sunday, June 7, 2009 5:10 PM
    Answerer
  • I installed Windows 7 yesterday on my PC, replacing my old XP SP2. At first I was quite impressed - maybe this was just as a result of having essentially reformatted my computer, however i found that windows 7 was doing much better than my xp.

    Today, I tried opening Firefox from the taskbar. It takes a long long time, and even when it opens i've already clicked half a dozen times so it opens half a dozen windows. This is the case for any other application pretty much, from wherever i open it.

    I tried going back to a system restore point i created yesterday, but to no avail ; i saw a similar thread where another user complained about this problem in relation to folders, and he found that AVG Carbonite was reducing the performance. But I don't know if his problem concerned applications too.

    Any advice?

    anagra -

    There's another post (maybe this might be the same one you found earlier) that mentions the same sort of issues you're having.
    Sunday, June 7, 2009 10:44 PM
  • Hello anagra,

    Is Firefox "pinned" to Start or quick launch?  
    Monday, June 8, 2009 9:00 PM
  • hey, thanks for all the help ladies/gents. =)

    but, i found that avg was indeed the problem. i'm running a fairly decent computer, 3gb ram, quad core 2.4ghz so i figured it had to be something i'd installed and avast and avg were the only things i'd installed. it was a bit of a nightmare to uninstall as well; i actually needed an avg removal tool!!

    thanks anyway!!

    • Marked as answer by dwoltersEditor Wednesday, June 10, 2009 12:45 PM
    Wednesday, June 10, 2009 9:34 AM
  • anagra -

    You mean you had Avast AND AVG both installed at the same time?!?!?

    Oy.. Yah.. That WILL do it.
    Wednesday, June 10, 2009 9:40 AM