locked
Slow file copy between Windows 7 and Windows Server2008 when firewall is active RRS feed

  • Question

  • We have at our place of employ encountered an oddly specific example of the “Windows 7 slow network file copy” phenomenon, and we are hoping to find an explanation: uploading files from any Windows 7 workstation on our network to a Windows 2008 file server is consistently slow, usually around 40 to 60 kbs. Disabling the Windows 7 firewall on the workstation will cause an immediate increase in the upload speed, usually improving to 10+ mbs right away.

    Also, if the Windows firewall is re-enabled, file transfer speeds remain at the faster 10+ mbs rate. That is until the workstation is rebooted, at which time file transfer speeds revert to the slower 40 to 60 kbs rate.

    We have seen this happen on desktop and laptop computers, and on both 32 and 64 bit versions of Windows 7 Professional. There are no problems uploading from XP workstations, or to Windows 2003 servers on the network. The slowdown is only between Windows 7 machines with firewalls active and a Server 2008 file server.

    Any insight would be truly appreciated.


    • Edited by j3gorman Monday, September 26, 2011 11:50 PM
    Monday, September 26, 2011 11:40 PM

Answers

  • Hello, our IT department found a solution for our problem: turning off IPv6 at the server enabled file transfers and all other network traffic  to operate at normal rates of speed.

     

    Thanks again for your suggestions.

    • Marked as answer by j3gorman Friday, November 11, 2011 4:58 PM
    Friday, November 11, 2011 4:58 PM

All replies

  • Hi,

     

    Since the issue is caused by Windows Firewall, please check if you have set block rules specially. In addition, you can Restore Windows Firewall defaults to check the result.

     

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, September 29, 2011 9:52 AM
  • Hello, and thanks for your reply.

     

    There are no "Block" rules active on our firewalls, only "Allow" and rules that are not enabled.

    Restoring default settings on the firewall does not change file transfer speeds.

    Thanks again,

    Jason

    Friday, September 30, 2011 11:20 PM
  • Hi Jason,

     

    You can enable Windows Firewall with Advanced Security audit events and check the blocked connection:

     

    Enable IPsec and Windows Firewall Audit Events

    http://technet.microsoft.com/en-us/library/cc754714(WS.10).aspx

     

    Check the related events:

     

    Description of security events in Windows Vista and in Windows Server 2008

    http://support.microsoft.com/kb/947226

     

    From the document, we can see the ID 5031, 5155 and 5157 means a connection is blocked. Please check which connection from the remote laptop is blocked and let us know. 

     

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Niki Han Tuesday, October 18, 2011 3:10 AM
    • Unmarked as answer by j3gorman Friday, November 11, 2011 4:59 PM
    Tuesday, October 4, 2011 8:54 AM
  • Niki,

     

    Thank you for the suggestion. I hope to have the chance to set up a computer with auditing in place soon. I hope this yields some relevant information.

     

    JG

    Tuesday, October 18, 2011 4:46 PM
  • Hello, our IT department found a solution for our problem: turning off IPv6 at the server enabled file transfers and all other network traffic  to operate at normal rates of speed.

     

    Thanks again for your suggestions.

    • Marked as answer by j3gorman Friday, November 11, 2011 4:58 PM
    Friday, November 11, 2011 4:58 PM