none
Opening word perfect and adobe files RRS feed

  • Question

  • We recently just got our Search Server 2010 installed. I have the iFilters for adobe and word perfect installed and they seem to work. I can search them just fine, however when I go to open up a word perfect file on some computers it opens it up in the browser and won't allow you to edit and some computers it does not even open up word perfect at all. Adobe opens fine on all computers in the browser, is there a way to make it open up in either adobe acrobat or in adobe reader and is there a way to make .wpd open up in wordperfect?

    Thank you

    Thursday, November 14, 2013 8:48 PM

All replies

  • It's all about the MIME type. http://social.technet.microsoft.com/wiki/contents/articles/8073.sharepoint-browser-file-handling-deep-dive.aspx#Remove_an_existing_MIME_Type_from_the_Trusted_List_for_a_specific_Web_Application
    Thursday, November 14, 2013 8:57 PM
  • It sounds like a file association issue on the users computer (client machine).  Even though you're not double clicking, the computer is still trying to associate and application to open the file within.

    If you're using windows XP, try this: http://support.microsoft.com/kb/307859/en-us

    If you're using windows Vista, try this: http://windows.microsoft.com/en-US/windows-vista/Change-which-programs-Windows-uses-by-default

    If you're using windows 7, open control panel, search for File Association, and then make the changes

    http://windows.microsoft.com/en-us/windows/answers?tId=e3470b2d-385c-e011-8dfc-68b599b31bf5

    If the library is set to open the file in the browser, then please mark the post by Alex as the answer as it relates to MIME types.


    Stacy

    Thursday, November 14, 2013 9:27 PM
  • I added word perfect and pdf to the list, however it still opens them up in the browser.
    Thursday, November 14, 2013 9:41 PM
  • What do you mean by if they Library is set to open?

    Thanks

    Thursday, November 14, 2013 9:48 PM
  • In the advanced settings of the library there is a default setting that if is at the default will be selected to "Use the server default (Open in browser)"

    however; if it is set to "open in client application" then the file association of the user machine would define the issue.

    Open the library, then library tab, then advanced settings and look at the Opening Documents in the Browser section.

    This is how you can adjust all your sites with PowerShell.


    The following example sets the default open behavior for all documents in all sites to open in their associated client application (if available).


    $defaultOpenBehaviorFeatureId = $(Get-SPFeature -limit all | where {$_.displayname -eq “OpenInClient”}).Id

    Get-SPSite -limit ALL |foreach{ Enable-SPFeature $defaultOpenBehaviorFeatureId -url $_.URL }

    The following example sets the default open behavior for all documents in all sites to open in the browser.


    $defaultOpenBehaviorFeatureId = $(Get-SPFeature -limit all | where {$_.displayname -eq “OpenInClient”}).Id

    Get-SPSite -limit ALL |foreach{ Disable-SPFeature $defaultOpenBehaviorFeatureId -url $_.URL }


    Stacy

    Thursday, November 14, 2013 10:07 PM
  • This is the default setting. On those computers that doesn't open up word perfect, is word perfect installed?

    If you want it to open in the browser, make sure the default setting to open in browser is set,

    if you want it to open in the client application, you can change the default behavior or you can manually change each library.


    Stacy

    Thursday, November 14, 2013 10:46 PM
  • Word Perfect is installed on the computers. What library are you referring to?
    Friday, November 15, 2013 2:24 PM
  • Sorry, I thought you were talking about a SharePoint site, with a SharePoint Library, please accept my apology for wasting your time with these suggestions and let me know if it is related to SharePoint,  so I can delete these posts if it is not related, Thanks.

    Stacy

    Friday, November 15, 2013 3:36 PM
  • it's related to sharepoint but we only use the search server.

    Thanks

    Friday, November 15, 2013 8:45 PM
  • Ok, good luck in finding your answers, and wish I could've been more help

    take care,


    Stacy

    Sunday, November 17, 2013 12:58 PM