locked
Timeline - open issue, download deails always fails RRS feed

  • Question

  • In the ATA Console> Suspicious Activity/Open issues, when I choose 'Download Details', I get "issue name blah blah.xlsx couldn't be downloaded. Multiple browsers.(Screenshots below.)

     I saw a similar report in this thread,  where the moderator's response was:
    "Known bug, will be fixed for 1.9
    (The problem is triggered by specific data in that alert)"

    I don't know what the specific text trigger is, but I've been unable to download any details for any kind of alert. The same thing happens when I try to download anything from the Reports page.

    Is there any way to get the details/reports before the release of version 1.9?

    Thanks

    Friday, January 26, 2018 5:24 PM

Answers

  • Was this tested with IE?

    If yes, Can you try the download with the latest version of chrome?

    We had a similar case that can sometimes happen with IE (which we also fixed for 1.9 :-) )

    Also, looking in Exception Statistics is not enough,

    you need to look in Microsoft.Tri.Center-Errors.log at the end of the file a few seconds after the repro.

    Eli

    • Marked as answer by Diane_ Tuesday, January 30, 2018 9:55 PM
    Tuesday, January 30, 2018 8:23 PM

All replies

  • Please inspect the Center's log (like in the mentioned thread) and see if the exception you are getting is from a similar call stack. Paste it here so I can verify. it could be you are encountering a different issue.

    The Center log should have the answer...

    Repro the problem, and inspect the log a few seconds later to see which error it produced,

    even if it's different, paste it here..

    Eli

     
    Saturday, January 27, 2018 12:14 AM
  • Hi-

    I reproduced the problem, but the issue does not appear to correlate with any of the timestamped errors in the log files (that's the Microsoft.Tri.Center.log and the Microsoft.Tri.Center-ExceptionStatistics-20180124123127.log).

    Of the errors that I do see in the log files, they look like these:

    2018-01-30 16:43:38.6668 3224 218 37a9ccbc-fea9-4bfe-a0ab-9dca9bd7b56f Error [UniqueEntityController+<ListSearchUniqueEntitiesAsync>d__5] [message=WebApi action failed [ActionArguments={
      "request": null
    }]] System.ArgumentNullException: Value cannot be null.
    Parameter name: request
       at async Microsoft.Tri.Center.Management.Controllers.UniqueEntityController.ListSearchUniqueEntitiesAsync(?)
       at async System.Threading.Tasks.TaskHelpersExtensions.CastToObject[](?)
       at async System.Web.Http.Controllers.ApiControllerActionInvoker.InvokeActionAsyncCore(?)
       at async System.Web.Http.Controllers.ActionFilterResult.ExecuteAsync(?)
       at async System.Web.Http.Filters.AuthorizationFilterAttribute.ExecuteAuthorizationFilterAsyncCore(?)
       at async System.Web.Http.Filters.AuthorizationFilterAttribute.ExecuteAuthorizationFilterAsyncCore(?)
       at async System.Web.Http.Controllers.ExceptionFilterResult.ExecuteAsync(?)
    2018-01-30 16:43:38.7099 3224 111 bfc3eb06-db97-4487-86ed-028c908d2747 Error [UniqueEntityController+<ListSearchUniqueEntitiesAsync>d__5] [message=WebApi action failed [ActionArguments={
      "request": null
    }]] System.ArgumentNullException: Value cannot be null.
    Parameter name: request
       at async Microsoft.Tri.Center.Management.Controllers.UniqueEntityController.ListSearchUniqueEntitiesAsync(?)
       at async System.Threading.Tasks.TaskHelpersExtensions.CastToObject[](?)
       at async System.Web.Http.Controllers.ApiControllerActionInvoker.InvokeActionAsyncCore(?)
       at async System.Web.Http.Controllers.ActionFilterResult.ExecuteAsync(?)
       at async System.Web.Http.Filters.AuthorizationFilterAttribute.ExecuteAuthorizationFilterAsyncCore(?)
       at async System.Web.Http.Filters.AuthorizationFilterAttribute.ExecuteAuthorizationFilterAsyncCore(?)
       at async System.Web.Http.Controllers.ExceptionFilterResult.ExecuteAsync(?)

    Thank you for your help.

    Tuesday, January 30, 2018 5:11 PM
  • Was this tested with IE?

    If yes, Can you try the download with the latest version of chrome?

    We had a similar case that can sometimes happen with IE (which we also fixed for 1.9 :-) )

    Also, looking in Exception Statistics is not enough,

    you need to look in Microsoft.Tri.Center-Errors.log at the end of the file a few seconds after the repro.

    Eli

    • Marked as answer by Diane_ Tuesday, January 30, 2018 9:55 PM
    Tuesday, January 30, 2018 8:23 PM
  • I can download the details successfully using Chrome, so thank you for that.

    Additional info in case others experience the issue:

    The error did not show up in the Microsoft.Tri.Center.log, the Microsoft.Tri.Center-ExceptionStatistics or the Microsoft.Tri.Center-Errors.log.
    I'd tested it in dev on Chrome with version ATA 1.8 but not 1.8 update 1. The combination of version 1.8 update 1 and Chrome appear to be the winning combination.

    Thank you for your help, Eli.

    Tuesday, January 30, 2018 9:54 PM
  • Thanks for the feedback.

    I expect IE to work fine with this case in 1.9.

    Please let me know if after upgrading to 1.9 (when available) you still run into any issues with this.

    Eli

    Tuesday, January 30, 2018 10:04 PM
  • Thanks for the feedback.

    I expect IE to work fine with this case in 1.9.

    Please let me know if after upgrading to 1.9 (when available) you still run into any issues with this.

    Eli

    For those of us that can't install Chrome is there a workaround?

    If not, when will version 1.9 be released?

    Tuesday, March 13, 2018 4:41 PM
  • 1.9 bits are already in the "Release pipeline", I don't have a final date, but I am guessing it will be publicly available within days to very few weeks.

    For now, Can you try with Edge or Firefox?

    Tuesday, March 13, 2018 6:56 PM
  • I've downloaded and upgraded the ATA Center and all agents to v1.9 and unfortunately the issue still isn't resolved.

    I get the same problem when attempting to download event details and reports.

    Wednesday, April 4, 2018 6:29 PM
  • If possible, please open a case with CSS, it might be something new we are not familiar yet,

    and troubleshooting it might be easier when you have an assigned engineer on this.

    If not possible, let me know and we will do "best effort" using this forum.

    Wednesday, April 4, 2018 6:42 PM
  • If possible, please open a case with CSS, it might be something new we are not familiar yet,

    and troubleshooting it might be easier when you have an assigned engineer on this.

    If not possible, let me know and we will do "best effort" using this forum.

    Best effort is the option for now; CSS requires a credit card and I'm not sure I can get authorization to troubleshoot this using our Premier hours.
    • Edited by cyddavis Thursday, April 5, 2018 3:01 PM
    Wednesday, April 4, 2018 8:51 PM
  • Email me via atashare at microsoft com.

    mention a link to this post, I will reply back with instructions how to get more data.

    Eli.


    Thursday, April 5, 2018 8:03 PM
  • Email me via atashare at microsoft com.

    mention a link to this post, I will reply back with instructions how to get more data.

    Eli.


    Email sent.
    Monday, April 9, 2018 2:13 PM