none
Virtual Switch - required to switch choice of External network NIC from time to time

    Question

  • Environment:

    Host = Windows 10 1607 + latest windows updates

    Guest = Windows 10 1607, Windows 7 SP1

    From time to time we find that while our VMs can ping the host they will no longer connect to a share the host provides.  The Host can be rebooted and no change.  The VMs can be rebooted and no change.

    The workaround for this condition is to go into Hyper-V Manager to the External Network Switch that is defined and change the NIC currently selected (NIC #1) to another NIC (NIC #2) in the drop down for External Network choice, Apply, then change it right back to the NIC that it began with (NIC #1), Apply.  Now the VMs can connect to the share provided by the host.

    So to figure out the root problem I need to understand more.  When the above is done, is this essentially taking the Host's vEthernet adapter and putting it over NIC #2 and then we are moving it back to being over NIC #1?  If so what is being reinitialized?  Maybe this is the area that needs further comparison troubleshooting?


    May we all make money in the sequel.

    Friday, March 03, 2017 4:42 PM

All replies

  • Make sure that the physical NICs are not defined to be using any power management.  Power management on the NICs can disable the NIC assigned to a virtual switch, thereby disabling the virtual switch.

    . : | : . : | : . tim

    Saturday, March 04, 2017 1:24 PM
  • I'll definitely check that.

    May we all make money in the sequel.

    Monday, March 06, 2017 4:23 PM

  • Hi,
    Are there any updates?
    You could mark the reply as answer if it is helpful.
    Best Regards,
    Leo

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, March 16, 2017 7:16 AM
    Moderator
  • One update. The NIC did have power management enabled. This was disabled. However, the behavior is still the same.

    May we all make money in the sequel.

    Thursday, March 16, 2017 11:54 AM