locked
Remote Computer could not be found? RRS feed

  • Question

  • I have setup a Web Access RemoteApp server on Server 2008 R2 and it is no longer letting anyone connect to apps or use remote desktop from the outside.  If I try to run any apps or try to RDP from the Web Access site it tries to launch but then I get a "The Remote Computer could not be found" error.  It was working earlier today, I was able to launch applications from home but it now gives me that error.

    Setup is as follows:  All TS roles are installed on TSserver except the virtualization host since this is not a Hyper-V server.  All the consoles show no issues, I have everything pointing to TSserver.  I have an external site setup (remote.domain.com) and it is working.  I can get to the site fine, apps populate fine and overall there are no issues there.  If I go to the RemoteApp server internally I can launch applications and rdp without a problem.  It's just externally that they're not working.

    I admit I'm new to all these new TS roles and just started setting this all up.  But I can't figure out why this was working earlier today and now is not.  The only changes I made were a redirect for IIS (so that users only have to type in remote.domain.com instead of https://remote.domain.com/rdweb) and I installed a new application (though a co-worker said he started getting that error before I installed that program).

    What should I be looking at to resolve this?  The fact that it works internally and that I can get to the site externally makes me think it's some small setting I'm missing.  With so many different management consoles to look through it's a little difficult to pinpoint what's wrong. 

    Wednesday, March 31, 2010 9:11 PM

Answers

  • Ok, I got it.  It was the RD Gateway server setting.  I thought it needed to be the FQDN of the server.  I changed it to the external DNS name (remote.domain.com) and it's all working.

    Thanks for the help guys!  I'm sure all of these different RDS roles are great for larger farms, but man does it get a bit confusing for a small deployment.

     

    BTW, where are the settings to share credentials between the RD Gateway and RD server?  I want to turn that on because we're getting prompted to credential multiple times during web access.

    Thursday, April 1, 2010 2:10 PM
  • Hi,

    Simple sharing of credentials between RD Gateway and RDS server can be enabled by doing the following :

    1. On the RD Session Host server, open RemoteApp Manager. To open RemoteApp Manager, click Start, point to Administrative Tools, point to Remote Desktop Services, and then click RemoteApp Manager.
    2. In the Actions pane of RemoteApp Manager, click RD Gateway Settings. (Or, in the Overview pane, next to RD Gateway Settings, click Change.)
    3. Select the Use these RD Gateway server settings.
    4. In the Logon box, select the Ask for password (NTLM).
    5. Select the Use the same user credentials for RD Gateway and RD Session Host server check box.
    6. Click OK to close the RemoteApp Deployment Settings dialog box.

    If you want to enable web single sign on , please take a look at the following blog -

    http://blogs.msdn.com/rds/archive/2009/08/11/introducing-web-single-sign-on-for-remoteapp-and-desktop-connections.aspx

    Thanks,

    Kaustubh

    Saturday, April 3, 2010 9:35 AM

All replies

  • Hi,

    1) Try specifying the TS Gateway server manually (TS Gateway Settings > TS Gateway tab > Use these TS Gateway Server settings)

    2) If #1 won't help, try reverting changes in IIS and see if it helps.

     


    сила в справедливости
    Wednesday, March 31, 2010 9:39 PM
  • Kudrat:

    1) Did that, didn't make a difference.

    2) I have tried setting everything back in IIS but that has not made a difference.  I even thought I should go ahead and take the Remote Desktop role out and redo everything.  I did that and unfortunately the server remembered everything so all the settings were exactly the same as before.

    I should mention that I have port 80, 443 and 3389 open on the corporate firewall, which is forwarding the outside IP to the Web Access server (TSserver).  We checked the firewall logs and it doesn't look like it's blocking anything.

    I may end up just blowing this server away and starting over. 

    Wednesday, March 31, 2010 9:47 PM
  • Hi,

    Could you please try to connect to your TS Gateway from the internet using a standard RDP client. (in the RDP client you have to specify TS Gateway settings)

    Also try to connect to any internal resource through TS Gateway. (please show us the full text of the error, if any)

    Did you create any TS CAPs and RAPs?

    Also, please show the full text of the error which you are getting after pressing on the App in WebAccess.

     


    сила в справедливости
    Thursday, April 1, 2010 7:35 AM
  • Yes, from my home computer I can RDP into remote.domain.com and get into the TS Gateway without a problem.  I did create a TS CAP and TS RAP, they're set to allow all internal resources and currently the administrator account is the only one allowed (and is what I'm using for testing).

    The full text of the error is about the same as if you tried to RDP to a computer that's not on: RemoteApp disconnected: The remote computer could not be found.  Please contact your helpdesk about this error.

    My co-worker just said he was able to get in last night, but I just tried it and it's still not working.  This is making me think it's a firewall problem.  Can anyone confirm what ports need to be open on the firewall to allow RemoteApp to work properly?

    Thursday, April 1, 2010 11:06 AM
  • Hi Camride ,

    The remote web access just populates the remote app programs for you. When you click on one of the remote app programs, it is akin to connecting from a mstsc client from your local box. It is just that the connection settings are already specified in your remote app rdp file.

    Since you are able to make the connection via gateway through your local mstsc client , I think this could be an issue with your remote app rdp file settings.

    Please do the following things to troubleshoot:

    a) Turn off redirection in IIS ( although this should not cause a problem but we just want to be safe)

    b) Please re-verify your remote app settings ( especially RD Gateway server settings ) . Also turn off your shared credentials between RD Gateway and Remote Desktop Server. This will help us in getting more clarity as to where the error is exactly occuring - on the RDG or RDS.

    Thanks,

    Kaustubh

    Thursday, April 1, 2010 12:37 PM
  • Ok, I got it.  It was the RD Gateway server setting.  I thought it needed to be the FQDN of the server.  I changed it to the external DNS name (remote.domain.com) and it's all working.

    Thanks for the help guys!  I'm sure all of these different RDS roles are great for larger farms, but man does it get a bit confusing for a small deployment.

     

    BTW, where are the settings to share credentials between the RD Gateway and RD server?  I want to turn that on because we're getting prompted to credential multiple times during web access.

    Thursday, April 1, 2010 2:10 PM
  • Hi,

    Simple sharing of credentials between RD Gateway and RDS server can be enabled by doing the following :

    1. On the RD Session Host server, open RemoteApp Manager. To open RemoteApp Manager, click Start, point to Administrative Tools, point to Remote Desktop Services, and then click RemoteApp Manager.
    2. In the Actions pane of RemoteApp Manager, click RD Gateway Settings. (Or, in the Overview pane, next to RD Gateway Settings, click Change.)
    3. Select the Use these RD Gateway server settings.
    4. In the Logon box, select the Ask for password (NTLM).
    5. Select the Use the same user credentials for RD Gateway and RD Session Host server check box.
    6. Click OK to close the RemoteApp Deployment Settings dialog box.

    If you want to enable web single sign on , please take a look at the following blog -

    http://blogs.msdn.com/rds/archive/2009/08/11/introducing-web-single-sign-on-for-remoteapp-and-desktop-connections.aspx

    Thanks,

    Kaustubh

    Saturday, April 3, 2010 9:35 AM
  • Hi,

    1) Try specifying the TS Gateway server manually (TS Gateway Settings > TS Gateway tab > Use these TS Gateway Server settings)

    2) If #1 won't help, try reverting changes in IIS and see if it helps.

     


    сила в справедливости

    Hi Camride,

    In my first answer I asked you to check TS Gateway Settings :-) , sorry for not clarifying that you have to specify TS Gateway's external name.

     


    сила в справедливости
    Saturday, April 3, 2010 10:48 AM
  • Can you tell me where you found that setting exactly as I am still having the same issue.

     

    Thanks

    Wednesday, September 21, 2011 1:30 PM
  • hi

    I have a question, Is a domain controller necessary in this case or is the remote app useful in a LAN via workgroup ?

    Thursday, December 18, 2014 8:26 AM
  • same problem with Server 2012 R2. Thanks Camride, that led me right away to fix my issue as well.

    you can also add addresses in the Hosts file and it will fix the problem as well.

    Cheers!

    G-Edge


    G-EDGE

    • Proposed as answer by G-EDGE Monday, August 21, 2017 10:37 PM
    Monday, August 21, 2017 10:36 PM