none
Strange problem with RDP and mouse, only solved after minimize/maximize

    General discussion

  • Good day,

    We have this very annoying problem with a RDP Terminal Server. It is Windows Server 2008 R2 SP1.

    This server has the Session Host role installed, with local RDP user licenses.

    We only have this issue when running a certain application.

    This application is called Rockwell FactoryTalk View and this in an application to display industrial processes.

    It will take the Full Screen in a fixed resolution and will display buttons, objects, values... The application also uses Internet Explorer cache so I think it uses ActiveX, Flash or Java, I don't know.

    What sometimes happens is this:

    - The mouse point is able to move in the entire screen (good)

    - The mouse button will only work in 1 certain area of the screen (which is a small rectangle)

    - The mouse "hovering" above objects will also only highlight items that are in this rectangle

    - The keyboard remains functional and with alt-tab other objects or other applications can get focus, but still no mouse clicking

    The problem can be solved by:

    - Minimizing the RDP window and maximizing it again

    - Or: Sending a message to the session using task manager, after clicking "OK" on that message the problem is gone

    Normally, about 5 users will have this application opened in their session, the "crash" is only effecting 1 session.

    The problem seems to happen randomly and we don't know if we should point to the FactoryTalk application, or to Terminal Services/RDP. The end users have no rights to minimize/maximize, this is not the solution. 

    Is it possible to have any input on this please?

    Thank you.


    Wednesday, July 9, 2014 9:57 AM

All replies

  • Hi,

    Thank you for posting in Windows Server Forum.

    Firstly please check with the application support team whether the application is fully supported by Windows Server 2008 R2 in remote session. In addition, suggest you to update the client RDP version to RDP 8.1 and check the result for better feature and functionality. 

    Apart from this, there is Hotfix for the issue. Please download, install and check the result.
    Cause:
    The issue occurs because the remote desktop ActiveX object does not deactivate the focus of the remote desktop session when the focus is lost. Because the focus is still activated, the remote desktop ActiveX object cannot set the focus of the remote desktop session again when you change the focus back to the session.

    A remote desktop session does not respond to keyboard input or mouse input after it loses the focus in Windows 7 or in Windows Server 2008 R2
    http://support.microsoft.com/kb/2579381

    Hope it helps!

    Thanks.

    Dharmesh Solanki

    Thursday, July 10, 2014 7:25 AM
    Moderator
  • Thank you for your answer,

    All thin clients used (Wyse T10) are only RDP 7.1 compatible. I am not sure the hotfix describes the same issue as we have, but I will check it. Thank you.

    Thursday, July 10, 2014 8:04 AM
  • Hi,

    Any further update?

    Thanks.


    Dharmesh Solanki

    Monday, July 14, 2014 7:21 AM
    Moderator
  • Hi,

    No the problem still exists, even after installing the hotfix.

    The Human Interface screen only has a small box that can be clicked.

    Sending a message to the session will fix the problem.

    It seems a problem with focus.

    We are also contacting the application developers.

    Thursday, July 17, 2014 10:51 AM
  • Hi,

    Thanks for your comment.

    Have you find any solution from your application developer side?

    Thanks.

    Dharmesh Solanki

    Monday, July 21, 2014 2:04 AM
    Moderator
  • I have a similar issue and I solved it in a simple way. Perhaps it can give you some idea.

    My issue is when a logon form is closed, and a main form is opened after that with maximized windows state, the main form appeared normally, but cannot get focus or control or input.

    My solution is, in main form design, set the windows state as normal instead of maximized, and in Load event, set it to maximized. It worked on Terminal Server 2012.

    Wednesday, August 13, 2014 6:47 PM
  • I am having this problem with Factorytalk View installed locally, not on RDP.

    I am trying the solutions suggested at: http://www.plctalk.net/qanda/showthread.php?t=52218

    Thursday, October 9, 2014 10:08 PM