none
Loop detection

    Question

  • Hi

    We have a shared smtp namespace, where a thirdparty cloud service is responsible to route the emails to the correct location using routing tables.

    Therefore the accepted domain is set to non authoritative.

    Problem:
    There was an error in the routing table, and emails where sent to the wrong server. Because this server didn't know these addresses he sent them back to the cloud service. The cloud service, of course, used the wrong routing table and sent the emails back to the wrong exchange server  -->  Loop.

    After some attempts the exchange server detected the loop, and deferred the message. One day later the wrong routing table was corrected. Now all these mails are vanished and the sender didn't receive NDRs.

    1. question: What happened with these emails?

    Normally the cloud service detects mailloops and send NDRs after 7 retries. But it seems, that the exchange server detected it earlier, but because the domain is non authoritative, no NDRs were sent.

    2. question: Is it possible to configure the mailloop detection in Exchange?
    The goal is that Exchange detects a mailloops only after lets say 8 attempts, so that the cloud service can send NDRs.

    Regards
    Peter


    • Edited by PeterN22 Tuesday, June 28, 2016 9:04 AM
    Tuesday, June 28, 2016 9:02 AM

Answers

  • Thanks guys

    Yes we fixed it and routing is working again.

    The message tracking shows:
    EventID: DEFER
    SourceContext: LoopDetected

    After that the email was not routed back once again, it just disappeared.

    I would just like to prevent that from happening again. Of course having a correct routing table is the key ;)

    Regards
    Peter

    Tuesday, June 28, 2016 8:53 PM

All replies

  • Is it in the poison queue? What does message trace show? 

    I dont think the loop detection can be configured.


    Blog:    Twitter:   

    Tuesday, June 28, 2016 12:46 PM
  • Hello Peter , 

    As ANDY said and also as per my knowledge there is no settings for loop detection .I believe in your environment the shared domain namespace is in place and also it was set as internal relay , so on such case if we send mail to any of the unavailable SMTP address with that shared domain namespace will lead into message loops .which means exchange server will give the message to next hop via send connector as soon as the server in the next hop receives the message it will send that message back to the exchange server will lead into message loops.

    Also you need to check whether there is proper message routing path is configured for that shared domain namespace to deliver the mails.

    i believe you are talking about the values of the parameter MaxHopCount & MaxLocalHopCount in the receive connectors .But with these values we can control no of times a server can receive the same message .Please have a look in to the below mentioned link.

    Reference Link : 

    https://technet.microsoft.com/en-us/library/bb125140(v=exchg.160).aspx


    Thanks & Regards S.Nithyanandham

    Tuesday, June 28, 2016 1:49 PM
  • Hello Peter , 

    As ANDY said and also as per my knowledge there is no settings for loop detection .I believe in your environment the shared domain namespace is in place and also it was set as internal relay , so on such case if we send mail to any of the unavailable SMTP address with that shared domain namespace will lead into message loops .which means exchange server will give the message to next hop via send connector as soon as the server in the next hop receives the message it will send that message back to the exchange server will lead into message loops.

    Also you need to check whether there is proper message routing path is configured for that shared domain namespace to deliver the mails.

    i believe you are talking about the values of the parameter MaxHopCount & MaxLocalHopCount in the receive connectors .But with these values we can control no of times a server can receive the same message .Please have a look in to the below mentioned link.

    Reference Link : 

    https://technet.microsoft.com/en-us/library/bb125140(v=exchg.160).aspx


    Thanks & Regards S.Nithyanandham

    MaxHopCount is not the same thing as loop detection and the default in 60. You dont want to lower that. It sounds as if he did fix things and routing is working again.

    Blog:    Twitter:   


    Tuesday, June 28, 2016 2:16 PM
  • Thanks guys

    Yes we fixed it and routing is working again.

    The message tracking shows:
    EventID: DEFER
    SourceContext: LoopDetected

    After that the email was not routed back once again, it just disappeared.

    I would just like to prevent that from happening again. Of course having a correct routing table is the key ;)

    Regards
    Peter

    Tuesday, June 28, 2016 8:53 PM