locked
Access denied to removable devices like USB Memory and DVD ROM RRS feed

  • Question

  • I have been using my Acer TM8215WLMi with preinstalled Vista Ultimate for some time now. I have restored the OS 2 or 3 times so far due to intensive testing of applications for our business in order to figure out what is working and what is not working under Vista. Since my last restore I have not had any problems and I have been happy with Vista's performance. However, last week I discovered that I have lost access to my removable devices like the DVD burner, USB connected Hard Drives or USB Memory sticks. In the explorer there is a "forbidden sign" over the icon for the removable devices, and when I try to explore the devices I get a message saying "Access denied".

     

    I have tried to go back to a restore point before the problem started, but system restore fails because of an "unexpected error". This problem with the system restore was the reason for doing a complete reinstall of the PC the last times, but this time I would like to know how to regain access to the removable devices.

     

    Does anyone have any idea on how to regain access to the removable devices without doing a reinstall of the OS?

     

    Thanks in advance for your kind help.

     

    Best regards GAJohansen

    Sunday, July 8, 2007 7:37 PM

All replies

  • Hey GA, I had the same exact problem, with an acer machine. The problem is the acer empowering software that came with the machine. If you removed it, re-install it and unlock the drives using the software. If it is still installed re-install it.

    I have worked on this problem for over a month and tried a bunch of things to no aval.

    If you dont have the acer software you can re-download from there site @  acer.com

    Hope this did it!

     

    Monday, August 6, 2007 7:09 PM