none
Not able to set default Home page

    Question

  • Hello all,

    I have a task to update the intranet url as default home page. i followed the url

    http://serverfault.com/questions/588031/how-to-set-the-internet-explorer-home-page-via-gpo

    and configured the Group policy through preference and it is working absolutely fine, however when we reset the IE it goes back to msn webpage.

    Again i configured Start Page Redirect Cache to intranet page but still it goes back to msn after IE reset or else it is working correctly even restarting the client machine

    Can anyone help me here

    Aamir


    NA

    Saturday, July 30, 2016 2:22 AM

Answers


  • it is working fine, however when the user reset the IE from tool>internet options>advance> bottom page RESET.

    the setting disappers and msn home page comes up.

    Please advise

    How about blocking the whole 'Reset" button?

    • Computer Configuration > Administrative Templates > Windows Components > Internet Explorer > Internet Control Panel  > Advanced Page > Do not allow resetting Internet Explorer settings


    Mahdi Tehrani   |     |   www.mahditehrani.ir
    Please click on Propose As Answer or to mark this post as and helpful for other people.
    This posting is provided AS-IS with no warranties, and confers no rights.

    • Marked as answer by Masthanomatic Tuesday, August 2, 2016 2:18 PM
    Saturday, July 30, 2016 7:11 PM
  • Hi,
    According to the URL, I have reproduced the same issue with you in my lab envirorment, and referring to Mahdi suggestion, I have enabled the policy “Do not allow resetting Internet Explorer settings” and uncheck the setting “Apply Once and Do not Re-Apply” in GPO, then run gpupdate /force command to take effect GPO again. The reset function is greyed out and default page is back, user can change the home page at the same time. So we would suggest you have a try it, too. If you have any questions, please feel free to contact us.

    Regards,
    Wendy


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by Masthanomatic Tuesday, August 2, 2016 2:18 PM
    Tuesday, August 2, 2016 5:32 AM
    Moderator

All replies

  • Group Policy preferences will set the home page once, but allow it to be changed back by an IE reset or by the user changing the setting manually.  To set the page and disallow changes even by an IE reset, go to this link:

    https://social.technet.microsoft.com/Forums/en-US/20061e82-f857-4d38-a494-e8af18a5b51a/enforcing-an-ie-default-page-via-gpo?forum=winserverGP

    Here's the advice from that page:  

    1. Create a GPO and link it to a scope (Site, Domain or OU level not group) that contains all your specified user accounts.

    2. Edit the GPO: GPO name-->User Configuration-->Policies-->Administrative Templates-->Windows Components-->Internet Explorer-->Disable changing home page settings-->Enable-->Home Page: input your home page

    3. Logoff or restart user computer to apply this GPO


    Best Regards, Todd Heron | Active Directory Consultant

    Saturday, July 30, 2016 3:01 AM
  • Thanks Todd for the reply

    however this is not my requirement.

    I want user to change the home page, so i followed the GPP in the http://serverfault.com/questions/588031/how-to-set-the-internet-explorer-home-page-via-gpo

    it is working fine, however when the user reset the IE from tool>internet options>advance> bottom page RESET.

    the setting disappers and msn home page comes up.

    Please advise


    NA

    Saturday, July 30, 2016 3:20 AM

  • it is working fine, however when the user reset the IE from tool>internet options>advance> bottom page RESET.

    the setting disappers and msn home page comes up.

    Please advise

    How about blocking the whole 'Reset" button?

    • Computer Configuration > Administrative Templates > Windows Components > Internet Explorer > Internet Control Panel  > Advanced Page > Do not allow resetting Internet Explorer settings


    Mahdi Tehrani   |     |   www.mahditehrani.ir
    Please click on Propose As Answer or to mark this post as and helpful for other people.
    This posting is provided AS-IS with no warranties, and confers no rights.

    • Marked as answer by Masthanomatic Tuesday, August 2, 2016 2:18 PM
    Saturday, July 30, 2016 7:11 PM
  • Hi,
    According to the URL, I have reproduced the same issue with you in my lab envirorment, and referring to Mahdi suggestion, I have enabled the policy “Do not allow resetting Internet Explorer settings” and uncheck the setting “Apply Once and Do not Re-Apply” in GPO, then run gpupdate /force command to take effect GPO again. The reset function is greyed out and default page is back, user can change the home page at the same time. So we would suggest you have a try it, too. If you have any questions, please feel free to contact us.

    Regards,
    Wendy


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by Masthanomatic Tuesday, August 2, 2016 2:18 PM
    Tuesday, August 2, 2016 5:32 AM
    Moderator
  • hello

    I think this should fine, thanks


    NA

    Tuesday, August 2, 2016 2:18 PM