none
Virtual PC XP Mode Mouse Release

    Question

  • Hello,

    I am trying to use a program that requires automated use of the mouse in a virutal PC. In VMWare, I am able to release the mouse from the virtual window, minimize the screen, and continue to use the host pc running in the background. I am trying to do this in Windows Virtual PC, XP Mode with my new copy of 7 Ultimate.

    I have found people trying to undo this feature by using CTRL+ALT+LEFT ARROW. This does not enable it for me.

    Any suggestions would be great!

    Thanks,

    Niki
    Tuesday, December 15, 2009 5:19 PM

Answers

All replies

  • Virtual PC captures the mouse in the VPC window only when Integration Features are not present. By default, they are installed and enabled in XP Mode, which is another way of saying that CTRL+ALT+LEFT ARROW doesn't do anything. If you uninstalled Integration Features, then CTRL+ALT+LEFT ARROW would release a captured mouse cursor. A list of keyboard commands for Virtual PC is found here: http://blogs.technet.com/windows_vpc/archive/2009/11/04/tip-using-the-keyboard-to-access-useful-functionality-in-windows-virtual-pc.aspx

    It's not at all clear to me what you need to do, but perhaps you need to uninstall Integration Features. 
    Tuesday, December 15, 2009 6:42 PM
  • Thanks for your quick response. I'll try to be more specific as to what I'm trying to accomplish.

    I want to run a program that will take control of the mouse cursor, which makes the computer unusable while the program is running. I was hoping to be able to run this program in XP Mode so that I could minimize it and use my computer as normal, with the program running in the background.

    The only problem I have so far, is separating the VPC/XP Mode mouse from the host OS mouse.

    I would like to start the program, perform some key combination causing the two mouse cursors to "split" (which I thought might have been CTRL+ALT+LEFT ARROW) and use the host OS cursor to minimize the program, while the VPC cursor does its thing.

    Hopefully this helps.

    P.S. I disabled integration features, rebooted the VPC OS and restarted the VPC itself. The CTRL+ALT+LEFT ARROW didn't seem to do anything (the cursor was not locked into the window and could hover from host OS desktop over into VPC desktop and vice versa.)
    Tuesday, December 15, 2009 7:44 PM
  • Disabling the IC doesn't disable the mouse integration feature.  If you want to restrict the mouse inside the VM, you're probably going to have to uninstall the IC.
    Disabling the IC only disables certain parts of the IC: audio, clipboard, printer, smartcards, drives, etc.
    Tuesday, December 15, 2009 9:45 PM
  • right combination is "ALTGr + left Ctrl"
    • Proposed as answer by eric1312 Monday, August 27, 2012 9:38 PM
    Friday, December 02, 2011 3:37 AM
  • Just use the quick switch (CTRL + Tab) to select desktop from your open windows. (or anything that isnt VPC basically).

    • Proposed as answer by Joe Mangle Sunday, May 06, 2012 10:20 AM
    Sunday, May 06, 2012 10:20 AM
  • left alt
    • Proposed as answer by eric1312 Monday, August 27, 2012 9:36 PM
    Monday, August 27, 2012 9:30 PM
  • I have a similar problem. I get two mouse pointers inside the ap running in windows 7 64 bit virtual host xp mode, integration features off (crashes when turned on). The host mouse pointer does nothing in the ap, the ap pointer works fine.

    It would seem to me that this should be one of the options that can be turned off and on - turn the host pointer off - turn the host pointer on.

    I have hundreds of customers using these aps and I can't tell them to "ignore the host pointer"

    I have tried some of these "hot keys" but they don't do much. Alt down area turns the ap upside down!

    It seems to me that the first thing MS would do is make sure all of the old aps run on their new products - after all - these ARE there customers! They should not be last on the list.

    • Proposed as answer by Wolfbay Monday, December 24, 2012 6:52 PM
    Wednesday, November 28, 2012 1:07 AM
  • Suggest you keep your customers in XP - it is stable

    James Gunther

    Monday, December 24, 2012 6:53 PM
  • Yes it works for me-------altgr + ctrl
    Monday, January 13, 2014 8:42 PM
  • I just press on my keyboard the windows key.
    Monday, July 06, 2015 3:31 PM