none
How do we prevent random user profile from getting created locally on File Server (Windows 2016)

    Question

  • Hi,

    We have Server 2016 running DFSR.  I don't understand why random user profiles get created locally to the server.  We are not using roaming profile.  We use folder redirections for MyDocs, Desktop & Favorites.  How do we prevent this?

    Log Name:      Application

    Source:        Microsoft-Windows-Search-ProfileNotify

    Date:          6/7/2018 9:32:12 AM

    Event ID:      5

    Task Category: None

    Level:         Information

    Keywords:      Classic

    User:          N/A

    Computer:      SERVERNAME

    Description:

    Windows Search Service has created default configuration for new user 'DOMAIN\JSmith' .

    Event Xml:

    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">

      <System>

        <Provider Name="Microsoft-Windows-Search-ProfileNotify" Guid="{XX-769A-470E-BCF9-1B6555A118B123}" EventSourceName="Windows Search Service Profile Notification" />

        <EventID Qualifiers="16384">5</EventID>

        <Version>0</Version>

        <Level>4</Level>

        <Task>0</Task>

        <Opcode>0</Opcode>

        <Keywords>0x80000000000000</Keywords>

        <TimeCreated SystemTime="2018-06-07T16:32:12.292556600Z" />

        <EventRecordID>16682</EventRecordID>

        <Correlation />

        <Execution ProcessID="0" ThreadID="0" />

        <Channel>Application</Channel>

        <Computer>SERVERNAME.DOMAIN</Computer>

        <Security />

      </System>

      <EventData>

        <Data Name="User">DOMAIN\JSmith</Data>

        <Binary>

        </Binary>

      </EventData>

    </Event>


    Thursday, June 7, 2018 8:11 PM

All replies

  • Hi!

    You could use a Group policy to remove the local profile at logoff.

    Computer Configuration\Policies\Administrative Templates\System\User Profiles 

    Setting: Delete cached copies of roaming profiles

    Or you could use the following Group Policy:

    Computer Configuration\Policies\Administrative Templates\System\User Profiles 

    Setting: Prevent Roaming Profile changes from propagating to the server

    Best regards,
    Leon


    Blog: https://thesystemcenterblog.com  LinkedIn:   

    Thursday, June 7, 2018 9:05 PM
  • Thanks! I will check this out, apply it and confirm if this works...
    Monday, June 11, 2018 3:36 PM