locked
Win7 Compatibility Tab not functional; registry keys missing RRS feed

  • Question

  • Hi,

    On our Windows 7 builds, x86 SP1, the Compatibility mode tab is not functional. I can check off boxes indicating the mode I wish the program to run in, but after clicking Apply/OK and re-opening the properties, the checkmarks and settings are gone.

    I did some googling and found the registry entries associated with this, HKCU\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags. Apparently this tree is supposed to have a bunch of keys under it, including one named "Layers". However, none of these keys exist for me. There is a tree under HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags, but, again, no Layers directory which seems to be the one required.

    If I try to create the Layers key, I can create the "New Key #1", but when attempting to rename it to Layers I am getting an error "Error while renaming key". This occurs when I am logged on as the local administrator.

    Any ideas?

    Thursday, May 26, 2011 3:28 PM

Answers

  • Hi,

     

    I suggest enabling built-in administrator account and taking the ownership of the registry to check the result.

     

    1. Click Start -> right click computer-> Manage

    2. Double click Local Users and Groups -> Users

    3. In the middle pane, double click Administrator, clear the option for Account is disabled.

    4. Log off and log in with the Administrator account.

    5. Go to HKCU\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags

    6. Right click AppCompatFlags -> permission -> add your account into list with full control permission.

    7. Click Advance, select the option for Replace all child object permissions with inheritable permissions from this object.

     

    After that, try to edit the registry again. Also, I suggest you scan the computer with your security software.

     

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Niki Han Tuesday, June 7, 2011 2:10 AM
    Wednesday, June 1, 2011 9:20 AM

All replies

  • Hi,

     

    Have you selected the option for run this program as an administrator in compatibility tab?

     

    The issue could be related to permission. You could disable UAC and perform a Clean Boot to check the result. If the issue persists, I suggest create a new user account or modify the registry in Safe Mode for testing.

     

    Note: After checking my computer, I also cannot find the key Layers under AppCompatFlags, however, I can add this key without any problem.

     

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, May 30, 2011 9:35 AM
  • Turning off UAC or restarting in Safe Mode still does not allow me to add this key, and Compatibility settings still do not stick.

     

    Tuesday, May 31, 2011 1:40 PM
  • Hi,

     

    I suggest enabling built-in administrator account and taking the ownership of the registry to check the result.

     

    1. Click Start -> right click computer-> Manage

    2. Double click Local Users and Groups -> Users

    3. In the middle pane, double click Administrator, clear the option for Account is disabled.

    4. Log off and log in with the Administrator account.

    5. Go to HKCU\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags

    6. Right click AppCompatFlags -> permission -> add your account into list with full control permission.

    7. Click Advance, select the option for Replace all child object permissions with inheritable permissions from this object.

     

    After that, try to edit the registry again. Also, I suggest you scan the computer with your security software.

     

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Niki Han Tuesday, June 7, 2011 2:10 AM
    Wednesday, June 1, 2011 9:20 AM
  • I am having the exact same issue.  Let me know if you have had any success at getting this to work
    Monday, June 20, 2011 2:50 PM
  • Has anyone resolved this.  I am also facing this exact same issue.  Can add a new registry key and rename it to anything EXCEPT "Layers"

     

    • Proposed as answer by Niki Han Friday, January 20, 2012 10:29 AM
    Friday, December 16, 2011 1:02 PM
  • I had this too. Fixed it by uninstalling McAfee Host Data Loss Prevention.
    • Proposed as answer by Niki Han Friday, January 20, 2012 10:29 AM
    Tuesday, January 17, 2012 11:59 AM