locked
Very slow startup RRS feed

  • Question

  • We have 65 new HP Z230 workstations running Win7 Enterprise 64bit. When some of them startup, they display "Applying computer settings...." for 20 minutes before getting to the login screen. This is not consistent, it might be one or two machines in a lab of 21 machines.

    Originally thought it might be a computer group policy but even starting with the network cable unplugged can hang the machine on Applying computer settings

    Used Process Monitor Boot Logging and found one process that took 1193 seconds (nearly 20 minutes) and another that took 873 seconds (over 14 minutes) so it looks like one of these is the culprit.

    4:35:51.6114421 PM    svchost.exe    1072    NotifyChangeDirectory    C:\Windows\Tasks    SUCCESS    Filter: FILE_NOTIFY_CHANGE_FILE_NAME, FILE_NOTIFY_CHANGE_LAST_WRITE, FILE_NOTIFY_CHANGE_SECURITY    1193.4111221

    4:35:53.3855368 PM    svchost.exe    388    FileSystemControl    \\.\.\    SUCCESS    Control: CSC_FSCTL_OPERATION_QUERY_HANDLE    873.0890726

    I have been mucking around in the Process Monitor boot log for awhile and cannot figure out the root cause. Any ideas?

    Saturday, November 1, 2014 5:34 PM

Answers

  • Perform a clean boot and check the results : support.microsoft.com/kb/929135


    Arnav Sharma | http://arnavsharma.net/ Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Proposed as answer by arnavsharma Wednesday, November 5, 2014 5:49 AM
    • Marked as answer by arnavsharma Wednesday, November 12, 2014 11:50 PM
    Sunday, November 2, 2014 8:54 AM

All replies

  • Perform a clean boot and check the results : support.microsoft.com/kb/929135


    Arnav Sharma | http://arnavsharma.net/ Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Proposed as answer by arnavsharma Wednesday, November 5, 2014 5:49 AM
    • Marked as answer by arnavsharma Wednesday, November 12, 2014 11:50 PM
    Sunday, November 2, 2014 8:54 AM
  • The difficulty is this problem is not consistent. In a lab of 20 computers, when all are started in the morning, maybe 1-3 will show this behavior. The next day it might only be one and it will not be any of the ones from the day before. My guess is a clean boot would fix the issue but then I would still need to narrow down what service is causing the delay. I was hoping that Process Monitor Boot Log would allow me to figure out exactly what is causing the delay.
    Wednesday, November 5, 2014 11:15 AM
  • Any progress ?

    Arnav Sharma | http://arnavsharma.net/ Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, November 6, 2014 11:43 PM
  • We have made some progress on this. We did set every machine in one lab for a clean boot expecting this to work leaving us with the task of figuring out what Service or Startup item was causing this issue. Much to our surprise, the issue was still there.

    I thought the issue might be group policies so we set all machines in one lab not to get any Computer Group policies and all the machines came to a login screen very quickly. After a little work we found the group policy that when enabled makes some computer hang for 20 minutes before login screen appears

    Always wait for the network at computer startup and logon

    We have had this policy enabled for all computers for years. Somehow this policy was an issue only on HP Z230 workstations but why? We think it might be one of two things

    • Auto-negotiation between the Juniper switch and the nic - they should negotiate quickly to 1Gig and full duplex but perhaps this is hanging at time. We are going to hard code the ports on the Juniper switch to 1Gig and full duplex to see if that fixes the issue
    • The SATA emulation mode in the BIOS has three choices, IDE, AHCI, and RAID. These are set for RAID. RAID should work even though the only time you need it set this way is when you have more than one hard drive and take advantage of RAID. Perhaps changing them to AHCI might fix this issue

    I will report back when we have done more testing

    Dave

    Monday, November 24, 2014 3:06 PM